Failed install 6.0.RC1 extension pack

Postings relating to old VirtualBox pre-releases

Re: Failed install 6.0.RC1 extension pack

Postby frg » 11. Dec 2018, 15:06

Workaround for me: Run installer with Install as administrator.
frg
 
Posts: 74
Joined: 29. Sep 2013, 12:22

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 11. Dec 2018, 16:02

@frg
You're not having the same problem. Your problem is during installation, and the workaround is to install it as administrator, something that we advocate here in the forums for all VirtualBox versions, new and old.

The issue of the thread is that people can't run VirtualBox after it has successfully installed...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed install 6.0.RC1 extension pack

Postby frg » 11. Dec 2018, 16:28

I had the same problem with REGDB_E_CLASSNOTREG (0x80040154). Usually these kinds of problems where fixed with a repair install but this exposed the second problem in the screenshot which might be related. Afterwards I deinstalled and reinstalled as adminstrator and virtualbox now works for me. The REGDB_E_CLASSNOTREG error is fixed for me using this workaround.
frg
 
Posts: 74
Joined: 29. Sep 2013, 12:22

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 11. Dec 2018, 16:31

Ah, OK, I see. Thanks for the clarification @frg.
BTW, can the rest of the people that saw this can confirm/refute if they used the right-click on the installer, "Run As Administrator" option? I did on my two tests and I didn't see the issue. Maybe 'frg' has unlocked the mystery?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed install 6.0.RC1 extension pack

Postby rliegh » 11. Dec 2018, 23:16

I'm using Windows 10 Home edition,
version1803,
build 17134.407,
64 bit

I'm going to uninstall and then reinstall it with elevated priveleges (running the installer as Administrator). I'll post wether it works or not in my next post.
rliegh
 
Posts: 12
Joined: 16. Jun 2007, 10:52

Re: Failed install 6.0.RC1 extension pack

Postby rliegh » 11. Dec 2018, 23:28

When I right-clicked the installer and picked "Run As Administrator" it worked. Virtualbox RC1 starts normally and I was able to start virtual machines.

My previous installs I had simply installed as a normal user and then picked "yes" when it asked for my permission.

There is something odd I have noticed. I have a Linux VM that uses a USB 3 adapter. When I installed RC1 I wasn't asked if I wanted to upgrade the virtualbox extension pack. I'm not sure if that is because of a bug related to the installer, or if it is because I am reinstalling from scratch.

I assume it's because I'm reinstalling from scratch; but I'll keep watching this thread in case you want me to try anything else.
rliegh
 
Posts: 12
Joined: 16. Jun 2007, 10:52

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 11. Dec 2018, 23:31

@rliegh
Check the "Extensions" in the VirtualBox preferences. See if you have an older ExtPack installed. If so, remove the existing one and install the 6.0.0 RC1 ExtPack...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed install 6.0.RC1 extension pack

Postby rliegh » 11. Dec 2018, 23:37

@socratis nope, it doesn't show anything installed. I'll head over and grab the 6.0.0 RC1 version from downloads.

Thanks for your help!
rliegh
 
Posts: 12
Joined: 16. Jun 2007, 10:52

Re: Failed install 6.0.RC1 extension pack

Postby jrc55 » 12. Dec 2018, 02:51

It also works for me when I choose to "Run as administrator". I'll add that I only needed to do that once. Afterwards I can start it without needing that auth.

Also ... once it started I thought ... Great ... so I tried to install the extpack. It threw some error message .... but I did not capture it because I thought I'd see it again ... but it went ahead and installed after the error message. Kind of a bittersweet situation.

So I'm working. But I'll keep an eye open on this thread in case anyone needs some info from my machine.

Thanks,
JC
jrc55
 
Posts: 60
Joined: 7. Jan 2012, 20:36
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: winxp, fedora16

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 12. Dec 2018, 03:27

Good to hear. Two out of two. Now, as long as I can convince the developers to incorporate the following patch, we're back in business:
Code: Select all   Expand viewCollapse view
Index: src/VBox/Installer/win/Stub/VBoxStub.manifest
===================================================================
--- src/VBox/Installer/win/Stub/VBoxStub.manifest   (revision 76139)
+++ src/VBox/Installer/win/Stub/VBoxStub.manifest   (working copy)
@@ -7,6 +7,17 @@
     type="win32"
 />
 <description>VirtualBox Windows Installer</description>
+<!-- Identify the application security requirements. -->
+<trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">
+    <security>
+        <requestedPrivileges>
+            <requestedExecutionLevel
+                level="requireAdministrator"
+                uiAccess="false"
+            />
+        </requestedPrivileges>
+    </security>
+</trustInfo>
 <dependency>
     <dependentAssembly>
         <assemblyIdentity
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

6.0 RC1 - error after installation

Postby Graveen » 12. Dec 2018, 15:18

Hi,
My previous installation was VBox 6.0 Beta2. I installed RC1 got the error, desinstalled, rebooted, reinstalled and still got that error at startup. Tryed to start as Admin too, instead of user. I'm trying to run VBox 6.0 RC1 on Windows 10 x64 host.
Failed to acquire the VirtualBox COM object.

The application will now terminate.

Completely failed to instantiate CLSID_VirtualBox: REGDB_E_CLASSNOTREG.

Code d'erreur : REGDB_E_CLASSNOTREG (0x80040154)
Composant : VirtualBoxClientWrap
Interface : IVirtualBoxClient {d2937a8e-cb8d-4382-90ba-b7da78a74573}
Last edited by socratis on 12. Dec 2018, 15:21, edited 1 time in total.
Reason: Enclosed the information in [quote] tag for better readability
Graveen
 
Posts: 2
Joined: 25. Nov 2018, 13:07

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 12. Dec 2018, 15:24

@Graveen
I merged your post with the existing thread that was talking about the exact same thing.
  1. Please state your Win10-64 complete version and flavor. See the previous posts for examples.
  2. Try to install VirtualBox by right-clicking on the installer and Run-as-Administrator. See the previous posts for examples.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed install 6.0.RC1 extension pack

Postby Graveen » 12. Dec 2018, 15:28

Ok, as stated previously in this thread, i did a repair with elevated admin rights and it corrected the issue.
Thank you community !
Graveen
 
Posts: 2
Joined: 25. Nov 2018, 13:07

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 12. Dec 2018, 15:38

Graveen, I'm glad it worked, but you didn't answer the first part. Was this a Home/Pro/Enterprise/Other installation? And what was the complete Win10 version? You can get it by running "winver".
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed install 6.0.RC1 extension pack

Postby chrstphrchvz » 13. Dec 2018, 08:03

I encountered this same issue ("Failed to acquire VirtualBox COM object") after upgrading from 5.2.14 to 6.0.0 RC1 on Windows 10 1809 Home. Were the other reporters installing VirtualBox basically for the first time (as socratis did), or were they upgrading from an older version and had configuration leftover from earlier versions? I think that may be more relevant than trying to "Run as Administrator" (the installer already prompts for admin privileges when clicking "Install" at the "Ready to Install" step if it doesn't have them already).
chrstphrchvz
 
Posts: 4
Joined: 24. Jun 2016, 07:16

PreviousNext

Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 1 guest