Sound Problem With VirtualBox -5.2.x branch

Discussions related to using VirtualBox on Windows hosts.

Re: Sound Problem With VirtualBox -5.2.x branch

Postby ODesk » 17. Jul 2018, 02:48

JanDE wrote:
JanDE wrote:1. Audio is not in sync. The more audio you play, all the more the delay grows up.
2. Audio output skips or has short clicking noises, after a while.
3. Audio output is distorted. After a while audio is crackling for some minutes. Often it repairs itself, but after the next while this phenomenon occurs again.

The issues 2. and 3. are apparently gone if you downgrade to VB 5.1.30. But the issue 1. (audio out of sync) persists in VB 5.1.30. I checked it with a fully fresh installation of windows 10 64 Bit Host and a fresh Windows 7 64 Bit guest. If I downgrade the host VirtualBox to 5.0.40 the sync problems disappears on this new machine (like on my first configuration). The guest is still the same.


Issue 1 does not seem to affect XP guest in VB 5.1.30, which uses the AC'97 controller. Perhaps all these issues are affecting only the Intel HD?
ODesk
 
Posts: 9
Joined: 16. Nov 2014, 08:54

Re: Sound Problem With VirtualBox -5.2.x branch

Postby Tacoma » 24. Jul 2018, 17:05

Problem still present with version 5.2.16
Tacoma
 
Posts: 4
Joined: 22. Sep 2015, 23:25

Re: Sound Problem With VirtualBox -5.2.x branch

Postby Raster » 30. Jul 2018, 19:01

An update: the sound crackling persists with 5.2.16 r123759.

I attempted the fix proposed by BillGermany:
BillGermany wrote:I have a fix that works for my configuration! :-)
...
In the Linux client, add the following to /etc/modprobe.d/alsa-base.conf:
options snd-intel8x0 ac97_clock=44100

You'll need to restart your sound system (or reboot) before it takes effect.

It did not solve the issue. I'm playing Pandora through the guest and it slowed down the music enough to give everyone a deeper voice -- funny.
Raster
 
Posts: 5
Joined: 14. Mar 2014, 16:35

Re: Sound Problem With VirtualBox -5.2.x branch

Postby j0schi » 4. Aug 2018, 05:40

For me installing development revision 124007 fixed the crackling audio output problem (with ICH AC97 it is complete clean audio, with Intel HD Audio there is still some cracking sounds but is is more than useable.).e.
However even in this build the audio input seems far from working. I am new here and I don’t want to hijack the thread, but could the input issue somehow related? Any suggestions on this?
Could this ticket be related? Ticket: 17597
Last but not least here is an comparison what normal audio on nox player looks like (which also runs on Virtual Box) on the right side vs a recording of virtual box on the left side: see atachement


Host: Windows 10
Guest: Bliss (Android x86)
Proc: Ryzen 1600x

Can i provide any additional informations to help with this problem?

Kind regards
j0schi
Attachments
audioissue.JPG
screenshot
audioissue.JPG (38.25 KiB) Viewed 5490 times
j0schi
 
Posts: 1
Joined: 4. Aug 2018, 05:14

Re: Sound Problem With VirtualBox -5.2.x branch

Postby Air Force One » 8. Sep 2018, 20:50

I hope this is really good news for everybody. I just tested the new test build 124848, and on both of my test systems there are nearly no glitches at all. My Windows 10 guest and host combo works without any problems and Windows 7 guest on Windows 8 host got some small glitches after 4 minutes, but in less than a second everything was alright. One can clearly could say, that this is the best 5.2 release since RC and advise everybody to test it. I hope this would be persisted and reach the official build.
Air Force One
 
Posts: 44
Joined: 6. Oct 2017, 16:54

Re: Sound Problem With VirtualBox -5.2.x branch

Postby Air Force One » 10. Sep 2018, 08:48

Already found the first issue. In case of audio out switching on the host (I switch from speakers to the Bluetooth and back) the guest can’t do this properly. The guest’s playback continues to play the last milliseconds over and over again. If I stop and start it, sometimes twice, then output goes to the new destination. But in this case the audio buffer is sometimes not correctly initialized and our familiar cracking sound starts immediately. Because of this I have to stop and start the playback one or two times more, after that the crackling disappears.
Air Force One
 
Posts: 44
Joined: 6. Oct 2017, 16:54

Re: Sound Problem With VirtualBox -5.2.x branch

Postby rseiler » 17. Oct 2018, 18:58

I don't see anything in the 5.2.20 release notes about this. I also don't hear any difference in testing with Win10 guest, still very distorted.
rseiler
 
Posts: 157
Joined: 5. Feb 2009, 20:26

Re: Sound Problem With VirtualBox -5.2.x branch

Postby rseiler » 11. Nov 2018, 00:41

I don't see anything in the 5.2.22 release notes about this. I also don't hear any difference in testing with Win10 guest, still very distorted.
rseiler
 
Posts: 157
Joined: 5. Feb 2009, 20:26

Re: Sound Problem With VirtualBox -5.2.x branch

Postby Mike Z » 19. Nov 2018, 05:59

Just a quick note: I was having **VERY** bad distortion on my VBox output. This won't get rid of **ALL** the crackle, but it could help a lot. If you haven't tried this yet, try this:

[my setup]
Host PC: Win 10 Pro
Guest (Virtual) PC: Win 10 Pro
VM Audio Settings:
     Enable Audio: Checked (Yes)
     Host Audio Driver: Windows DirectSound
     Audio Controller: Intel HD Audio
     Enable Audio Output: Checked (Yes)
     Enable Audio Input: Unchecked (No)

[Possible Fix]
1. In the lower right hand corner of your Windows Taskbar (this *may* also work for Linux clients,) right click on the SPEAKER icon.
2a: Win 10: Click "Open Sound Settings," then, on the right click "Sound Control Panel."
2b: Win 7: Just click "Playback Devices"
3. Select your output device (speakers?) then click "Configure."
4. Select "Stereo" (I'm only using stereo speakers on my system. If your setup uses quad, 5.1, etc... speakers, try those too.)
5. Hit Test. Any better?

Your Guest OS (Windows, Linux, etc...) **MAY** have misinterpreted the number of channels you have available for your sound setup. This *might* fix it. (It fixed mine. [or at least made the audio A LOT better.])

Wishing U Luck -

- Mike
Mike Z
 
Posts: 2
Joined: 19. Nov 2018, 05:49

Re: Sound Problem With VirtualBox -5.2.x branch

Postby rseiler » 19. Nov 2018, 06:17

Good heavens, you're right, that works. My 1809 VM was on 5.1 somehow (apparently a default), but setting it on stereo fixed it right up.

I'm not sure what this means for the thread overall though. Whatever the case, this will do for the meantime.
rseiler
 
Posts: 157
Joined: 5. Feb 2009, 20:26

Re: Sound Problem With VirtualBox -5.2.x branch

Postby Mike Z » 20. Nov 2018, 09:54

Shucks! :) Happy to help.

Sincerely

Mike
(Out of work computer geek looking for work.)
Mike Z
 
Posts: 2
Joined: 19. Nov 2018, 05:49

Re: Sound Problem With VirtualBox -5.2.x branch

Postby pentagonik » 20. Nov 2018, 18:05

Yes, that's right -- Windows Build 1809 seems to take a 5.1 as default, which in turn makes the sound output distorted. Please manually set the guest's speaker setup to stereo (2) channels until we have a proper fix for that.
pentagonik
Oracle Corporation
 
Posts: 273
Joined: 19. May 2008, 16:09
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Too many to specify!

Re: Sound Problem With VirtualBox -5.2.x branch

Postby gcshum » 13. Dec 2018, 20:20

Audio delay is there with VBox 5.2.22 Windows 10 Pro host & Windows XP guest. Was not there with VBox 5.2.18.

Audio delay exists with Ubuntu 18.04 host and Windows XP guest, also under VBox 5.5.22.

Going back to 5.2.18.
gcshum
 
Posts: 4
Joined: 29. Oct 2008, 04:27

Re: Sound Problem With VirtualBox -5.2.x branch

Postby ODesk » 16. Dec 2018, 11:41

gcshum wrote:Audio delay is there with VBox 5.2.22 Windows 10 Pro host & Windows XP guest. Was not there with VBox 5.2.18.

I agree. Both 5.2.20 and 5.2.22 have a noticeable lag on XP guest (eg testing with Youtube vids). 5.2.18 is much better. Win 10 x64 host.
ODesk
 
Posts: 9
Joined: 16. Nov 2014, 08:54

Re: Sound Problem With VirtualBox -5.2.x branch

Postby croniccorey » 7. Jan 2019, 22:44

After alot of playing around with audio in my Debian 9.6 guest using the Intel HD Audio Driver (Windows 10 x64 host with VirtualBox 6.0) i was able to fix audio stutter/slowness, i hope this helps someone

edit "/etc/pulse/daemon.conf" to include the following lines and reboot the guest or restart pulse audio.

# VirtualBox Workaround
default-sample-rate = 48000
alternate-sample-rate = 44100
default-fragments = 2
default-fragment-size-msec = 55

edit:
Also if you have issues with youtube playback in mozilla install h264ify addon.
croniccorey
 
Posts: 1
Joined: 7. Jan 2019, 22:39

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Jacob Klein and 51 guests