Hardening acting (temporarily) weird after a host crash

Discussions related to using VirtualBox on Windows hosts.

Hardening acting (temporarily) weird after a host crash

Postby socratis » 22. Jun 2018, 13:26

I had a weird encounter with a hardening error, and I'm simply sharing my experience...
  • Host: Win7-64, SP1, latest updates, no 3rd party AV, no hardening errors. Never so far. New motherboard/CPU[1] was "transplanted", since the old one died a couple of weeks ago. RAM, GPU, HDs were left untouched.
  • VirtualBox: 5.2.12 r122591
  • Guest: Win7-64, SP1 (at the moment of the crash), any.
The host froze. I had to shut it down from the power button. After it came back up again, VirtualBox refused to start with a hardening error! I'm almost certain that it was due to "crypt32.dll". See the last 6 lines of the "VBoxHardening.log", I could upload the whole thing if needed:
7a8.460: supR3HardenedMonitor_LdrLoadDll: rejecting 'C:\Windows\system32\crypt32.dll' (C:\Windows\system32\crypt32.dll): rcNt=0xc0000190
7a8.460: supR3HardenedMonitor_LdrLoadDll: returns rcNt=0xc0000190 'C:\Windows\system32\crypt32.dll'
7a8.460: Fatal error:
7a8.460: Error loading 'crypt32.dll': 1790 [C:\Windows\system32\crypt32.dll]
9ec.b34: supR3HardNtChildWaitFor[2]: Quitting: ExitCode=0x1 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 1412 ms, the end);
7b8.8ac: supR3HardNtChildWaitFor[1]: Quitting: ExitCode=0x1 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 2062 ms, the end);

Now, and that's the weird part, I rebooted the host. I run a check on the HDs. And guess what? It worked! Nothing to report from 'chkdsk'. I'm just putting my experience here as a reference for when something (seemingly out of the blue) goes wrong, with no clear explanation. And then again out of the blue, it gets fixed!

The only "plausible" explanation that I heard from someone else, was that something "flipped", since this is a new motherboard/CPU with the older install of my host's HD. 'memtest' from a bootable CD was run a couple of times, no issues.

My explanation (if any), was that something was in the middle of an update, and I simply lost the host in the middle of the update. When things returned to normal, all order was restored.

[1]: I have the User Manuals for both motherboards if someone would like in depth information.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Site Moderator
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 22 guests