USB 3.0 flash drive captures inconsistently, runs at slow speeds when captured

Discussions about using Mac OS X guests (on Apple hardware) in VirtualBox.

USB 3.0 flash drive captures inconsistently, runs at slow speeds when captured

Postby pats » 6. Jun 2018, 19:36

I am running Mac OS High Sierra 10.13.2 with four Thunderbolt 3 ports; my VirtualBox is running using Windows 7, 64-bit Home Premium; VB version 5.2.12 r122591 (Qt5.63), 5.2.12 Guest Additions Packet, USB 3.0 Extensible Host Drivers loaded.

I've spent the last three days trying to get my USB Flashdrive (SanDisk Ultra USB 3.0) to capture in the Windows environment. It captured yesterday, but the drive was running so slow most of the files wouldn't load. Eventually, the connection would degrade. Tried a new flash drive this morning. The USB flash drive captured, I was able to navigate through files and load two JPEGs, but then the connection eventually slowed.

Watched a tutorial to check USB speed/compatibility and to perhaps change a setting in the Windows environment. (That's another rabbit hole). Realized, I think, that you can't run BIOS to check the USB setting, but Windows froze when I hit the delete key (still thinking then I could run BIOS) when loading and eventually had to run repairs, which it did successfully. Now, I am unable to get the USB drive to capture again.

Log is attached. Did my best to follow directions after going through steps 1-8 in USB 3.0 forum.

Thank you!
Attachments
Windiows 7-2018-06-06-09-40-02.log.zip
(25.29 KiB) Downloaded 40 times
Last edited by socratis on 6. Jun 2018, 19:44, edited 1 time in total.
Reason: Fixed formatting.
pats
 
Posts: 2
Joined: 6. Jun 2018, 18:58

Re: USB 3.0 flash drive captures inconsistently, runs at slow speeds when captured

Postby socratis » 6. Jun 2018, 21:24

pats wrote:Did my best to follow directions after going through steps 1-8 in USB 3.0 forum.
Are you referring to "USB basics and troubleshooting"? Because there are several pieces of information missing.

pats wrote:the drive was running so slow most of the files wouldn't load.
"Loading" a file is not usually how you measure speeds in hard/flash drives. You copy a file (usually a big one) from the USB device to somewhere in your VM.

pats wrote:Now, I am unable to get the USB drive to capture again.
How are you capturing the USB device? From the Devices menu or with a filter? Did you eject the flash from the host if not using the filter? What's the format of the USB drive? NTFS, FATxx, exFAT, something else?


With the USB device(s) plugged in and no VM running, open a Terminal. Type the command:

    VBoxBugReport "Windiows 7"
This will generate a "YYYY-MM-DD-hh-mm-ss-bugreport.tgz" file in the current directory (most probably your home directory). Attach that file in your response. See the "Upload attachment" tab below the reply form.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26934
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: USB 3.0 flash drive captures inconsistently, runs at slow speeds when captured

Postby pats » 6. Jun 2018, 22:14

- Yes, I was referring to USB Basics and troubleshooting. Sorry, I don't know where to locate build information.
Build for MacBook Pro is 17C88 (mac OS High Sierra 10.13.2)
Can't find Build Info for Windows
Windows 7 Home Premium
Copyright 2009
Processor: Intel(R) Core(TM) i5-6267u CPU @ 2.90 GHz

- I did not try to copy files. I was attempting to load a game file (Strat-o-matic Baseball) and the file would not load. I did not check speed by attempting to copy files.

- To capture the drive I was selecting DEVICES/USB/SansDisk Ultra [0100] ... the flash drive format is MS-DOS (FAT32)

- Requested VBoxBugReport attached.

Thank you.
Attachments
2018-06-06-20-08-24-bugreport.tgz
(116.78 KiB) Downloaded 44 times
pats
 
Posts: 2
Joined: 6. Jun 2018, 18:58

Re: USB 3.0 flash drive captures inconsistently, runs at slow speeds when captured

Postby socratis » 6. Jun 2018, 23:35

pats wrote:I was attempting to load a game file (Strat-o-matic Baseball) and the file would not load.
I'm afraid that can be due to a gazillion reasons. Please try with a simple file copy, a rather big file, more than 100 MB (at least).

pats wrote:To capture the drive I was selecting DEVICES/USB/SansDisk Ultra [0100]
That's fine, as long as you understand the differences between the two capturing methods. I don't think it's going to make a difference in any event.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26934
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Mac OS X Guests

Who is online

Users browsing this forum: No registered users and 8 guests