Video won't record (#17307)

Discussions related to using VirtualBox on Windows hosts.

Video won't record (#17307)

Postby ricecrispies » 10. Jan 2018, 03:57


[ModEdit; related ticket: #17307: Video capture doesn't work after upgrade from 5.1.30 to 5.2.0]

I am running a Windows 95 guest on Windows 10 host. I am trying to record video, but without success. When I choose view—>record-video the first time I get an error saying that video recording cannot be started. The second time I select it, I get the film rolling animation at the bottom of the guest's window, but the size of the output movie file remains at between 0 and 270 bytes. And the same thing happens when I choose view—>record-video to stop the recording. The first time, I get an error saying that recording could not be stopped. The second time, the film rolling animation stops. How can I get video recording to work?
Last edited by socratis on 10. Jan 2018, 13:09, edited 1 time in total.
Reason: Added ticket related information.
ricecrispies
 
Posts: 14
Joined: 7. Jan 2018, 23:52
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: A recent version of Ubuntu and, as I write this, trying to get Windows 95 running properly

Re: Video won't record

Postby mpack » 10. Jan 2018, 10:44

This is not a feature that I use, nor is it well documented. It may be that it requires the Guest Additions, which of course do not exist for Win9x guests. If you have screen recording software for the host then you should be able to capture guest graphics that way.
mpack
Site Moderator
 
Posts: 30055
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Video won't record

Postby michaln » 10. Jan 2018, 12:54

It does not require GAs. It's just... not working great. Opening a ticket with actual details might be helpful.
michaln
Oracle Corporation
 
Posts: 2962
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: Video won't record

Postby socratis » 10. Jan 2018, 13:00

michaln wrote:Opening a ticket with actual details might be helpful.
I've been meaning to do that since before the holidays. A quick summary can be found in: viewtopic.php?f=6&t=85660 but I will definitely open a new ticket. Tonight...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27377
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Video won't record

Postby socratis » 10. Jan 2018, 13:06

I just checked, the OP in the other thread actually opened a ticket, "#17307: Video capture doesn't work after upgrade from 5.1.30 to 5.2.0". I'll update the ticket with my findings, and have this discussion (and the other one) pointing to the ticket, and vice versa.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27377
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Video won't record (#17307)

Postby ricecrispies » 10. Jan 2018, 13:56

Thank you.
ricecrispies
 
Posts: 14
Joined: 7. Jan 2018, 23:52
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: A recent version of Ubuntu and, as I write this, trying to get Windows 95 running properly

Re: Video won't record (#17307)

Postby socratis » 2. Mar 2018, 00:39

The issue has been fixed with 5.2.9 r121058 (or later) from the test builds. Please verify or deny if it works or not in ticket #17307.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27377
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot], PureGreen and 58 guests