Chrome browser in Win7 guest crashes VM

Discussions related to using VirtualBox on Mac OS X hosts.

Re: Chrome browser in Win7 guest crashes VM

Postby Ashton » 13. Jul 2014, 10:07

meowsqueak wrote:Fellow forum user Danthemanintan kindly sent me this to try:

Start Google Chrome then click the button in the upper right hand corner that is marked with three horizontal bars. Choose Settings, scroll to the bottom. Choose advanced settings, scroll down to System and uncheck "Use hardware acceleration when available". Close Google Chrome and reopen it.


I'm happy to say that this seems to have successfully worked around the problem I reported. I still had the original issue even with the latest version of VirtualBox, so this makes Chrome usable again. Thanks Danthemanintan!


Had the exact same issue (except it was a W7Pro VM under Mint (Debian) Linux. This fixed the problem for me too, thanks!
Ashton
 
Posts: 2
Joined: 13. Jul 2014, 10:05

Re: Chrome browser in Win7 guest crashes VM

Postby loukingjr » 13. Jul 2014, 11:43

Well, I've tried and tried for over a year and still can't get Chrome to crash on my Windows 7 Pro guest with hardware acceleration enabled.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Chrome browser in Win7 guest crashes VM

Postby V1rtualUser » 18. Jun 2016, 16:20

Recently I started having this problem with my Windows 10 installation on Ubuntu 14.04 and VirtualBox 5.0.22. I never had this problem before neither with Windows 7 nor with 10, and I am using VirtualBox for a while now.
Anyway, wanted to say, deactivating the hardware acceleration has helped. Thanks.
V1rtualUser
 
Posts: 4
Joined: 11. Oct 2011, 12:48
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 7 64 bit, OpenBSD, Linux

Re: Chrome browser in Win7 guest crashes VM

Postby winonlin » 4. May 2017, 11:39

Different setup, same problem, same solution here.

Issue: Extreme flickering in Chrome when using 3D support
Host: Fedora 25
Guest: Windows 7
VirtualBox version: 5.1.22 r115126 (Qt5.7.1)
Chrome version: 57.0.2987.133
Workaround: Disable hardware acceleration in Chrome.

Thanks for the suggestion!
winonlin
 
Posts: 1
Joined: 4. May 2017, 11:36

Re: Chrome browser in Win7 guest crashes VM

Postby DaerJohannes » 30. Jul 2021, 07:55

For the record: A similar problem still exists today (end of July 2021) here, with the following setup:

  • Host: Up-to-date Windows 10 on an AMD Threadripper system (AMD X399 chipset, AMD Threadripper 1950X)
  • VM: Up-to-date Windows 10
  • Virtualbox: Latest version 6.1.24 r145767 (Qt5.6.2)

When hardware acceleration is activated for Chrome in the VM, e.g. Google Maps does not work properly. When you choose a location, Google Maps does not relocate the map to the according place, and there are errors ocurring: "We're sorry, but an error has occurred. Please reload the page."

Only when disabling the hardware acceleration in Chrome's settings, Google Maps is working without any problems again.

Luckily, Chrome offers an option to disable the usage of hardware acceleration, but I wonder if there might be other applications that insist on using hardware acceleration, which then would lead to unresolvable problems.
DaerJohannes
 
Posts: 1
Joined: 30. Jul 2021, 07:42

Previous

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Wilburx3 and 29 guests