Resolution not scaling with rdesktop to RDP-server of vbox

Discussions related to using VirtualBox on Linux hosts.

Resolution not scaling with rdesktop to RDP-server of vbox

Postby markba » 23. Sep 2008, 20:31

I'm connecting with rdesktop through the builtin RDP-server in VirtualBox to a Windows session. Although this succeeds, the client-side resolution can *not* be controlled by the rdp-client (rdesktop) through several commandline options. The actual resolution is the resolution on the server it self (this is the same if the session is displayed locally by the vbox manager). The only way to control the client-side resolution is to change the resolution in the session it self (right click on Desktop, Properties, etc.).

Normally RDP should work like this: the client requests for a certain screen resolution (fullscreen or defined width/height), the RDP-server responds by actually change the resoluton server-side. It seems that my problem has to do with the fact that the vbox RDP-server does not respond to the requested resolution by the client.

The following combinations were tried:
1. Ubuntu/rdesktop -> vbox RDP-server: no resolution scaling
2. Ubuntu/tsclient -> vbox RDP-server: no resolution scaling
3. Windows/mstsc -> vbox RDP-server: resolution scaling works
4. Ubuntu/rdesktop -> Windowx XP RDP-server: resolution scaling works

At first, I was thinking it was a RDP-client problem, because both rdesktop and tsclient (combinations 1+2) did not do the resolution scaling. This seems to be confirmed when I connected with MS Terminal Server Client (standard RDP-client in Windows) from a Windows XP installation to the vbox RDP-server (combination 3): that client did change the client resolution.

Thinking it was clearly a client problem, I then did combination 4, rdesktop to a Windows XP RDP-server and rdesktop is actually capable of resolution scaling, because it worked (unexpected though).

My conclusion so far: it seems like *only* the specific combination from rdesktop/tsclient to vbox RDP-server does not do resolution scaling, all other combinations work (tried also gnome-rdp client, but as this is using rdesktop on the background, it gives the same result).

This is the error/warning when I try to connect from rdesktop to vbox RDP-server:

Code: Select all   Expand viewCollapse view
user@lin12:~$ rdesktop 192.168.0.101:3390 -g 1024x700
WARNING: Remote desktop changed from 1024x700 to 800x600.


It's obvious it's changing the defined resolution (1024x700) to the resolution server side (800x600). When I connect with rdesktop to a Windows RDP-server, such a warning does *not* popup.

Does anybody have a clue why rdesktop is not able to change to resolution of the vbox RDP-server session?

I've posted this also on http://ubuntuforums.org/showthread.php?p=5814779 but so far, no reaction.
markba
 
Posts: 99
Joined: 1. Oct 2007, 23:50
Location: The Netherlands

Postby Murz » 6. Oct 2008, 12:49

I have the same problem and can't found at now any method to solve this :(
Murz
 
Posts: 16
Joined: 20. Aug 2008, 13:36

Postby markba » 6. Oct 2008, 12:59

That makes at least two of us with the same problem :(
Just waiting if someone passes who has a solution...
VBoxTool: VirtualBox automation tools http://vboxtool.sourceforge.net/
markba
 
Posts: 99
Joined: 1. Oct 2007, 23:50
Location: The Netherlands

Give a try

Postby midnightsun » 26. Dec 2008, 23:43

Hi Guys!

Give a try to set the resolution of the VM manually by typing

Code: Select all   Expand viewCollapse view
 VBoxManage setextradata global GUI/MaxGuestResolution <horizontal size>,<vertical size>


Then start the VM with VBoxHeadless -startvm, or VBoxManage startvm.
Worked for me either ways.
There was some tricks under XP (Guest). I had to click a checkbox saying "auto scale resolution", or something like this. Sorry that I don't remember perfectly.
Please give a try!
midnightsun
 
Posts: 6
Joined: 26. Dec 2008, 23:33

Postby baf » 27. Dec 2008, 00:13

VBoxManage controlvm <uuid>|<name> setvideomodehint <xres> <yres> <bpp> [display]

VBoxManage controlvm "Machine" setvideomodehint 900 400 16
Or something like that should do it.

The way midnightsun suggested sets the max resolution for all VM:s and that might not be what you want.
baf
Volunteer
 
Posts: 829
Joined: 27. Sep 2008, 06:18
Location: Luleå or Skellefteå, Sweden
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: linux,xp,win7

Postby midnightsun » 27. Dec 2008, 00:24

One always learns something!

Thanks!
midnightsun
 
Posts: 6
Joined: 26. Dec 2008, 23:33

Postby baf » 27. Dec 2008, 00:32

Well some say "You learn as long as you live"
My motto is "You live as long as you learn"

Also helping/teaching others is the best way to learn it yourself.
baf
Volunteer
 
Posts: 829
Joined: 27. Sep 2008, 06:18
Location: Luleå or Skellefteå, Sweden
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: linux,xp,win7

Postby midnightsun » 27. Dec 2008, 01:13

So be it! :D
midnightsun
 
Posts: 6
Joined: 26. Dec 2008, 23:33

screen resolution for windows XP guest

Postby gnovel » 2. Jan 2009, 13:10

hello,
Please, Can you give me some detail about command line i have to write for 1280x800 resolution screen?
I try that baf say but it don't work
gnovel
 
Posts: 3
Joined: 2. Jan 2009, 13:03

Postby midnightsun » 2. Jan 2009, 20:26

As the dear Colleague mentioned above:

Code: Select all   Expand viewCollapse view
VBoxManage controlvm "Machinename" setvideomodehint 1280 800 16


This should do it.
After this I start the box with command line also.

Code: Select all   Expand viewCollapse view
VBoxmanage startvm Machinename


This works for me.
midnightsun
 
Posts: 6
Joined: 26. Dec 2008, 23:33

screen resolution for windows XP guest

Postby gnovel » 3. Jan 2009, 13:39

Hello,
thanks for you help, but it's don't work for me!
I can have 1280x800 screen resolution when i delete video card driver in windows XP manager.
But I will not use virtualbox because i can't install games.(I'll try cedega or wine or play on linux)
Thanks for all
gnovel
 
Posts: 3
Joined: 2. Jan 2009, 13:03

Postby midnightsun » 3. Jan 2009, 13:53

I don't know much about games, but be sure to install VirtualBox Guest Additions before You give up! I think maybe it helps. (Just a guess...)

Good luck!
midnightsun
 
Posts: 6
Joined: 26. Dec 2008, 23:33

screen resolution for windows XP guest

Postby gnovel » 3. Jan 2009, 21:31

Hello,
Guest additions is install but it's graphic driver don't give my screen resolution. Then i have suppress only graphic device and windows XP seems to be use is default driver and i have my 1280x800 screen resolution's.
Be sure that i try all that i find on web (and the virtualbox help -in english and I'm french) but this solution give me that i want. I hope I'll have no trouble with this way and can install another software.
Thanks
gnovel
 
Posts: 3
Joined: 2. Jan 2009, 13:03

Postby midnightsun » 3. Jan 2009, 21:39

Hope the best... :-)
midnightsun
 
Posts: 6
Joined: 26. Dec 2008, 23:33

VBoxManage can't be run unless VirtualBox is already running

Postby erosay » 13. Jan 2009, 22:09

VBoxManage controlvm LMCOXP setvideomodehint 1580 980 16
VirtualBox Command Line Management Interface Version 2.1.0
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

[!] FAILED calling virtualBox->OpenExistingSession (session, uuid) at line 2807!
[!] Primary RC = VBOX_E_INVALID_SESSION_STATE (0x80BB000B) - Current session state prohibits operation
[!] Full error info present: true , basic error info present: true
[!] Result Code = VBOX_E_INVALID_SESSION_STATE (0x80BB000B) - Current session state prohibits operation
[!] Text = The machine 'LMCOXP' does not have an open session
[!] Component = Machine, Interface: IMachine, {ea6fb7ea-1993-4642-b113-f29eb39e0df0}
[!] Callee = IVirtualBox, {339abca2-f47a-4302-87f5-7bc324e6bbde}

So I started it:
nohup VBoxHeadless -s LMCOXP &

I then ran:
VBoxManage controlvm LMCOXP setvideomodehint 1580 980 16
VirtualBox Command Line Management Interface Version 2.1.0
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

(gotta love the strong silent type)

and I still get:
rdesktop -a 16 -g 1500x980 -0 LMCOXP
Autoselected keyboard map en-us
WARNING: Remote desktop changed from 1500x980 to 1280x960.

Any other ideas on how to get this to work properly?

E
erosay
 
Posts: 8
Joined: 30. Sep 2008, 11:43

Next

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 34 guests