[solved] VT-x enabled in BIOS, yet no 64bit for guest hosts

Discussions related to using VirtualBox on Linux hosts.

[solved] VT-x enabled in BIOS, yet no 64bit for guest hosts

Postby Stiopa » 5. Jan 2017, 01:42

VT-x enabled in BIOS, yet there is no 64bit for guest hosts available. What way am I supposed to trace what is messing the OS layer?

I am aware of this:
Code: Select all   Expand viewCollapse view
viewtopic.php?f=1&t=62339


And checked threads such as:
Code: Select all   Expand viewCollapse view
viewtopic.php?f=10&t=38676


The settings in BIOS as in the attached photo.

lscpu:
Code: Select all   Expand viewCollapse view
rchitecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Model name:            Intel(R) Core(TM)2 Duo CPU     L7100  @ 1.20GHz
Stepping:              11
CPU MHz:               1200.000
CPU max MHz:           1201.0000
CPU min MHz:           800.0000
BogoMIPS:              2394.00
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              4096K
NUMA node0 CPU(s):     0,1
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf eagerfpu pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm tpr_shadow vnmi flexpriority dtherm ida


System info:
Linux merom 4.8.0-2-amd64 #1 SMP Debian 4.8.11-1 (2016-12-02) x86_64 GNU/Linux
stretch/sid
Code: Select all   Expand viewCollapse view
lsmod | grep vb
vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  0
vboxdrv               454656  3 vboxnetadp,vboxnetflt,vboxpci


VirtualBox version:
5.1.12-112440~Debian~stretch
Attachments
vtx_bios.jpg
vt-x bios settings enabled
vtx_bios.jpg (30.47 KiB) Viewed 1177 times
Last edited by Stiopa on 5. Jan 2017, 09:48, edited 1 time in total.
Stiopa
 
Posts: 2
Joined: 5. Jan 2017, 01:09

Re: VT-x enabled in BIOS, yet no 64bit for guest hosts

Postby BelJoost » 5. Jan 2017, 03:28

Weird. Should be working fine.

I came across the following two suggestions:
You haven't tried KVM, VMware or other virtualization software which perhaps is not removed completely?
You might need to enable/disable other bios settings, like "Trusted Execution"?
BelJoost
 
Posts: 37
Joined: 12. Nov 2016, 18:35

Re: VT-x enabled in BIOS, yet no 64bit for guest hosts

Postby Stiopa » 5. Jan 2017, 09:27

Thanks!

I set Memory Protection/Execution Prevention to Disabled and 64 bit option became visible.

Thanks a lot again for this hint.
Stiopa
 
Posts: 2
Joined: 5. Jan 2017, 01:09


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 11 guests