Microphone doesn't work after upgrade to 5.1

Discussions related to using VirtualBox on Linux hosts.

Microphone doesn't work after upgrade to 5.1

Postby GeneCash » 21. Jul 2016, 23:43

I'm running a Windows 7 guest in Debian Stretch/Testing. I'm Svs-V init instead of systemd. I'm using ALSA with Intel HD sound on the real motherboard.

I use it for VoIP mainly. I just upgraded from 5.0 to 5.1 and the microphone stopped working.

If you go to control panel -> sound -> recording tab, there's a "microphone" device with a green vertical VU bar next to it. In 5.0, this bounces up and down to reflect input from the microphone. In 5.1, this no longer has any activity.

I've tried both the front and rear jacks, and making sure that everything looks to be proper in alsamixer. I use the "Intel HD Audio" emulation, but I've also tried "ICH AC97" and installed the proper Windows 7 driver. I've tried the PIIX3 and ICH9 chipsets.

I tried using Pulseaudio. I switched to that in the VM audio settings and ran the Pulseaudio server. I got sound, but when I opened control panel -> sound -> recording, the VM instantly aborted and I got
kernel: threaded-ml[21934]: segfault at 5e16ef008 ip 00007f1922d9d4e0 sp 00007f192150ecf0 error 4 in libpulse.so.0.20.0[7f1922d78000+50000]
in the system logs.

If I downgrade back to 5.0, the microphone works again, on the same VM.

I've done a lot of Google searches and I appear to pretty much the only one having this problem.

Any suggestions? Any ideas what to try? I tried 5.1.2 today and no luck.
GeneCash
 
Posts: 7
Joined: 16. May 2015, 00:13

Re: Microphone doesn't work after upgrade to 5.1

Postby Raumis » 22. Jul 2016, 15:55

Just thought I would let you know you are not alone. I tried to reinstall the audio drivers on the Windows 7 guest and nothing seemed to work.
Raumis
 
Posts: 1
Joined: 22. Jul 2016, 15:51

Re: Microphone doesn't work after upgrade to 5.1

Postby michaln » 22. Jul 2016, 20:17

Please attach VBox.log files. Without that, expect no fix.
michaln
Oracle Corporation
 
Posts: 2670
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: Microphone doesn't work after upgrade to 5.1

Postby GeneCash » 22. Jul 2016, 22:47

Yep, logs are very necessary. Sorry about that.
Attachments
VBox.log.gz
Log from vbox 5.1.2
(30.51 KiB) Downloaded 25 times
GeneCash
 
Posts: 7
Joined: 16. May 2015, 00:13

Re: Microphone doesn't work after upgrade to 5.1

Postby TimThein » 26. Jul 2016, 03:09

I'm experiencing the same issue. Recording device in guest OS, Windows 10 Pro & Enterprise, both 64-bit, does not receive any audio from host default microphone, using 5.1.2.
Because of this, I needed to revert back to 5.0.26.
Attachments
VBox.zip
(85.67 KiB) Downloaded 12 times
TimThein
 
Posts: 10
Joined: 30. Sep 2015, 23:15

Re: Microphone doesn't work after upgrade to 5.1

Postby gideong » 26. Jul 2016, 06:36

I am also expreiencing the same issue with 5.1.2. I am using a Linux host and using Windows 10 as a VM. Mic input is also not working for me. I have attached my VBox.log file for this. Mic support is important for me as I need to use a communication app that is Windows based and is not yet available for Linux.

I have also noticed that audio input on 5.1.0 is a bit weird. On 5.1.0 I noticed that mic input from the host machine was being picked up by the CD audio input from the Windows 10 guest VM. Of course that completely went away on 5.1.2.

Just to make sure it is not a Windows issue I made a clean install of Windows 10 on a new VM on VBox 5.1.2. To my surprise it didn't seem to detect any audio input devices at all.
Attachments
VBox.log.gz
(28.81 KiB) Downloaded 7 times
gideong
 
Posts: 3
Joined: 26. Jul 2016, 06:11

Re: Microphone doesn't work after upgrade to 5.1

Postby RogerB99 » 26. Jul 2016, 12:45

Hi
I'm Also experiencing the same issue:
- Host: VirtualBox 5.1.2 r108956 on Linux Mint 17.2 64-bit (Cinnamon)
- Guest: Windows 8.1
Microphone works fine in host; but it appears no input is received in the guest.
It was definitely working in VirtualBox versions 5.0.20; 5.0.22 and 5.0.24.
I'm not certain if the problem was present in 5.0.26.
Since upgrading to 5.1.2 the problem is definitely present.

VirtualBox.log file attached:
Win81_64-2016-07-26-11-12-35.log
(78.72 KiB) Downloaded 19 times


Any suggestions greatly appreciated; will have to downgrade in the meantime as I regularly need to use a Windows-based collaboration app.

Many thanks
Roger
RogerB99
 
Posts: 1
Joined: 26. Jul 2016, 12:20

Re: Microphone doesn't work after upgrade to 5.1

Postby matthewls » 27. Jul 2016, 00:12

I'm glad to see this thread, though I'm not sure the data will be helpful.
As above, audio in and output work fine in the host. Both work well in official 5.0 releases including 5.0.26, and worked in 5.1.1. But audio in does NOT work in 5.0 or 5.1 test builds. This has been a consistent issue since I started using VBox last year, and though I find it a minor annoyance, maybe there's a hint for the developers.
matthewls
 
Posts: 10
Joined: 20. Oct 2015, 07:23

Re: Microphone doesn't work after upgrade to 5.1

Postby Peter K. » 27. Jul 2016, 08:50

Same problem on my machine. After upgrade to 5.1.0 microphone did not work with ALSA, but changing to PulseAudio it worked. After upgrade to 5.1.2 microphone via PulseAudio does not work too.
Peter K.
 
Posts: 1
Joined: 27. Jul 2016, 08:46

Re: Microphone doesn't work after upgrade to 5.1

Postby NachoGomez » 27. Jul 2016, 17:56

I've been having this exact same issue since last VBox update, and is very annoying because the only reason I need this Win7 vm is for attending WebEx sessions, where I need to speak.

I'm using openSUSE 13.2 as host and Windows 7 64bit as guest on VirtualBox version 5.1.2 r108956. Initially I though it could be caused by the Extension Pack, but after disabling it the problem persists.

I'm attaching the last log file.

Thank you very much in advance for any help, regards...
Attachments
VBox.log
(71.51 KiB) Downloaded 16 times
NachoGomez
 
Posts: 4
Joined: 27. Jul 2016, 17:47
Primary OS: openSUSE
VBox Version: PUEL
Guest OSses: RHEL, CentOS, Win7

Re: Microphone doesn't work after upgrade to 5.1

Postby karolbe » 28. Jul 2016, 12:19

Same problem here. I also use VB to run Windows and Webex and after updating to the latest VB 5.1 microphone stopped working. I have downgraded VB to 5.0_5.0.26-108824 and it started working fine again.
karolbe
 
Posts: 2
Joined: 5. May 2008, 12:40

Re: Microphone doesn't work after upgrade to 5.1

Postby randybb » 28. Jul 2016, 16:19

Today I have finally realized why people on all meetings ignored me :)))) My mic doesn't work on latest version on VBox. I hope it will be fixed soon - I really need my mic working under windows (for skype for business calls).
randybb
 
Posts: 1
Joined: 17. May 2009, 01:57
Primary OS: openSUSE
VBox Version: PUEL
Guest OSses: openuse and other linux distributions

Re: Microphone doesn't work after upgrade to 5.1

Postby syntax2001 » 2. Aug 2016, 15:45

My microphone doesn't work either in a Windows 10 guest on Virtualbox 5.1.2 on a Linux Mint 18 (x64) host.
Host driver is PulseAudio and the Controller (in the guest) is IntelHDAudio. Audio playback works great in the guest, but in the recording devices *no* device is listed :(
On the Host the microphone works (tested with Audacity) very well.
syntax2001
 
Posts: 2
Joined: 15. Sep 2014, 16:44

Re: Microphone doesn't work after upgrade to 5.1

Postby Kamandir » 3. Aug 2016, 11:25

Hi,

Microphones do not work in any of my guest systems.

Is there any workaround of fix available?

For me it is high priority issue and i searching for a quick solution.

Thank you!

virtualbox 5.1.2-1
virtualbox-ext-oracle 5.1.2-1
virtualbox-ext-vnc 5.1.2-1
virtualbox-guest-iso 5.1.2-1
virtualbox-host-dkms 5.1.2-1
Kamandir
 
Posts: 1
Joined: 3. Aug 2016, 11:19

Re: Microphone doesn't work after upgrade to 5.1

Postby NachoGomez » 3. Aug 2016, 16:23

Sadly, the only workaround so far is downgrading to VirtualBox 5.1.0-r108711
NachoGomez
 
Posts: 4
Joined: 27. Jul 2016, 17:47
Primary OS: openSUSE
VBox Version: PUEL
Guest OSses: RHEL, CentOS, Win7

Next

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Google [Bot] and 14 guests