[INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Discussions related to using VirtualBox on Mac OS X hosts.

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby socratis » 25. Jun 2016, 09:23

From a credible member of the community there were some wise comments on 2013. Still valid today:
https://forums.virtualbox.org/viewtopic.php?f=8&t=58195
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27307
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby MacVBUser » 1. Jul 2016, 21:37

I am currently running VirtualBox Version 5.0.20 r106931 on MAC OS X El Capitan version 10.11.5. I am an Admin level user on this Mac. When I launched this version of VirtualBox I was notified that there is a new version available and was provided the option to download VirtualBox-5.0.24-108355-OSX-3.dmg. The download completes successfully and the size of the disk image is 89.942.533 bytes.

I launch the DMG and get the Opening and Verifying message and I get to the screen with the 4 Items for this new version of VirtualBox. I then double-click on the icon VirtualBox.pkg which results in a window that says
Verifying "VirtualBox.pkg"...
. From here the installer seems to be stuck. I have let this Verifying run the entire night and no change.
Untitled2.jpg
Screenshot Verifying hang
Untitled2.jpg (33.15 KiB) Viewed 10 times

I have tried downloading again using the link provided. I have tried downloading by going directly to virtual box dot org and downloading from the downloads. I have tried running the installer both with the older VirtualBox running and not running concurrently. All option result in the same Verifying hanging...

Is there an issue with this installer? I should not be required to do anything else other than double click the icon....that is how it has worked for all other updated that I have installed personally for the last 2 years on this same laptop.
MacVBUser
 
Posts: 4
Joined: 1. Jul 2016, 16:12

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby socratis » 1. Jul 2016, 22:02

I've pointed you to this thread in order to do some reading and realize that you're not the only one. You could have skipped the Copy/Paste of your previous message. Adding a "me too" doesn't really help, in this specific issue anyway, because there has not been a clear path to a solution. If you read enough, there are workarounds which have been reported too many times, on this thread alone, for me to repeat again.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27307
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby MacVBUser » 2. Jul 2016, 00:22

Well if you read the threads you will actually see that someone stated that it has not been reported enough to be considered an issue...so therefore a ME TOO is an accurate response. Plus if you read....the initial issue was reported on a previous version of VB and a previous version of MAC OS...so while a ME TOO seems ridiculous to you...Someone that is actually responsible for identifying the issue and searching for a solution might find it valuable information that hey this guy has never had an issue updating the VB in over 2 years and now all of the sudden in this particular combination there is something funky going on. And someone might also realize that turning on the logging in this version is not working and highly described and that this user is too an Admin of this computer and domain and potentially the user has no clue how to login as root on a Mac because...well they are just not Sys Admins and are not supposed to login as root and disable CRC checking and change the package checking. Someone that is actually trying to help will figure out there is a problem and post a real life solution that actually helps people that have encountered the issue or will encounter the issue rather than pointing to a useless thread that appears to be insignificantly related to the issue encountered at this time for this release for these versions. But thanks for adding unproductive words to this thread...instead focus your productivity on providing a solution...unless you are incapable...in that case sit back, enjoy the me toos and get off the keyboard because you are not helping.
MacVBUser
 
Posts: 4
Joined: 1. Jul 2016, 16:12

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby socratis » 2. Jul 2016, 01:54

You didn't actually read the thread from the beginning. Otherwise you would have noticed that all I did was to point you to a discussion that contains workarounds to help you get going. And as I've stated in this very thread, I've spent a lot of time researching this. And I asked for clues from affected users to see if we can pinpoint the problem with OSX. None has so far.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27307
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby MacVBUser » 2. Jul 2016, 03:17

Yes I read it all...

Here is your clue...

Yes it is an OS X issue. VB Update was released prior to the latest OS X Security Patch. However, the VB Patch was not installed first. Instead the OS X patch was installed first. Perhaps the VB package needs to be compiled under the new OS Security Patch. Regardless...the OS X patch was installed and the standard soft reboot was performed.

Now the issue...tried installing the VB Update and receive the hanging issue. Was not able to start any logging...again not my job...not a sys admin...I don't really care. Problem is there is no easy way to get to the logging and there is no error message and no timeout...just mindless hang time. So the package does not have the proper error handling to capture the root cause and terminate like any other reasonable installer would.

SOLUTION: Confirmed that the fix for this issue is a hard reboot of OS X. After complete restart, launched VB, downloaded the update and applied the update with no issues whatsoever.

ISSUE: Package needs to identify and terminate when a system access or error occurs. End users need a more friendly way of helping troubleshoot or error displayed. Developer need to test for current versions of dependent packages, java, bits/bites and code needed to make the install happen.

Cheers...it is Friday!
MacVBUser
 
Posts: 4
Joined: 1. Jul 2016, 16:12

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby MacProTX » 2. Jul 2016, 17:06

Lewis Wright wrote:I had the same issue, the instructions on this page: discussions.apple. com/thread/7260492?start=0&tstart=0 (sorry I'm a new member so I can't post proper links) fixed the issue for me:

OSX apparently needs to regenerate a fresh auth.db from /System/Library/Security/authorization.plist.

This can be triggered in terminal with the following command: sudo mv /var/db/auth.db /var/db/auth.db.old

After rebooting the system everything works as it should be.


Hope this helps!


Just wanted to add that this worked for me, and avoided the need to launch installer.app (from the GUI or the command line) to install. Seems to me more of a solution than a workaround. I'm surprised not to see more comments on this approach.
MacProTX
 
Posts: 1
Joined: 2. Jul 2016, 17:02

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby socratis » 2. Jul 2016, 17:17

MacProTX wrote:Seems to me more of a solution than a workaround.

Nope, that's actually the definition of a workaround to a problem. Deleting the authorization DB of your computer in order to allow the installer to work? A workaround. I've seen read and researched this particular solution, that's why I asked for other users' contributions with solid data so that I could compare the auth.db. Not that we're going to solve a flaw in OSX, but at least if we know what causes it, the Devs can "potentially" work around it somehow, possibly, if it is doable, maybe... You get the point.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27307
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby TheMaster » 3. Jul 2016, 22:44

Just posting "Me Too." I launch the installer for version 5.0.24-108355, and I get stuck on "Verifying..." Other installers seem to work.

The following is printed in the logs when I attempt to launch the installer "CoreServicesUIAgent[367]: Error -60005 creating authorization"

I haven't "modified" my host in any odd ways that I can think of, and I think the possibility that my installed applications interfering with this are low. I'm one of those users who keeps a "tight ship" on my system. I am super cautious about installing software that modifies shared system resources. Before installing anything, the first thing I do is pop open the installer in Pacifist to see what it does, and I tend to shy away from things that do more than they need to. After I run a new app for the first time, I then dig through my system to find out any things it might have done post-install. For example, I don't run google or Adobe software because of the daemons/launchd scripts that those types of software installs, which I feel are unnecessary.

With that out of the way, I think whatever is happening may have something to do with successive installations. I don't ever recall having a problem installing VBOX for the first time on a fresh host, but I do tend to run into this issue when upgrading over existing installations. If this hasn't been tried already, I would suggest trying to upgrade over an existing VBOX install, and see if the this makes the issue easier to reproduce. I don't have the time to do this myself, so offering this as a suggestion...

BTW, I'm not implying that VBOX is at fault. But I think it's very possible that there is something unique to VBOX (and maybe some other OS X Installers) which triggers a bug in the GateKeeper, and leads to this issue. But if we get to a point where we can reliably reproduce the issue, it would be easier to get this fixed at Apple's end. On the other hand, it might be a moot point, as I've read that 10.11.6 is supposed to have some Gatekeeper-related fixes, so maybe it's best to wait and see before doing more work...

On a final note, holding down option while launching the installer seems to be the easiest solution to the problem. Worked for me on two machines. Not sure what this bypasses, so maybe it's a good idea to check the MD5 just in case...
TheMaster
 
Posts: 1
Joined: 2. Jul 2016, 07:12

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby niry » 9. Sep 2016, 18:53

OSX apparently needs to regenerate a fresh auth.db from /System/Library/Security/authorization.plist.

This can be triggered in terminal with the following command: sudo mv /var/db/auth.db /var/db/auth.db.old

After rebooting the system everything works as it should be.

This worked for me, thank you.

The hex/ascii diff of the old vs. new SQLite3 files is too large to post here.
niry
 
Posts: 1
Joined: 9. Sep 2016, 18:36

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby santagada » 6. Oct 2016, 09:28

I just came to say that I was very sad to see the amount of abuse being dispensed in this thread alone. I would never post anything here again if not to voice my concerns agains this type of communication that was common on the olden days of linux and should be in our distant past. Don't tell people to buy new hardware to test your software, don't mock people for not providing enough informantion of force your FUD about people changing their computer systems. How no one on this thread got banned for being so aggressive I don't know.
santagada
 
Posts: 1
Joined: 6. Oct 2016, 09:23

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby socratis » 6. Oct 2016, 09:41

santagada wrote:I was very sad to see the amount of abuse being dispensed in this thread alone.
Abuse? Can you please point me to a post where users were "abused"? Unless we have a different definition of the word...

santagada wrote:Don't tell people to buy new hardware to test your software
Again, can you point me to a post that claimed that this was the solution? Deleting an auto-created (at system startup) file was the most drastic solution, the last resort if you will. Nobody said anywhere, anything about new hardware. I believe that not even an OS re-install was one of the suggestions.

santagada wrote:don't mock people for not providing enough informantion
Mock people? Again, I'm afraid I'm going to have to ask for specific posts.

santagada wrote:force your FUD about people changing their computer systems
FUD? The "please show me the relevant post" theme is becoming more and more important. Messing with your base system *is* to be reserved by users that know what they're doing, i.e. don't mess with it and then complain that things don't work. At the very least, you should be able to describe what it is exactly that you messed with so a solution can be found. It has happened hundreds of times in the past.

santagada wrote:How no one on this thread got banned for being so aggressive I don't know.
Yet again, I don't see any references to specific posts/users. Could you help us out here? There are tools to report abuse and tools to ban users. There was no need whatsoever in this particular thread. I'm not really sure what you're referring to.


PS. I had this problem bite me last week as well, for the first time (10.9.5, test build 5.1.7). A simple reboot fixed it.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27307
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4

Postby TroyCollinsworth » 19. Oct 2016, 15:01

Hung for me too on new Mac Book Pro El Capitan 10.11.6, reboot resolved the issue.
TroyCollinsworth
 
Posts: 1
Joined: 4. Aug 2009, 18:00
Primary OS: Ubuntu 8.10
VBox Version: PUEL
Guest OSses: Windows XP, Vista

VBox installer stuck on verifying install pkg--solved

Postby Eschscholzia » 28. Oct 2016, 21:55

Between when I tried to post this here yesterday and ran afoul of the url posting rules (once triggered, the 'can't post URL' bot blocked the post even when I removed the URL entirely), a friend elsewhere gave me the solution. I'll post it here because I see several other threads related and this solution seems simpler than some of the others:

I was trying to update from VBox 5.0.26 to 5.0.28 via the link that popped up when I opened VBox, and the installer hung on verifying the pkg step. I deleted and .dmg and redownoladed; no joy. I came to the VBox site and saw a 5.1 available and downloaded that .dmg, and same problem. I read in the forums and saw a similar thread but couldn't figure out that solution so was trying to post with a link to that and request for whether that applied to my situation or not, and that's when the guardbot stopped me. I did not save that link.

But meanwhile, I was sent a link to this article with a solution that worked a treat this time, on a 2011 MBP running 10.11.6 El Cap:

Fixing an Installer .pkg Stuck on “Verifying” in Mac OS X

Basically, it shows how to open the installer app directly, and open the pkg from within installer. I would be very apprehensive using this on software of doubtful integrity, but figured VBox directly from Oracle should be OK.
Eschscholzia
 
Posts: 7
Joined: 27. Oct 2016, 18:12

Re: VBox installer stuck on verifying install pkg--solved

Postby socratis » 28. Oct 2016, 22:28

@Eschscholzia
This solution is already included as a workaround in an existing thread ([INSTALL] Verifying "VirtualBox.pkg"... never clears -- El Cap 10.11.4), that's why I'm merging your solution with the rest of it. It's a good thing that there is this article included, because it shows that this is not a VirtualBox problem, because is happens even with officials updates.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27307
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

PreviousNext

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Google [Bot] and 10 guests