USB not working

Discussions related to using VirtualBox on Windows hosts.

Re: USB not working

Postby keedoggy » 15. May 2016, 01:51

Re: USB not working

Postby nayasis » 24. Feb 2011, 10:14 - Thank You. Win7-Ulitmate Host and winXP Pro Guest. Using multiple
usb connected Mikroelektronika Development boards. All OK.
Posts: 1
Joined: 15. May 2016, 01:43

Re: USB not working

Postby MikesNote » 26. Sep 2016, 13:10

  • New MSI GS40 6QE laptop - I7-6700HQ - 16GB RAM - USB ports all v3.0
  • VBox v5.1.6
  • Host: Win 10 Home v1511 b10586.589
  • Guest: Kubuntu v16.04 32-bit

The Problem: USB was not working - I tested by trying to mount a WD MyPassport USB3.0 portable drive and a Strontium USB2.0 pen drive.


  • When plugged in, devices were recognized by the Win 10 host, and a Safely Remove Hardware icon appeared in the task bar.
  • When the VM was started, the devices showed in its Devices > USB list. Hovering over a device in the list, its State was shown as Busy if it had neither been clicked to capture it nor a filter set in the VM's Settings > USB to automatically capture it when the VM is started.
  • When the device in the list was clicked to capture it, no checkmark was set as it should have been but State changed to Captured. Win 10's icon disappeared indicating it was no longer connected to the host. But neither a device connection notification to allow mounting the device nor an entry in the Dolphin file manager showing it had been mounted appeared in Kubuntu. And the USB icon on the VM's status bar in the lower right corner showed, when hovered over, No USB devices attached.
  • If the device in the list was clicked a second time, an error dialog always appeared saying the device was busy with a previous request.
  • Releasing the devices back to Win 10 could only be done by shutting down Kubuntu, then closing VBox, after which the removable devices icon reappeared on the host's task bar and file manager windows opened in the host displaying their contents.


  • Searched the web thoroughly and tried some of the suggestions there, most of which involved setting filters to directly capture the devices in the VM. As the devices were already shown as captured, having or not having filters didn't seem to be the problem. Besides, I did not want to use filters to automatically capture my devices since I often want to continue using them in the host while the VM is running. Nothing worked.
  • The best procedure I came across was nayasis' solution. Though it didn't work for me as-is, it pointed me in the right direction:

    nayasis wrote:I've got solution finally... T-T

    (It seems like problem of window 7)

    1. My Host is window 7 32bit home premium. But, 64bit's solution may be same because problem was caused by USB filtering function of WINDOW 7.

    2. first of all, edit your registry

    - Open the Windows registry, by clicking on Start > Run and typing regedit
    - Navigate to the following location HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
    - In the right hand panel, if the the UpperFilters entry exists, then delete it

    3. Install virtualbox USB driver manually.

    - Goto folder C:\Program Files\Oracle\VirtualBox\drivers\USB\filter
    - Click right mouse button on file named VboxUSBMon.inf
    - Check Install(I) (maybe.. My window is korean so it dose not exact. )

    4. Rebooting

    5. Unplug your USB memory (or joystick..)

    6. Open VirtualBox and Close it rightly.
    ( it will remove your USB device from VM's seized list. )

    7. Plug your USB memory.

    8. Open VirtualBox and Run Virtual Machine.

    9. Click right mouse button on USB icon placed in status bar which is below VM window.

    10. Check USB device what you want to plug in.

  • Step 3 gave me the idea for the solution. He says to manually install the VboxUSBMon.inf driver at C:\Program Files\Oracle\VirtualBox\drivers\USB\filter. Judging by its name and folder, it monitors USB connections and implements the filters. But there is another driver in the adjacent device folder, VBoxUSB.inf, which I suspected implemented the USB device connections and might be missing in my system. Installing this driver proved to be the solution.

The Solution (basically nayasis' solution with the second driver installation added):

  1. Safely unplug your USB devices from the host if any are plugged in.
  2. Open VBox then close it again to release any USB devices that may still be captured in the VM.
  3. Delete the UpperFilters entry, if it exists, in the host registry -

    • Open the Windows registry: Start (right-click in Win 10) > Run and type regedit.
    • Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}.
    • Delete the UpperFilters entry if it exists.
    • Note: This entry did not exist on my system.
  4. Manually re-install VBox USB drivers on the Windows host -

    • Open folder C:\Program Files\Oracle\VirtualBox\drivers\USB.
    • Open subfolder device, right-click driver file VBoxUSB.inf, and click Install.
    • Open subfolder filter, right-click driver file VBoxUSBMon.inf, and click Install.
    • Reboot the Windows host system just to make sure the drivers are loaded.
  5. Plug in your USB devices.
  6. Open VBox and run the VM.
  7. Click any devices in the VM's Devices > USB menu list, and they should mount OK. (Hovering the mouse over the USB icon on the VM's status bar in the lower right corner of the VM will show the USB devices attached.)

The Probable Cause

Win 10 had crashed and recovered itself during the original VBox install, and the installation was not completed. I had not disabled Norton Security and suspected the antivirus had caused the problem. After rebooting, I closed the wifi, temporarily disabled the antivirus component of NS, and successfully re-ran the installer to completion. VBox seemed to run OK so I didn't give this a second thought. But apparently the USB drivers had not installed properly.

Hope this helps someone. And special thanks to nayasis for his post :)
Posts: 1
Joined: 26. Sep 2016, 09:13

Re: USB not working

Postby mpack » 26. Sep 2016, 15:31

I'm locking this. The topic title is too broad and is bound to attract "me too" posts, and 5 years of those means we probably have enough. Note that this isn't a criticism of "MikesNote", his last post just made me notice the topic.
Site Moderator
Posts: 38138
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: thmojacob and 30 guests