RDP connection - "connection reset by peer"

This is for discussing general topics about how to use VirtualBox.

RDP connection - "connection reset by peer"

Postby Liosan » 28. Aug 2008, 12:11


I'm trying to connect to windows-hosted machines through the remote desktop protocol. Using neither rdesktop on mandriva linux nor the standard tool on windows xp or vista doesn't bring any results.

rdesktop says "connection reset by peer" (although it does open a window), and the MS tool just waits a couple of seconds and does nothing - I presume the cause is the same. The amount of time waited seems to correlate to the timeout set in the GUI. The type of the guest doesn't seem to matter - I've tried DOS, windows 98se, windows 2003, XP, Vista and ubuntu server and ubuntu desktop.

Any ideas? Thanks in advance,

Posts: 4
Joined: 5. Aug 2008, 12:43

Postby TerryE » 28. Aug 2008, 13:22

1) its always worth using a non-default port just so you don't accidentally start connecting to the wrong RDP service. I use 4000, 40001, ...

2) If you start the VM on fred with the -p 4000 parameter then you need to connect to fred:4000.

Is this what you are doing?
Read the Forum Posting Guide
Google your Q site:VirtualBox.org or search for the answer before posting.
Posts: 3572
Joined: 28. May 2008, 08:40
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu 10.04 & 11.10, both Svr&Wstn, Debian, CentOS

Postby Liosan » 28. Aug 2008, 13:33

I tried this, and it didn't change the situation.

I just managed to get RDP running and connected on a Windows 2003 host... well, it DOES work, but it's inconvenient for me to use that computer. Then again, it might mean that something is wrong on the other hosts I tried - XP and Vista - although I can't figure out what.

Posts: 4
Joined: 5. Aug 2008, 12:43

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 18 guests