Unknown PCI device

Discussions related to using VirtualBox on Linux hosts.

Unknown PCI device

Postby teddy » 8. May 2008, 14:18

After I upgraded to Virtualbox 1.6.0 a new PCI device has appeared in device manager (Windows XP SP2). I installed the new Guest addition, but that did not help. The guest settings are the same as before, only thing is that they were upgraded to the new 1.3 settings format. Windows XP reports the device as unknown, PCI Slot 12 (PCI bus 0, device 13, function 0). Everything works as before, does anyone know what this device are?
teddy
 
Posts: 10
Joined: 12. Mar 2008, 12:09

Postby nvivo » 10. May 2008, 15:48

I had the same problem here.

Take a look if you enabled the SATA Controller or the USB 2.0 support. When I first ran a machine on 1.6 here, I enabled them and windows started asking for it.

Reverted the snapshot and ran as it was on 1.5.6, and I got no device notices.
nvivo
 
Posts: 57
Joined: 4. Aug 2007, 17:08

Resolved it in XP

Postby mrevd » 14. Aug 2008, 00:39

By booting a Linux distro with SATA option enabled, I found that it needs the Intel Mobile SATA drivers.
"http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProductID=2101&DwnldID=16012&strOSs=44&OSFullName=Windows*%20XP%20Professional&lang=eng"

Hope this helps you
mrevd
 
Posts: 1
Joined: 14. Aug 2008, 00:35

Postby huijaa » 14. Aug 2008, 23:37

it works succesfully! thanks! ;)
huijaa
 
Posts: 9
Joined: 14. Aug 2008, 18:52

Re: Unknown PCI device

Postby peterman7701 » 19. Sep 2009, 22:08

This thread http://communities.intel.com/thread/3397 pointed these drivers: http://downloadcenter.intel.com/Detail_ ... l&lang=eng

It's working correctly with VirtualBox v2.2.4, Windows XP SP3 (both host and quest), using SATA ports for hard disks.
peterman7701
 
Posts: 1
Joined: 19. Sep 2009, 22:03
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: windows xp, ubuntu


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: phantom21 and 24 guests