Windows 4.3.16 specifically for errors due to security

Discussions related to using VirtualBox on Windows hosts.

Re: Windows 4.3.16 specifically for errors due to security

Postby DerCHiEFhb » 2. Oct 2014, 12:18

VBoxStartup.rar
Logfile for Startup
(9.32 KiB) Downloaded 35 times
Hi,
have the same issues - Error message is rc=-3738

Testbuild 4.3.17 r96342

OS: is Windows 7 SP1 Ultimate x64 fully patched (as of today) GERMAN

Antivirus:
Symantec Endpoint Protection V. 11.0.6005.562
Modules:
Antivirus and Antispy (definitions: Oktober 1st 2014 r23)
Proactive Threat Protection (definitions: Oktober 1st 2014 r23)

crash happens upon starting any virtual machine.

I can provide a developer with the AV version in question if needed.
Teamspeak, skype and teamviewer available :)
Cheers,
Jens
DerCHiEFhb
 
Posts: 1
Joined: 2. Oct 2014, 12:03
Location: Frankfurt, Germany
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows 10, Windows 7, Debian, Ubuntu

Re: Windows 4.3.16 specifically for errors due to security

Postby Collizion » 2. Oct 2014, 15:57

Host:
HP ProDesk 600 G1 SFF
Windows 8.1 Professional x64
Fully up to date as of 2 Oct 2014.

Security Suite:
avast! Endpoint Protection Suite
Program version: 8.0.1603
Definitions: 141002-0

Using test build 4, receiving the following errors when attempting to start a CentOS 7 x64 VM:

VBoxError1.PNG
VBoxError1.PNG (8.96 KiB) Viewed 5889 times

VBoxError2.PNG
VBoxError2.PNG (15.05 KiB) Viewed 5889 times


VBoxStartup log compressed and attached.
Attachments
VBoxStartup.zip
(6.18 KiB) Downloaded 24 times
Collizion
 
Posts: 1
Joined: 2. Oct 2014, 15:53

Re: Windows 4.3.16 specifically for errors due to security

Postby drescherjm » 2. Oct 2014, 17:29

Test#4 still does not work on my system with the same failed to verify process integrity: (rc=-5662)

1. Windows 8.1 Enterprise / Virtual Box 4.3.17-96342
3. Symantec Endpoint Protection 12.1.4100.41261
Attachments
VBoxStartup.zip
(9.08 KiB) Downloaded 17 times
drescherjm
 
Posts: 13
Joined: 30. Apr 2008, 22:44

Re: Windows 4.3.16 specifically for errors due to security

Postby mattsnowboard » 3. Oct 2014, 19:46

mpack wrote:
mattsnowboard wrote:The only problem is it still regresses Vagrant support

Vagrant has never been supported, so it's impossible to regress support for it.


Okay, forget Vagrant/my terminology, it regresses this command (which happens to be run from Vagrant):

VBoxManage.exe controlvm <uuid> savestate


https://forums.virtualbox.org/viewtopic.php?f=6&t=63703
Are you sure this is not a bug in VirtualBox itself? From my understanding, this issue only manifests itself with VirtualBox (>.12) on Windows.
mattsnowboard
 
Posts: 4
Joined: 17. Feb 2011, 16:35
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu

Re: Windows 4.3.16 specifically for errors due to security

Postby Jacob Klein » 3. Oct 2014, 23:48

Hey bird,

I encountered a security problem... SUPR3HardenedMain suplibOsInit VERR_SUPDRV_HARDENING_EVIL_HANDLE... when attempting to launch a VM on Windows 10 Technical Preview (which is available to everyone as a free download, as of yesterday).

Is there any chance you can put in a fix for this? I'd like to be able to test VirtualBox VMs on the new OS.

The error is:
23f4.1c6c: SUPR3HardenedMain: Final process, opening VBoxDrv...
23f4.1c6c: Error -3738 in suplibOsInit! (enmWhat=3)
23f4.1c6c: VERR_SUPDRV_HARDENING_EVIL_HANDLE
... and the error message also says:
Make sure the kernel module has been loaded successfully.

I'll attach the screenshot, as well as the full log.
I hope you plan on fixing this, so your dedicated testers can test even on newer OS's!

Let me know, thanks,
Jacob
Attachments
VBoxStartup.zip
Startup Log
(9.48 KiB) Downloaded 19 times
Oracle VirtualBox v4.3.17 R96342 - Windows 10 - Error In suplibOsInit - VERR_SUPDRV_HARDENING_EVIL_HANDLE.png
Windows 10 Technical Preview - SUPR3HardenedMain error
Oracle VirtualBox v4.3.17 R96342 - Windows 10 - Error In suplibOsInit - VERR_SUPDRV_HARDENING_EVIL_HANDLE.png (7.65 KiB) Viewed 5658 times
Jacob Klein
 
Posts: 463
Joined: 20. Nov 2013, 01:07

Re: Windows 4.3.16 specifically for errors due to security

Postby Liftbox » 4. Oct 2014, 03:02

bird wrote:Reposting test build #3 as the initial build (96096) was broken by some build server changes:

The previous build (#2) broke things for all avast users. Frightfully sorry about that. Here is a new build that fixes that blunder.

Test build #3: virtualbox . org/download/testcase/VirtualBox-4.3.17-96101-Win.exe


Cheers,
bird

Thank you very much, it almost work 100% fine for me(only got a single issue with the build #3).

Feedback:

My real machine runs:
- Windows 7 ultimate sp1 64bits
- Avast! free antivirus 9.0.2021

~~~~~~~~~~~~~~

I've loaded four different .vdi (win7, winXP, win2008, ubuntu 10), that have been worked fine in different computer(linux) previously.

~~~~~~~~~~~~~~

With build 4.3.16-95972 (The one provided in the main website):

    Only ubuntu loaded sometimes for first time, but when rebooting it, I got Fyle system errors such this:
    "file system error -1073741502"

    - After multiple repair/reinstall/reboot from my real win7 I got error when opening other programms:
    "The application was unable to start correctly (0xc0000142)"

    - Also got bluescreen of death when loading win2008.

    - The most common issue was the "creating process for virtual machine vmname (GUI/Qt)"
    hanged in a 0% value as infinite loop.
    It was related to other error "an unexpected process (pid=0x00000C74) has tried to lock the machine xxxxx, while only the process started by LaunchVMProcess (PID=0x00000F94) is allowed.

    - Other issue when loading a .vdi, the mouse freezes and it blocks real machine and everything, forcing me to power off.

    - Twice got "intel VT-x" loading issues, but anymore after.

~~~~~~~~~~~~~~

With the build 4.3.17-96101 (The #3 build you've provided):

    - I loaded my .vdi "ubuntu 10", it loaded sucessfully the first time. But the second time I got blue screen of death on my win7(real machine).
    After reboot, I deleted it, and made another "ubuntu 10", which has no problems whilst loading.
After it, everything went fine with the other four machines(win7, winXP, u10, win2008)
~~~~~~~~~~~~~~

Hope it helps.
Regards.
Liftbox
 
Posts: 1
Joined: 4. Oct 2014, 02:55

Re: Windows 4.3.16 specifically for errors due to security

Postby nobook » 4. Oct 2014, 14:35

VirtualBox version:
#4 VirtualBox-4.3.17-96342-Win.exe

other version which got the same error:
VirtualBox-4.3.17-96101-Win.exe
VirtualBox-4.3.16-95972-Win.exe
VirtualBox-4.3.14-95030-Win.exe

My host computer runs:
Windows 7 ultimate sp1 64bits

Anti-virus Software:
Microsoft Security Essentials

Turn on an existing VM show error:
The virtual machine 'w7x64' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005). More details may be available in 'VBoxStartup.log'.
code: E_FAIL (0x80004005)
Machine
IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

Log upload.
Attachments
VBoxStartup.log
VBoxStartup.log while E_FAIL (0x80004005)
(11.08 KiB) Downloaded 20 times
nobook
 
Posts: 14
Joined: 25. Oct 2008, 11:31

Re: Windows 4.3.16 specifically for errors due to security

Postby Memiself » 4. Oct 2014, 15:11

@bird
sigcheck.exe -i %windir%\system32\crypt32.dll ->
c:\windows\system32\crypt32.dll:
Verified: Unsigned
Link date: 23:33 30/09/2013
Publisher: Microsoft Corporation
Description: Crypto API32
Product: Microsoft® Windows® Operating System
Prod version: 6.2.9200.16727
File version: 6.2.9200.16727 (win8_gdr.130930-1510)
MachineType: 64-bit

Also att. output from msinfo32
Attachments
server.zip
(35.78 KiB) Downloaded 18 times
Memiself
 
Posts: 4
Joined: 21. Sep 2014, 20:28

Re: Windows 4.3.16 specifically for errors due to security

Postby tsh2 » 4. Oct 2014, 16:10

I am seeing intermittent failures on starting a VM. Roughly 50/50 success rate.
Win 8.1 host, win 10 preview guest
virtualBox 4.3.17r96342

Avast 2014.9.0.2021 (disabled, no success when enabled)
Malwarebytes 2.0.2.1012

Passing and failing logs included. Pass was achieved immediately after failing startup (after time to copy logs)
Attachments
VBoxStartup.zip
(35.97 KiB) Downloaded 10 times
tsh2
 
Posts: 1
Joined: 4. Oct 2014, 16:04

Re: Windows 4.3.16 specifically for errors due to security

Postby Pantyboy » 4. Oct 2014, 22:45

Downloaded VirtualBox v4.3.16-95972 to load on to my system - Acer 5750 laptop with Intel i5-2450M CPU, 8Gb RAM running Windows 7 Premium 64 bit.

Trying to install Windows XP Pro 32 bit getting errors:

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

I've attached the Startup log from my machine.
VBoxStartup.rar
(25.13 KiB) Downloaded 21 times


I've have tried to install this version with and without administrator privileges, with my anti-virus (AVG Free) enabled and disabled and internet access enabled and disabled I've even completely cleaned my drive and registry of all things VirtualBox but not luck.
Pantyboy
 
Posts: 1
Joined: 28. Aug 2013, 15:53

Re: Windows 4.3.16 specifically for errors due to security

Postby mpack » 5. Oct 2014, 11:57

I don't think it will be productive to mention unsupported guests in this topic (i.e. Win10 Preview). We are trying to narrow the focus, not enlarge it.
mpack
Site Moderator
 
Posts: 29348
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Windows 4.3.16 specifically for errors due to security

Postby Jacob Klein » 5. Oct 2014, 13:11

Well... the problem that we are seeing in Windows 10 Technical Preview, is specifically caused by the hardened security added after VirtualBox 4.3.12. It is relevant.
I would think they would want to fix it, especially if it is a simple issue, which it very well could be.

At the very least, I'd like a response on the nature of the issue, how difficult it may be to fix, and an estimated time on the fix.
There's a thread of other people complaining about it, too, so I'm not the only one.
Jacob Klein
 
Posts: 463
Joined: 20. Nov 2013, 01:07

Re: Windows 4.3.16 specifically for errors due to security

Postby dalchina » 5. Oct 2014, 16:22

VM error.jpg
VM error.jpg (83.47 KiB) Viewed 5402 times


Hi, having struggled with the error as reported with two vdi's, I found this thread and tried build 4.3.17 r96342.

Trying to start the virtual OS gave the same error message.

I've tried turning off Bitdefender AV and firewall.

Win 8.1 Pro, Bitdefender IS 2015.

"Failed to open a session for the virtual machine win 2000.

The virtual machine 'win 2000' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'H:\Virtual Machines\win 2000\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}"
dalchina
 
Posts: 1
Joined: 5. Oct 2014, 16:16

Re: Windows 4.3.16 specifically for errors due to security

Postby Jacob Klein » 5. Oct 2014, 17:00

dalchina:

In your picture, I see a strange overlay on the window titlebar, providing an up-arrow options and a pin button. What program does that?
Keep in mind, the VirtualBox hardened security will trip up on more than just antivirus -- it can trip up on anything that "intercepts and injects" normal Windows operations (including drawing a titlebar!).
Please identify that titlebar program, and consider testing to see if uninstalling it and restarting your PC, would make VirtualBox work, thus indicating VirtualBox's problem would be with that program.

Regards,
Jacob
Jacob Klein
 
Posts: 463
Joined: 20. Nov 2013, 01:07

Re: Windows 4.3.16 specifically for errors due to security

Postby mpack » 5. Oct 2014, 18:09

@dalchina: It might also help if you posted the VBoxStartup.log file (zipped) as requested in the first post of this discussion.
mpack
Site Moderator
 
Posts: 29348
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 33 guests