4.3.14 conflicts with anti-virus packages.

Discussions related to using VirtualBox on Windows hosts.

Re: 4.3.14 conflicts with anti-virus packages.

Postby gabeortiz » 2. Sep 2014, 22:25

I was having the same initial error and updated to 4.3.15r95713, but am now getting the VT-x is unavailable. This was of course working several months ago without issue. None of my 64-bit VMs are working. Windows 8.1 Pro with Media Center (x64). Intel I7. I have not tested disabling the antivirus yet, because I do not have permissions to. It is McAfee.
gabeortiz
 
Posts: 1
Joined: 2. Sep 2014, 22:17

Re: 4.3.14 conflicts with anti-virus packages.

Postby Muco53 » 3. Sep 2014, 06:33

How can i fix that problem, i am using 4.3.15

Failed to open a session for the virtual machine Lol.

The virtual machine 'Lol' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\Users\Mücahit\VirtualBox VMs\Lol\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}



The error log is on the attachment.
Attachments
wdk6Wqa.png
wdk6Wqa.png (44.57 KiB) Viewed 7576 times
VBoxStartup.log
(5.47 KiB) Downloaded 46 times
Muco53
 
Posts: 1
Joined: 3. Sep 2014, 06:28

Re: 4.3.14 conflicts with anti-virus packages.

Postby bawldiggle » 3. Sep 2014, 15:29

Downloaded [VirtualBox 4.3.15 (build95713)]

Ran VirtualBox-4.3.15-95713-Win.exe

Default installation wizard message

disk-space-requirements.png
disk-space-requirements.png (15.31 KiB) Viewed 7463 times


Installation abandoned by me
--------------
Windows 7 Home Premium 32 bit
AV:- Bitdefender Internet Security 2013 (current and updated today)
bawldiggle
 
Posts: 2
Joined: 1. Sep 2014, 15:00

Re: 4.3.14 conflicts with anti-virus packages.

Postby mpack » 3. Sep 2014, 15:46

I don't see how this can be related. Available disk space is calculated by the Windows installer, MSI. Not by VirtualBox. Perhaps you should try running chkdsk on your drive. Also, you said Win7, but that dialog looks awfully like XP.
mpack
Site Moderator
 
Posts: 29722
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: 4.3.14 conflicts with anti-virus packages.

Postby wearyofallthiscrap » 3. Sep 2014, 21:01

Success with the following combination:

64-bit Windows 7 host, running Microsoft Security Essentials 4.5.216.0
VBox 4.3.15 r95713 from the link on the first page
VBox extension pack 4.3.14 r95030 from the site downloads page (this is standard 4.3.14)

Guest Additions was a bit tricky. The guest is a Debian mostly-sid server, and I need X 1.16 support, which VBox 4.3.14 doesn't have. Fortunately, ticket 13207 has already solved this problem, and michael updated a link there to a testing GA build with newer X support. The testing image provided is an .iso file. So instead of the standard "Devices -> Insert Guest Additions CD Image" followed by running the appropriate script out of /media/cdrom/VBoxLinuxWhateverTheNameIs, I needed to mount the VBoxGuestAdditions_4.3.15-95679.iso directly instead.

(I lied, none of that was tricky; that's all entirely normal. The tricky part was that in the running system, "Devices -> CD/DVD Devices -> Choose a virtual disk file" had no effect. Nothing in the log file, no errors, just nothing. Bringing up the VBox Manager GUI, opening the running machine's settings dialog, then mounting the ISO image under the appropriate Storage tab worked just fine. Why the difference, I've no idea, but it saved me some unneeded rebooting to map the drive.)
wearyofallthiscrap
 
Posts: 34
Joined: 8. Nov 2011, 16:10
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu/Debian

Re: 4.3.14 conflicts with anti-virus packages.

Postby J.L. » 3. Sep 2014, 23:44

What happened to my email notifications? Anyways, Virtualbox 4.3.15-95713 finally doesn't crash, but sometimes freezes at bootup for all machines and frequently at startup for Haiku.

Unbearably slow cursor for Haiku and OS/2 Warp 4 as well. And when will my Nvidia Optimus GPU selection for virtualbox.exe apply?
Attachments
Startup Freeze.zip
(88.81 KiB) Downloaded 25 times
Boot Freeze.zip
(62.8 KiB) Downloaded 16 times
Windows 10 is the actual host, not 8 (no option).
J.L.
 
Posts: 78
Joined: 17. Jan 2013, 07:38
Primary OS: MS Windows 8
VBox Version: PUEL
Guest OSses: LMDE, Ubuntu, Windows XP, Windows 7

Re: 4.3.14 conflicts with anti-virus packages.

Postby Redleh » 4. Sep 2014, 00:35

Hi,
Just to report I installed version VirtualBox 4.3.15 (build 95713) and do not have the problem anymore.
Previously, when running version 4.3.14-95030 I also had the error “Error relaunching VirtualBox VM process 5” when starting up a VM.
Installing the problematic version by disabling antivirus first did not solve the problem but like others installing version 4.3.12-93733 worked fine, therefore issue seems really to be with 4.3.14-95030 version.

This happened on a Acer Aspire 1810Tz which has a 64-bit CPU and with Windows 7 Home Premium 64-bit installed. The CPU does not have VT-x so I cannot run 64-bit VM's but always ran 32-bit VM's until version 4.3.14-95030

Thanks,
Redleh
 
Posts: 1
Joined: 4. Sep 2014, 00:27

Re: 4.3.14 conflicts with anti-virus packages.

Postby vboxuser98563 » 4. Sep 2014, 11:14

Hi,

I just downloaded the latest 4.3.15 test version from vbox website (VirtualBox 4.3.15 (build 95713)) and tried running a Windows 7 32bit VM on my Windows 8.1 64bit host. Everything works fine so far, but whenever I try to manage shared folders (in order to add a new shared folder) using GUI VBox crashes with some access violation. You will find vbox log attached to this post. I couldnt add a screenshot since this is my first post.

Error dialog says:

title: VirtualBox: Windows - Application Error
content:
The instruction at 0x7fa218fc references memory at 0x00000000. The memory could not be read.

Click on OK to terminate the program.
Click on CANCEL to debug the program.

I had to zip the Startup because it was bigger than 128kb

EDIT:

One remark: Adding the shared folder using the command line VBoxManage sharedfolder add command worked good for me! It seem to be some issue in the GUI.
Attachments
VBoxStartup.zip
(16.36 KiB) Downloaded 54 times
VBox.log
(67.25 KiB) Downloaded 28 times
vboxuser98563
 
Posts: 1
Joined: 4. Sep 2014, 11:04

Re: 4.3.14 conflicts with anti-virus packages.

Postby JoTaReX » 4. Sep 2014, 20:46

yesss!!!!
I'm using windows 7 pro 64 bits and Kaspersky Endpoint Security 10 for Windows
The new version VirtualBox-4.3.15-95713-Win works fine!

Thank you!
JoTaReX
 
Posts: 1
Joined: 4. Sep 2014, 20:43

Re: 4.3.14 conflicts with anti-virus packages.

Postby oleedee » 4. Sep 2014, 21:29

I was getting the "Failed to install NtCreateSection monitor" error with 4.3.14, So I installed 4.3.15 with all antivirus and firewalls off.

now I get this error when running the VirtualBox.exe
win7 64bit
Avast free, Comodo firewall free

----
Problem signature:
Problem Event Name: APPCRASH
Application Name: VirtualBox.exe
Application Version: 0.0.0.0
Application Timestamp: 53fa3433
Fault Module Name: VirtualBox.exe
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 53fa3433
Exception Code: c0000005
Exception Offset: 0000000000014f98
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 2057
Additional Information 1: 12d9
Additional Information 2: 12d97e52368814769cd6cce96325cde2
Additional Information 3: eefd
Additional Information 4: eefd2053463bac756f9dee3f566e2c29
-----
edit-
It seems to work sometimes and not others with no pattern from what I can see. I have tried with security programs off and on, and using different shortcuts, and from the actual exe..

Then on the rare occasions I get through to use VB I then get this error when I try to start a VM;

------
Failed to open a session for the virtual machine Kali-Linux.

The virtual machine 'Kali-Linux' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005).

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}
----

edit-
Ok, I've since found that this is also a temperamental error with no identifiable pattern. I ran the VM on the third try.
Could this temporary block to normal functioning be another symptom of anti-virus's DLL injection?
oleedee
 
Posts: 1
Joined: 4. Sep 2014, 21:25

Re: 4.3.14 conflicts with anti-virus packages.

Postby VBProblems » 6. Sep 2014, 20:24

VBProblems wrote:I got the "Error relaunching VirtualBox VM Process: 5" error in the first post when I installed 4.3.14. Later I installed the sixth build of 4.3.15. The error disappeared with 4.3.15. I'm able to load a virtual machine but now the buttons to select an ISO to boot from ignore being pressed. Nothing happens other than the hour glass is shown for a second. VirtualBox is unusable for me because of this.

I have AVG AntiVirus, and APC PowerChute in memory on my computer. Malwarebytes and SpyBot 1.62 are installed as well. It has RealTek Audio, Realtek Nic and Intel video. VirtualBox is installed on Windows 7 64-Bit.


I'll add that I have ClassicShell and Workrave in memory too. I'm not sure if that's helpful.
VBProblems
 
Posts: 11
Joined: 1. Sep 2014, 17:33

Re: 4.3.14 conflicts with anti-virus packages.

Postby bird » 7. Sep 2014, 00:59

Hi All!

Test build #7 (think of it as an release candidate): https://www.virtualbox.org/download/tes ... 23-Win.exe

Fixes since #6:
- Fixed non-working "Choose a virtual CD/DVD disk file..." menu item.
- Fixed rare crash when loading a DLL (this is possibly the same as the shared folder setup crash).
- Fixed left behind VBoxNetDHCP and VBoxNetNAT processes.
- Adjusted the Avast kludge (feedback from avast users would be great).
- Should work on Windows 7 Embedded hosts with DLLs signed months after they got built.

Enjoy,
bird.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 119
Joined: 10. May 2007, 10:27

Re: 4.3.14 conflicts with anti-virus packages.

Postby Jacob Klein » 7. Sep 2014, 05:47

bird:

When we install a test build, is it normal behavior for the registry key:
HKLM\SOFTWARE\Oracle\VirtualBox\InstallDir
...
to be BLANK?

I was expecting to see the value be something like:
C:\Program Files\Oracle\VirtualBox\

Why is it BLANK?
Jacob Klein
 
Posts: 486
Joined: 20. Nov 2013, 01:07

Re: 4.3.14 conflicts with anti-virus packages.

Postby GenericHero » 7. Sep 2014, 05:48

Just posting here to confirm that Test build #7 works with Avast internet security without disabling it now. The previous build worked when disabling Avast only. I only have one VM, but still.
GenericHero
 
Posts: 1
Joined: 7. Sep 2014, 05:44

Re: 4.3.14 conflicts with anti-virus packages.

Postby bird » 8. Sep 2014, 03:01

Jacob Klein wrote:bird:
When we install a test build, is it normal behavior for the registry key:
HKLM\SOFTWARE\Oracle\VirtualBox\InstallDir
...
to be BLANK?

No, that's a genuine bug. Thanks for noticing! I can reproduce it locally and have field an internal bug report for our installer guy. I fear the fix will have to wait till 4.3.18 as the guy is on vacation right now.

GenericHero: Very relieved to hear that it works. Lovely to get positive feedback once in a while!

Cheers,
bird.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 119
Joined: 10. May 2007, 10:27

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 61 guests