4.3.14 conflicts with anti-virus packages.

Discussions related to using VirtualBox on Windows hosts.

Re: 4.3.14 conflicts with anti-virus packages.

Postby JAttila » 31. Jul 2014, 02:11

I've already uninstalled and reinstalled 4.3.12, but my problem was caused by NVidia video drivers (nview64.dll).

Jamie
JAttila
 
Posts: 2
Joined: 31. Jul 2014, 02:10

Re: 4.3.14 conflicts with anti-virus packages.

Postby Redbyte » 31. Jul 2014, 05:44

I have been having this error as well. My AV is Symantec Endpoint. I installed the latest build via the link on this post (currently 4.3.15 r95286) and I am still getting the error "Error in supR3HardenedWinVerifyProcess" with sysfer.dll. I have installed the guess additions as well and it has made no difference. Also ADC is disabled

Image

Image

Image
Attachments
VBoxStartup.log
(33.3 KiB) Downloaded 24 times
Redbyte
 
Posts: 3
Joined: 18. Dec 2013, 07:56

Re: 4.3.14 conflicts with anti-virus packages.

Postby mystik_7 » 31. Jul 2014, 09:40

I also got error 0xc0000005 when starting virtual machine with latest build 4.3.15 r95286

OS: Windows 8
AV: BitDefender
mystik_7
 
Posts: 1
Joined: 31. Jul 2014, 09:38

Re: 4.3.14 conflicts with anti-virus packages.

Postby JK_Flip_Flop » 31. Jul 2014, 20:42

The latest test build did fix the issue of not being able to even launch the interface, however I now see the same E_FAIL error as other users.

Host OS: Windows 7 Pro SP1
VBox: 4.3.15 r95286
AV: McAfee Virus Scan Enterprise + Antispyware Enterprise 8.8.0.975

Hope these logs help.

F20-launch_error.jpg
F20-launch_error.jpg (46.13 KiB) Viewed 8043 times

F20-VBox.log
(100.68 KiB) Downloaded 47 times

F20-VBoxStartup.log
(36.37 KiB) Downloaded 31 times
JK_Flip_Flop
 
Posts: 2
Joined: 31. Jul 2014, 20:35
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Fedora, CentOS, Mint, Ubuntu

Re: 4.3.14 conflicts with anti-virus packages.

Postby nick____ » 31. Jul 2014, 20:52

Hi Virtualbox forum. I am having a similar problem with Virtualbox builds 4.3.14 and 4.3.15

However, I do not believe that it is my antivirus that is causing the problem, but rather using third-party programs such as Mactype or UXStyle, or any other program which loads a dll into another application. For example, the attached VBoxStartup.log

As you can see, it gets stuck trying to verify the integrity of uxtheme.dll, which is provided by one of the 3RD party windows theme patchers.
If you need any more information, please reply and let me know
Attachments
VBoxStartup.log
(48.27 KiB) Downloaded 66 times
nick____
 
Posts: 1
Joined: 31. Jul 2014, 20:45

Re: 4.3.14 conflicts with anti-virus packages.

Postby socratis » 1. Aug 2014, 00:25

nick____ wrote:I do not believe that it is my antivirus that is causing the problem, but rather using third-party programs such as Mactype or UXStyle, or any other program which loads a dll into another application.

That would be an absolutely correct assessment. But, you would known that already if you had read the previous posts in this thread. It is NOT just antivirus. Anything with a "needle" can cause this "DLL injection" ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: 4.3.14 conflicts with anti-virus packages.

Postby mpack » 1. Aug 2014, 15:47

nick____ wrote:or any other program which loads a dll into another application.

You mean, like it says in the first paragraph of the first post in this thread? :roll:
mpack
Site Moderator
 
Posts: 33699
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: 4.3.14 conflicts with anti-virus packages.

Postby kirsche40 » 1. Aug 2014, 19:21

On my Win7-x64 I have only Microsoft's Secure Essentials installed. To me that's the most simple platform configuration but I am affected by this show stopper too. <sarcasm>Looks like perfect organized Software QA</sarkasm>
kirsche40
 
Posts: 7
Joined: 1. Aug 2014, 10:53

Re: 4.3.14 conflicts with anti-virus packages.

Postby arth4 » 1. Aug 2014, 21:53

VirtualBox 4.3.15 (build 95286) seems to be working for me with Symantec Endpoint Protection 12.1.4013.4013
arth4
 
Posts: 1
Joined: 1. Aug 2014, 21:50

Re: 4.3.14 conflicts with anti-virus packages.

Postby JK_Flip_Flop » 1. Aug 2014, 22:31

socratis wrote:
nick____ wrote:I do not believe that it is my antivirus that is causing the problem, but rather using third-party programs such as Mactype or UXStyle, or any other program which loads a dll into another application.

That would be an absolutely correct assessment. But, you would known that already if you had read the previous posts in this thread. It is NOT just antivirus. Anything with a "needle" can cause this "DLL injection" ;)

After reading my logs from my previous post more closely, it looks like the issue is with the Tumbleweed Desktop Validator that our organization uses for smart card credential validation rather than the AV. Looks like McAfee is in the clear.
JK_Flip_Flop
 
Posts: 2
Joined: 31. Jul 2014, 20:35
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Fedora, CentOS, Mint, Ubuntu

Re: 4.3.14 conflicts with anti-virus packages.

Postby VirtualBoxer63525 » 2. Aug 2014, 14:23

Can start GUI but none of the virtual machines.

The virtual machine 'every-vm-failed' has terminated unexpectedly during startup with exit code 1 (0x1).
E_FAIL (0x80004005)
Interface:IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

30c.112c: Log file opened: 4.3.15r95286 g_hStartupLog=0000000000000058 g_uNtVerCombined=0x611db110
30c.112c: Calling main()
30c.112c: SUPR3HardenedMain: pszProgName=VirtualBox fFlags=0x0
30c.112c: SUPR3HardenedMain: Respawn #1
30c.112c: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume2\VirtualBox\VirtualBox.exe)
30c.112c: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume2\VirtualBox\VirtualBox.dll)
30c.112c: supR3HardenedWinDoReSpawn(1): New child fd4.1364 [kernel32].
30c.112c: supR3HardenedWinPurifyChild: PebBaseAddress=000007fffffdf000 cbPeb=0x380
30c.112c: supR3HardNtPuChFindNtdll: uNtDllParentAddr=0000000077870000 uNtDllChildAddr=0000000077870000
30c.112c: supR3HardNtPuChTriggerInitialImageEvents: pvLdrInitThunk=000000007789c340 pvNtTerminateThread=0000000080580000
30c.112c: supHardNtVpScanVirtualMemory: enmKind=CHILD_PURIFICATION
30c.112c: *0000000000000000-fffffffffffeffff 0x0001/0x0000 0x0000000
30c.112c: Error (rc=-5637):
30c.112c: NtQueryVirtualMemory failed for 0000000000010000: 0xc000010a
30c.112c: Fatal error:
30c.112c: NtQueryVirtualMemory failed for 0000000000010000: 0xc000010a
VirtualBoxer63525
 
Posts: 4
Joined: 2. Aug 2014, 14:13

Re: 4.3.14 conflicts with anti-virus packages.

Postby Cousin Shutin » 2. Aug 2014, 20:37

The AV package that I am currently running along with the Host Operating system that it is running with:

System/Host OS:

Manufacturer: Lenovo
Model: Lenovo Win7 PC
Processor: Intel Core i5-2450M CPU @ 2.5GHz
Installed memory (RAM): 6.00 GB
System Type: 64bit Operating System

OS: Windows 7 Home Premium Service Pack 1


AV package/version:
Kaspersky 2014:
Application Version: 15.0.0.463 (a)

Here is the snapshot:
Attachments
Virtualbox error snap.PNG
This is what I get every time I try to run any OS through this virtual machine. I have tried the most recent versions of NodeZero, Ubuntu, and Kali-Linux which all gave me the same error response. Thank you for your time.
Virtualbox error snap.PNG (61.09 KiB) Viewed 7181 times
Cousin Shutin
 
Posts: 1
Joined: 2. Aug 2014, 20:08

Re: 4.3.14 conflicts with anti-virus packages.

Postby mpack » 2. Aug 2014, 22:35

@cousin: please say what VBox build you were using.
mpack
Site Moderator
 
Posts: 33699
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: 4.3.14 conflicts with anti-virus packages.

Postby BrollyLSSJ » 2. Aug 2014, 23:51

Build 95286 fixes my problem and my USB VM is working again.
BrollyLSSJ
 
Posts: 5
Joined: 9. Jun 2007, 19:28

Re: 4.3.14 conflicts with anti-virus packages.

Postby BrollyLSSJ » 3. Aug 2014, 10:00

OK, it only worked once. After booting the system (my computer was off tonight) I got the nt create message again. The VM itself did not update it's log. Will try to see if I can get some logs.
BrollyLSSJ
 
Posts: 5
Joined: 9. Jun 2007, 19:28

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 24 guests