4.3.14 conflicts with anti-virus packages.

Discussions related to using VirtualBox on Windows hosts.

Re: 4.3.14 conflicts with anti-virus packages.

Postby cwahlgren » 29. Jul 2014, 09:42

Hi,

I've tested latest build 4.3.15-95286 and now when I start a VM I get another error dialog:
VB-4.3.15-95286_VM_start_error.png
VB-4.3.15-95286_VM_start_error.png (38.04 KiB) Viewed 5752 times

After closing that dialog I get the E_FAIL dialog (VBoxStartup.log attached):

Code: Select all   Expand viewCollapse view
Failed to open a session for the virtual machine c7a3.

The virtual machine 'c7a3' has terminated unexpectedly during startup with exit code 1 (0x1).  More details may be available in 'C:\VMs\VirtualBox\c7a3\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}


The previous test build 4.3.15-95226 worked and I could successfully compile the VB Addons for CentOS 7 as well. I've not tested any VM that has a GUI.

I'm running Windows 7 Enterprise, Symantec Endpoint Protection.
Attachments
VBoxStartup.log
(21.46 KiB) Downloaded 19 times
cwahlgren
 
Posts: 17
Joined: 10. Jul 2014, 17:24
Location: Stockholm, Sweden
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: CentOS 5,6,7

Re: 4.3.14 conflicts with anti-virus packages.

Postby bird » 29. Jul 2014, 12:00

cwahlgren wrote:Hi,

I've tested latest build 4.3.15-95286 and now when I start a VM I get another error dialog:
VB-4.3.15-95286_VM_start_error.png

<snip><snip>


"Make sure the kernel module has been loaded successfully" is probably on the mark here. Either use the 'sc start vboxdrv' and/or 'sc query vboxdrv' on the command line to start the driver, or use one of the service managers that list driver services to do it. The problem may go away after a reboot too, or/and a reinstall of VirtualBox.

Kind Regards,
bird.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 123
Joined: 10. May 2007, 10:27

Re: 4.3.14 conflicts with anti-virus packages.

Postby LotharL » 29. Jul 2014, 12:18

The version "VirtualBox-4.3.15-95286-Win.exe" now seems to work with my system, too. But I had to reinstall
"Oracle_VM_VirtualBox_Extension_Pack-4.3.14-95030.vbox-extpack" via "Files/Global Settings/Additional Packages".

My System:
Win 7 Sp1/64, VirtualBox-4.3.15-95286-Win, Avast 2014.9.0.2021, Comodo 7.0.317799.4142

Now I can say "Good work, folks" too. ;-)
LotharL
 
Posts: 9
Joined: 23. Apr 2009, 20:24
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Linux

Re: 4.3.14 conflicts with anti-virus packages.

Postby cwahlgren » 29. Jul 2014, 13:08

bird wrote:
cwahlgren wrote:Hi,

I've tested latest build 4.3.15-95286 and now when I start a VM I get another error dialog:
VB-4.3.15-95286_VM_start_error.png

<snip><snip>


"Make sure the kernel module has been loaded successfully" is probably on the mark here. Either use the 'sc start vboxdrv' and/or 'sc query vboxdrv' on the command line to start the driver, or use one of the service managers that list driver services to do it. The problem may go away after a reboot too, or/and a reinstall of VirtualBox.

Kind Regards,
bird.


Hi,

Sorry for the noise - yes, I reinstalled just now and then the problem disappeared (I did reboot the first time).
cwahlgren
 
Posts: 17
Joined: 10. Jul 2014, 17:24
Location: Stockholm, Sweden
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: CentOS 5,6,7

Re: 4.3.14 conflicts with anti-virus packages.

Postby Liquor » 29. Jul 2014, 15:30

Keep getting the following error when trying to start up my vm:

VirtualBox - Error In supR3HardenedWinReSpawn

Error relaunching VirtualBoxVM process:5
Command line: '81954AF5-4D2F-31EB-A142-B7AF187A1C41-suplib-2ndchild
--comment "Windows 2008 Server" -- startvm 85d80462-
fee4-4258-840e-52719bfc8120--no-start-vm-errormsgbox' (rc=-104)

I click through that, by clicking Abort and a VirtualBox Error popup comes up:

Failed to open a session for the virtual machine Windows 2008 Server.

The vm 'Windows 2008 Server' has terminated unexpectedly during startup with exit code 1.

Details:
Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}


I am using VirtualBox 4.3.14 on a Windows 7 machine. Thank you.
Liquor
 
Posts: 2
Joined: 29. Jul 2014, 15:24

Re: 4.3.14 conflicts with anti-virus packages.

Postby bird » 29. Jul 2014, 15:39

Liquor wrote:Keep getting the following error when trying to start up my vm:

VirtualBox - Error In supR3HardenedWinReSpawn

Error relaunching VirtualBoxVM process:5
Command line: '81954AF5-4D2F-31EB-A142-B7AF187A1C41-suplib-2ndchild
--comment "Windows 2008 Server" -- startvm 85d80462-
fee4-4258-840e-52719bfc8120--no-start-vm-errormsgbox' (rc=-104)
<snip><snip>


I would recommend trying the test build I posted earlier today: https://www.virtualbox.org/download/tes ... 86-Win.exe

Kind Regards,
bird.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 123
Joined: 10. May 2007, 10:27

Re: 4.3.14 conflicts with anti-virus packages.

Postby BMN233 » 29. Jul 2014, 17:06

bird wrote:I would recommend trying the test build I posted earlier today: https://www.virtualbox.org/download/tes ... 86-Win.exe

Kind Regards,
bird.


Any chance someone can give us a change-log and explain exactly what is VB doing to the AV/FW protection modules and it's effect system-wide?

P.S. Is it disabling them just for itself or for the system? Also what are the chances another program can use them to hide itself from the installed AV/FW?

P.P.S. Still not ruining with 95286. On clean W7 x64 (SP1 + all updates), ESET, Outpost, Switchable Intel/NVIDIA GPU.
BMN233
 
Posts: 3
Joined: 22. Jun 2014, 14:14

Re: 4.3.14 conflicts with anti-virus packages.

Postby jagitojago » 29. Jul 2014, 18:09

Hi

And is there an "Oracle_VM_VirtualBox_Extension_Pack for 4.3.15 release" ?

TIA

Jago
jagitojago
 
Posts: 1
Joined: 29. Jul 2014, 18:01

Re: 4.3.14 conflicts with anti-virus packages.

Postby r1958 » 29. Jul 2014, 18:56

It looks like the new download 4.3.15.95286 nailed it for me. The OracleLinux65.ova loaded, ran the installer and brought up a desktop!!

Thanks for the diligent effort in getting this working. :D

r1958
r1958
 
Posts: 2
Joined: 27. Jul 2014, 22:02

Re: 4.3.14 conflicts with anti-virus packages.

Postby ssnyder » 29. Jul 2014, 19:32

I also need the extension pack - is one available? 4.3.15 did fix my problem, but I need the USB 2.0 support in the extension pack.

TIA,
Sharon
ssnyder
 
Posts: 2
Joined: 29. Jul 2014, 19:30

Re: 4.3.14 conflicts with anti-virus packages.

Postby Sanyynn » 29. Jul 2014, 19:59

Hey,

I'm using Virtualbox with Windows 8.1 x64.

I encountered the same problem (getting supR3HardenedWinReSpawn errors) when I was installing Ubuntu 14.04 and Debian 7.0 on my machine with v4.3.14 so I downloaded v4.3.15 r95286. With this I could go through the install options fine and (after a few iterations) the system started OK.

Then I encountered this problem:
askubuntu dot com/questions/452108/cannot-change-screen-size-from-640x480-after-14-04-installation-on-virtualbox-os

I did the fix mentioned there (installed virtualbox-guest-dkms with apt-get) but the next time I started the virtual box it didn't get past the loading phase as it threw: "unknown software exception" and quit. Debian also fails to start only when I install this extension, but without it a lot of features are unaccessable. I restarted the system multiple times.

Any ideas?
Sanyynn
 
Posts: 1
Joined: 29. Jul 2014, 19:51

Re: 4.3.14 conflicts with anti-virus packages.

Postby ssnyder » 29. Jul 2014, 20:28

Update on the extension pack - apparently you can use the one from the .14 release with the .15 preview.

Hope it helps others!

Sharon
ssnyder
 
Posts: 2
Joined: 29. Jul 2014, 19:30

Re: 4.3.14 conflicts with anti-virus packages.

Postby Carbonera » 29. Jul 2014, 22:51

The Test build VirtualBox-4.3.15-95226-Win.exe works for me with all my guests.
Windows 7 Home Premium x64
Kaspersky Internet Security 2014

Thanks a lot.
Carbonera
 
Posts: 3
Joined: 23. Jul 2014, 16:56

Re: 4.3.14 conflicts with anti-virus packages.

Postby jefke » 29. Jul 2014, 22:59

This latest build still works for me, just as the previous one, but it still takes exactly 10 seconds to start a VM, way slower than before.
Windows 8.1 pro, 64bit, I5 cpu, 8gb RAM, Norton Internet Security.
jefke
 
Posts: 21
Joined: 15. Aug 2012, 16:17

Re: 4.3.14 conflicts with anti-virus packages.

Postby jefke » 29. Jul 2014, 23:04

BMN233 wrote:
bird wrote:I would recommend trying the test build I posted earlier today: https://www.virtualbox.org/download/tes ... 86-Win.exe

Kind Regards,
bird.


Any chance someone can give us a change-log and explain exactly what is VB doing to the AV/FW protection modules and it's effect system-wide?

P.S. Is it disabling them just for itself or for the system? Also what are the chances another program can use them to hide itself from the installed AV/FW?

P.P.S. Still not ruining with 95286. On clean W7 x64 (SP1 + all updates), ESET, Outpost, Switchable Intel/NVIDIA GPU.


I don't think their will be a statement by Oracle coworkers regarding this "AV-disabling". According to what I learned, they can't see a difference between a malicious and valid DLL-injection, since both malware and AV-packages use the same techniques.
Therefore, I think you can already guess for yourself what they will do to handle this...
If you know that both the good and the bad guys use the same techniques, but you can't make a distinction software-wise if you're dealing with a good guy or a bad guy, what would you do? So I guess you have your answer.
jefke
 
Posts: 21
Joined: 15. Aug 2012, 16:17

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 22 guests