4.3.14 conflicts with anti-virus packages.

Discussions related to using VirtualBox on Windows hosts.

Re: 4.3.14 conflicts with anti-virus packages.

Postby dracula » 27. Jul 2014, 23:37

Bunatl wrote:I installed versions:
...
even 4.3.15...

Which version of 4.3.15? 95226?
dracula
 
Posts: 3
Joined: 19. Jun 2012, 21:44

Re: 4.3.14 conflicts with anti-virus packages.

Postby fditolla » 28. Jul 2014, 00:01

Testing with VirtualBox-4.3.15-95226-Win.exe and I get randomic behavior:

  • Often I get E_FAIL (0x80004005) as reported by many
  • sometimes the VM just starts
  • sometimes it hangs while starting, I can stop the startup process but I cannot try to restart the same VM, only different ones: even If i exit VirtualBox and get in again. I need to kill both VBoxSVC.exe and VitualBox.exe to able again to start the VM that got stuck

the VM I use are Ubuntu/Fedora/Oracle/Centos etc all fail. The host is Windows 7 64 with an Nvidia driver that was causing VirtualBox to fail with 4.3.14.
I've attached the log of failing Oracle Linux VM.
Attachments
VBoxStartup.log
(10.18 KiB) Downloaded 37 times
fditolla
 
Posts: 5
Joined: 27. Jul 2014, 23:51

Re: 4.3.14 conflicts with anti-virus packages.

Postby r1958 » 28. Jul 2014, 00:13

I have a Win7 SP1 Sony f-series laptop with an i7-2630QM processor. Avast version 140727-1
I was trying to use the OracleLinux65.ova and ZS6.3-OL6.4-XE11.2-MySQL5.6.ova virtual images.
I had the same troubles as those folks had in the past few days. Wouldn't start either.

I downloaded the latest, 4.3.15r95226. When I tried them, they both RAN! However, they both also stopped executing with the same error message:
This kernel requires an x86-64 CPU, but only detected an i686 CPU.
Unable to boot = please use a kernal appropriate for your CPU.

I tried looking up the error in the forum. I found something that said flip on your "virtualization". I don't have an AMD, I'm using Intel, but I turned it on anyways. I started having a similar failure to start. I looked up the error on the internet, instead of the forum, and I found something that said I was trying to use the 32-bit versions of the software, to go into the "SETTINGS" and change to the 64-bit. The 64-bit options are only available when I have the "virtualization" enabled (because I went back/forth trying both ways).

So now, trying to execute the correct 64 bit versions with "virtualization" on, (and Avast disabled for an hour), I am still not executing.

I believe there is still a problem, or my Intel virtual machine isn't compatible with the structure that this Oracle VirtualBox is expecting.
Do I have to go back to attempting VMWare?
Thanks
r1958

Screen:
Failed to open a session for the virtual machine Oracle Virtual Sysadmin Days.

The virtual machine 'Oracle Virtual Sysadmin Days' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005). More details may be available in 'C:\Users\rbaptista\VirtualBox VMs\Oracle Virtual Sysadmin Days\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

Startup log:
4d4.22bc: Log file opened: 4.3.15r95226 g_hStartupLog=0000000000000014 g_uNtVerCombined=0x611db110
4d4.22bc: Calling main()
4d4.22bc: SUPR3HardenedMain: pszProgName=VirtualBox fFlags=0x0
4d4.22bc: SUPR3HardenedMain: Respawn #1
4d4.22bc: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume3\Program Files\Oracle\VirtualBox\VirtualBox.exe)
4d4.22bc: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume3\Program Files\Oracle\VirtualBox\VirtualBox.dll)
4d4.22bc: supR3HardenedWinDoReSpawn(1): New child 225c.594 [kernel32].
4d4.22bc: supR3HardenedWinPurifyChild: PebBaseAddress=000007fffffd4000 cbPeb=0x380
4d4.22bc: supR3HardNtPuChFindNtdll: uNtDllParentAddr=0000000077990000 uNtDllChildAddr=0000000077990000
4d4.22bc: supR3HardNtPuChTriggerInitialImageEvents: pvLdrInitThunk=00000000779bc340 pvNtTerminateThread=00000000779e17e0
4d4.22bc: supR3HardNtPuChSanitizeMemory: Freeing exec mem at 0000000000270000 (0000000000270000 LB 0x2000)
4d4.22bc: supR3HardNtPuChSanitizeImage: 0000000077990000 '\Device\HarddiskVolume3\Windows\System32\ntdll.dll'
4d4.22bc: supR3HardNtPuChSanitizeImage: 000000013f720000 '\Device\HarddiskVolume3\Program Files\Oracle\VirtualBox\VirtualBox.exe'
4d4.22bc: supR3HardNtPuChSanitizeImage: 000007feffcb0000 '\Device\HarddiskVolume3\Windows\System32\apisetschema.dll'
4d4.22bc: supR3HardenedWinDoReSpawn(1): Quitting: ExitCode=0xc0000005 rcNt=0x0
r1958
 
Posts: 2
Joined: 27. Jul 2014, 22:02

Re: 4.3.14 conflicts with anti-virus packages.

Postby RichardDawkins » 28. Jul 2014, 09:48

awesome_cool wrote:The only way to resolve this issue would be to install Virtualbox 4.3.12 -93733 win.exe


I confirm it works on my Windows 8.1. Thanks!
RichardDawkins
 
Posts: 2
Joined: 27. Jul 2014, 18:44

Re: 4.3.14 conflicts with anti-virus packages.

Postby MikeDiack » 28. Jul 2014, 10:40

Yet a further update on my tests with 4.3.15 (build 95226):

I said earlier of the 2nd test build: VirtualBox-4.3.15-95226-Win.exe

SIGNIFICANT PROBLEM:
1) Running a Windows 7 SP1 x86 Guest on the Win 7 SP1 x64 Host (Symantec Endpoint Protection) - the guest Win 7 PC very rarely boots successfully and the guest Win 7 PC often hangs during shutdown (which also hangs virtualbox - needing a reboot of the host machine!). Note - it doesn't seem to happen for XP guests on the host PC.

However, I've now noticed that this hang on shutdown ONLY seems to occur if I have the 4.3.15 guest additions installed for the Win 7 SP1 x86 Guest (configured to run the WDDM drives for Aero support). If I uninstall the guest drivers - the hang on shutdown problem (for the guest) goes, if I reinstall the guest drivers, the hang on shutdown problem (for the guest) reappears.

FURTHER UPDATE: The guest Win 7 x86 hang on shutdown consistently does NOT occur (even with the guest additions drivers with full direct 3d support for aero) - if I disable/kill Symantec Endpoint Protection. So there is something odd going on in the interaction between Win 7 guest additions support and SEP/VB as well... I guess it's all to do with the memory management interactions in this new build.

Mike
MikeDiack
 
Posts: 72
Joined: 20. Mar 2009, 15:57
Location: UK
Primary OS: MS Windows 8.1
VBox Version: PUEL
Guest OSses: Win 10, Win 7, XP, Linux, Win 8.1, Win 2000, Win NT 4

Re: 4.3.14 conflicts with anti-virus packages.

Postby Hezd » 28. Jul 2014, 11:54

Hi

Confirming that recent test build "VirtualBox-4.3.15-95226-Win" works on Windows 7 Home Premium x64 with AVG free and AMD/ATI gfx.
I did notice a slight delay starting VM's but not VB manager itself, though when adding VB to AVG exception list the delay disappeared.

Many thanks for a working update! =D
-albeit only a test build, it's still miles better than a nonworking one...
Hezd
 
Posts: 6
Joined: 16. Jul 2014, 14:06

Re: 4.3.14 conflicts with anti-virus packages.

Postby StenlyTvidl » 28. Jul 2014, 14:22

Hello.
If you use the startup 4.3.14-95030 first swore to dll error then when you start the guest OS.
If you use the 4.3.15-95226 when running on dll not swear, but when you start the guest OS error persists. Enclosing LOG file.
Attachments
VBoxStartup.log
(32.55 KiB) Downloaded 37 times
StenlyTvidl
 
Posts: 2
Joined: 28. Jul 2014, 14:13

Re: 4.3.14 conflicts with anti-virus packages.

Postby adasiko » 28. Jul 2014, 17:44

VirtualBox-4.3.15-95226
Yay! It works for me on windows 7 x64 with symantec endpoint protection 12.1, visual studio and nvidia drivers.
adasiko
 
Posts: 13
Joined: 16. Sep 2012, 12:20
Location: Russia
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows, Linux, QNX, Haiku, OS X

Re: 4.3.14 conflicts with anti-virus packages.

Postby Steve Richards » 28. Jul 2014, 18:41

I can also report 4.3.15 is working for me. W8.1, nvidia, Malwarebytes
Steve Richards
 
Posts: 16
Joined: 18. Nov 2008, 14:38

Re: 4.3.14 conflicts with anti-virus packages.

Postby stefan.becker » 28. Jul 2014, 20:36

For me its working too with 95226.

Windows 8.1 Update 1 64 Bit, AMD A8 incl. Radeon VGA, ESET Nod32 as AV.
stefan.becker
Volunteer
 
Posts: 7626
Joined: 7. Jun 2007, 21:53

Re: 4.3.14 conflicts with anti-virus packages.

Postby MikeDiack » 28. Jul 2014, 23:43

Quick question to Stefan, Steve Richards and other recent posters of successes with 4.3.15 build 95226 ...

You've got the new 4.3.15 build running on different systems (NB I'm using Win 7x64 SP1, with SEP 12.1, Nvidia drivers and visual studio installed as well), and you report that Virtual Box is working...
BUT:
Have you tried running some virtual machines (not just starting the manager)?
Did they run OK? I'm keen to find out if the flakey behaviour of Windows 7 guests with the Windows 7 guest drivers (with Direct 3d/WDDM/Aero support on), is working for you? For me, it consistently fails)
MikeDiack
 
Posts: 72
Joined: 20. Mar 2009, 15:57
Location: UK
Primary OS: MS Windows 8.1
VBox Version: PUEL
Guest OSses: Win 10, Win 7, XP, Linux, Win 8.1, Win 2000, Win NT 4

Re: 4.3.14 conflicts with anti-virus packages.

Postby birrellwalsh » 29. Jul 2014, 06:47

I have installed 4.3.12, which works for me, while 4.3.15 did not on my 32-bit Windows 7 system.

I wonder if the extension pack for 4.3.12 is still available, as I would like to have access to the USB and that seems to require the Extension Pakc.

Thanks
birrellwalsh
 
Posts: 8
Joined: 18. Jul 2014, 07:17

Re: 4.3.14 conflicts with anti-virus packages.

Postby J.L. » 29. Jul 2014, 07:18

A little navigating of Virtualbox downloads results in this: http://download.virtualbox.org/virtualb ... ox-extpack

I'm still waiting for any news of the next test build. Plus, I wonder if anyone using Nvidia Optimus can replicate preferred GPU for virtualbox.exe not being applied.
Windows 10 is the actual host, not 8 (no option).
J.L.
 
Posts: 78
Joined: 17. Jan 2013, 07:38
Primary OS: MS Windows 8
VBox Version: PUEL
Guest OSses: LMDE, Ubuntu, Windows XP, Windows 7

Re: 4.3.14 conflicts with anti-virus packages.

Postby bird » 29. Jul 2014, 08:13

New test build: https://www.virtualbox.org/download/tes ... 86-Win.exe

Should address the 0xc0000005 problem with avast and hopefully with a few other AV products.

Enjoy,
bird.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 123
Joined: 10. May 2007, 10:27

Re: 4.3.14 conflicts with anti-virus packages.

Postby J.L. » 29. Jul 2014, 09:22

Still the same error with Zemana AntiLogger installed. I'll attach the log anyways.

FileBox Extender, Nvidia is still blocked, as well as Avast I suspect. Performance is laughably bad compared to what VirtualBox should be without DLL injections.
Attachments
VBoxStartup.zip
Replacement log due to corrupt installation. Thank AX64.
(5.26 KiB) Downloaded 26 times
Last edited by J.L. on 29. Jul 2014, 09:56, edited 2 times in total.
Windows 10 is the actual host, not 8 (no option).
J.L.
 
Posts: 78
Joined: 17. Jan 2013, 07:38
Primary OS: MS Windows 8
VBox Version: PUEL
Guest OSses: LMDE, Ubuntu, Windows XP, Windows 7

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: andrei14921 and 40 guests