VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postings relating to old VirtualBox pre-releases

VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby MichaelH » 12. Jul 2014, 21:13

I uninstalled 4.3.12, rebooted, and installed 4.3.14 RC1 94905. Afterwards I get the error in supR3HardenedWinReSpawn. Error relaunching VirtualBox VM process 5 Command line: (the rest is in the picture). I've tried both with and without the extension pack installed and there is no change. I've also tried uninstalling and reinstalling with right click "Run as admin". I've tried launching all of the VMs I have and none work. There was another error I didn't get a screenshot of that said "failed install ntcreatesection".

What should I try next? I'd like to help test the release candidate.
Attachments
Vbox4.3.14RC1-1.jpg
Vbox4.3.14RC1-1.jpg (67.61 KiB) Viewed 15719 times
Vbox4.3.14RC1-2.PNG
Vbox4.3.14RC1-2.PNG (21.16 KiB) Viewed 15719 times
MichaelH
 
Posts: 5
Joined: 12. Jul 2014, 21:00
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, Windows 8, RHEL

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby yesoos » 12. Jul 2014, 21:55

I'm having exactly the same issue in this thread: Windows 8.1 x64 Host, can't start any VM. (can't post links yet). Windows 8.1 x64 host, also tried new clean installs, with removing profile, recreating vms etc. Still have this error.
yesoos
 
Posts: 8
Joined: 12. Jul 2014, 20:45
Primary OS: MS Windows 8
VBox Version: PUEL
Guest OSses: Linux, Windows, BSD

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby MatthijsM » 13. Jul 2014, 23:02

Start of VBox 4.3.14_RC1-94905 on Win7prof/SP1 gives the following error dialogue:
VirtualBox-4.3.14_RC1-94905-Win_Errors.png
Wimdows error dialogue
VirtualBox-4.3.14_RC1-94905-Win_Errors.png (71.94 KiB) Viewed 15635 times

Reinstalling VBox 4.3.12 resolves the problem...
MatthijsM
 
Posts: 1
Joined: 13. Jul 2014, 22:48

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby frank » 14. Jul 2014, 13:35

Thank you. Are you running any virus scanner on your system? If so, which one?
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby yesoos » 14. Jul 2014, 20:24

Frank,

I'm running Kaspersky Internet Security (latest version), but had the same issue when disabling KIS.
yesoos
 
Posts: 8
Joined: 12. Jul 2014, 20:45
Primary OS: MS Windows 8
VBox Version: PUEL
Guest OSses: Linux, Windows, BSD

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby MichaelH » 15. Jul 2014, 23:56

I am running Avast! free antivirus. 2014.9.0.2018 with current definitions. It didn't report anything blocked or quarantined during or after the install.
MichaelH
 
Posts: 5
Joined: 12. Jul 2014, 21:00
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, Windows 8, RHEL

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby frank » 16. Jul 2014, 10:23

The problem is not the virus scanning engine but the habit of virus scanners to map certain DLLs into Windows processes. VirtualBox 4.3.14 has extended hardening features which may conflict with virus scanners. We did several tests but obviously didn't catch every case. The final 4.3.14 release contains more fixes in this regards but I've read in other topics that certain users have still problems :-(
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby MikeDiack » 16. Jul 2014, 11:25

Sorry to say Frank that the final build still is very problematic in this area. Even disabling Avast, Comodo, Symantec AV's still prevents the final build starting correctly.

Can I suggest pulling this release and updating it to give a option to turn the hardening support on or off?

Mike
MikeDiack
 
Posts: 66
Joined: 20. Mar 2009, 15:57
Location: UK
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win 7, Vista, XP, Linux, Win 8/ Win 8.1, Win 2000, Win NT 4

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby yesoos » 16. Jul 2014, 20:45

@Frank

Still have the same issue with final version of 4.3.14. Should I create a bug for that or have this already been created?
yesoos
 
Posts: 8
Joined: 12. Jul 2014, 20:45
Primary OS: MS Windows 8
VBox Version: PUEL
Guest OSses: Linux, Windows, BSD

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby MichaelH » 16. Jul 2014, 21:36

Install of 4.3.14-95030 immediately shows this error. Is there a bug I should post to at this point? I'll uninstall my antivirus and see if that helps.
Attachments
vbox4.3.14.JPG
vbox4.3.14.JPG (19.77 KiB) Viewed 15192 times
MichaelH
 
Posts: 5
Joined: 12. Jul 2014, 21:00
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, Windows 8, RHEL

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby Jacob Klein » 16. Jul 2014, 21:39

When posting, please also indicate your Operating System, just in case the issue here is Operating-System-specific.
I have not had problems with Windows 8.1 Update 1 x64, using the built-in Windows Defender antivirus.
Jacob Klein
 
Posts: 506
Joined: 20. Nov 2013, 01:07

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby MichaelH » 16. Jul 2014, 23:11

I am running Windows 7 SP1 x64 all security updates installed.

After uninstalling Avast! Antivirus and reinstalling VirtualBox 4.3.14-95030 VMs launch just fine. I'll see if reinstalling Avast! at this point breaks it again or not.

If if it breaks again I'll switch to Windows Defender for now.
MichaelH
 
Posts: 5
Joined: 12. Jul 2014, 21:00
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, Windows 8, RHEL

Re: VirtualBox 4.3.14 RC1 94905 for Windows Errors

Postby MichaelH » 16. Jul 2014, 23:33

Okay, reinstalling Avast! lead to the same problem. Installing Microsoft Security Essentials doesn't seem to cause any problems though.
MichaelH
 
Posts: 5
Joined: 12. Jul 2014, 21:00
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, Windows 8, RHEL


Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 0 guests