Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Discussions related to using VirtualBox on Windows hosts.

Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby sarhadi » 18. Jul 2008, 21:05

I am getting the following error whenever I try to create a new vm on virtualbox.

Callee RC: REGDB_E_CLASSNOTREG (0x80040154)

Host is windows xp2

I tried on different machines for different vmachines but same error for all vms on all machines.

Any help????
sarhadi
 
Posts: 1
Joined: 18. Jul 2008, 21:00

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby manzolo » 23. Dec 2009, 23:21

I solved this problem installing microsoft .NET framework 3.5!
My problem was generated with a compiled version (built on my machine) of VirtualBox OSE (3.1.2)
Try to run:

VBoxSVC.exe /ReRegServer
regsvr32.exe VBoxC.dll

I hope to help you...
manzolo
 
Posts: 1
Joined: 23. Dec 2009, 23:18
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby wascou » 19. Jun 2011, 02:39

I've got the issue after an update.
The following line worked for me :
VBoxSVC.exe /ReRegServer
wascou
 
Posts: 1
Joined: 19. Jun 2011, 02:36
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Debian

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby stskr » 12. Aug 2014, 12:58

I have the same problem.
I installed VirtualBox v4.3 under Windows XP SP3.
After I did the described steps, VirtualBox doesn't start. It can start only after reinstallation.
I tried also to reinstall . NET Framework 3.5, but it wasn't helpful.
stskr
 
Posts: 3
Joined: 12. Aug 2014, 12:51

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby stskr » 21. Aug 2014, 09:02

Probably, it is a problem with new version, because previous versions of virtualbox seemed to work under Windows XP.
Does anyone know which version works well with Windows XP?
stskr
 
Posts: 3
Joined: 12. Aug 2014, 12:51

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby stskr » 21. Aug 2014, 16:14

I installed version 3.2 instead of 4.3. I did all this steps again, but it was helpful.
stskr
 
Posts: 3
Joined: 12. Aug 2014, 12:51

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby mrpalferink » 27. Jul 2015, 00:06

I solved it myself, please take a look here for details.
look at stackoverflow for solved-virtualbox-callee-rc-regdb-e-classnotreg-0x80040154

Was something with the xml file in your user directory...
mrpalferink
 
Posts: 1
Joined: 26. Jul 2015, 23:50

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby yayo » 18. Aug 2015, 19:11

i guess searching Stopbyte for "How to solve VirtualBox Error: "Callee RC: REGDB_E_CLASSNOTREG (0x80040154)"" will give you all possible solution of how to solve it.
that worked for me well. :D :P
yayo
 
Posts: 3
Joined: 18. Aug 2015, 18:57

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby aaalekseyyy@yandex.ru » 8. Nov 2015, 13:11

After you upgrade to VirtualBox-5.0.8-103449 started getting error: Virtualbox "Callee RC: REGDB_E_CLASSNOTREG" (0x80040154)
No advice on the Internet did not help.
It helped only delete the entire contents of the folder C: \ Users \ <user> \. VirtualBox and then restart Oracle VM VirtualBox shortcut on the desktop.
Apparently when you remove the previous version of Virtualbox folder C: \ Users \ <user> \. VirtualBox is removed.
As the contents of the folder should be removed manually after reinstalling VirtualBox, as well as in case of damage VirtualBox, for example due to lack of space on the hard disk.
Not to be confused with the folder C: \ Users \ <user> \ VirtualBox VMs
This folder appears later, only after the establishment has a particular virtual machine.

sorry for machine translation.
aaalekseyyy@yandex.ru
 
Posts: 1
Joined: 8. Nov 2015, 13:04

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby erika neri » 28. Feb 2017, 01:06

Hi I´m Erika Neri and I solved...

In "C:\Users\''UserName''\.VirtualBox", Delete the archive "VirtualBox.xml", Copy and Paste the archive "VirtualBox.xml-prev" And Change the name to "VirtualBox.xml"

Ready
erika neri
 
Posts: 1
Joined: 28. Feb 2017, 01:05

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby socratis » 28. Feb 2017, 12:49

@Erika Neri
You posted your "solution" in ticket #14296 and I wanted to reply to you over there as well, but it was late and... I didn't. I will reply there as well for anyone reading the ticket, instead of this thread.

What you did has absolutely nothing to do with the Windows registry. There is no way on earth that re-creating the VirtualBox.xml fixed this specific error. This error is due to a misconfigured Windows registry key, either bad class, bad bindings or incorrectly set security access (most probably the last). The specific registry key is created/updated only during the VirtualBox installation. Re-creating the VirtualBox.xml file, I repeat, has absolutely nothing to do with that. It may have fixed/corrected other issues with your VirtualBox installation, just not this one.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 23277
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby socratis » 1. Mar 2017, 09:50

From ticket #14296:
klaus wrote:Socratis, this time you're underestimating the powers of VBoxSVC when it comes to producing misleading error messages. It is possible (but it should not happen!) that a broken VirtualBox.xml has this effect. In the past (up to 4.3 IIRC) any kind of VirtualBox.xml corruption caused a failure to start it, leading to such cryptic errors. Since 5.0 we totally revamped, hopefully preventing such issues, but unless we know what corruption actually can fool our improvement it's impossible to say...

socratis wrote:@Erika Neri: in light of these new "clues", I'd have to say I might have jumped the gun on this one. I'm sorry for that. My apologies...

@klaus: Wait... what??? A corrupt VirtualBox.xml could potentially produce a COM error? With the correct CLSID? Seriously? If that was the case, the least I can say is that the total revamp took a long time to materialize! Man, that can throw someone way, way off... :(
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 23277
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby socratis » 2. Mar 2017, 07:33

From ticket #14296:
klaus wrote:Yes, it's a sad fact. It took us a long time to realize that there's a surprising difference between COM (which VirtualBox uses on Windows) and it's partial clone XPCOM (used on all other host OSes): if the construction of the initial IVirtualBox object instance fails (and it used to fail if the config file contained rubbish), then XPCOM happily passes the detailed error description along to the user. COM loses this error information entirely (there is no technical reason whatsoever for this, there must be some place in that big black box which explicitly clears it) and simply says REGDB_E_CLASSNOTREG.

It's an error code used for all sorts of issues related to the inability to create the instance, ranging from registry screwups which means that the COM server can't be found over all sorts of VBoxSVC process start failures to this failure in the code which creates the instance.

socratis wrote:Excellent!!! The description of the problem I mean, not the problem itself. ;)

So, just to make it clear, if this error appears in VirtualBox >= 5.x.x it *is* due to COM errors in Windows, but if it's in VirtualBox < 5.x.x it can be a lot of things, including (but not limited to), a bad/rogue VirtualBox.xml, and it is cross-platform.

If that sums it up, that information will help a great deal in the triage of the reports in the forums. I'll update the thread that @Erika posted with your response, so that it gets a more widespread audience. Thanks!
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 23277
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Callee RC: REGDB_E_CLASSNOTREG (0x80040154) error on xp2

Postby socratis » 2. Mar 2017, 17:24

klaus wrote:There's never a clear cut black/white distinction in the real world unfortunately.

I suspect that Erika's broken VirtualBox.xml somehow made VBoxSVC crash during the initial IVirtualBox object instance construction. It may or may not be a cross-platform issue, but it makes our improved code (which intends to eliminate this error, as long as it's caused by our code) not work the way it was intended.

If there's someone out there who has a VirtualBox.xml file which makes the 5.x GUI (or anything else) fail to start with this error, we'd really appreciate if we could get the file. It is easy to test: rename VirtualBox.xml to some other name and start VirtualBox. If that works then terminate VirtualBox again and check in Task Manager that there's no process called VBoxSVC running any more. After that one can e.g. try Erika's hint of using VirtualBox.xml-prev (keeping in mind hat it's not guaranteed to be the current state of the VM registry).

Until we have an idea what's going on we can't do much.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 23277
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: stagadet and 51 guests