Shared folders will not mount after 3.10 update

Discussions about using Linux guests in VirtualBox.

Shared folders will not mount after 3.10 update

Postby RRJ » 28. Mar 2014, 17:44

Hi all,

I installed the VirtualBox-4.3.10-93012-Win.exe update today.

My Ubuntu VM booted OK and worked normally, but then I got the prompt to update the guest additions. After doing that and rebooting I cannot mount shared folders. I get this error:
mount: wrong fs type, bad option, bad superblock on /home/richard/Xdata,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

and in dmesg I see
sf_read_super_aux err=-22
I tried recreating the shared folder but it made no difference.

The guest is running Ubuntu 12.04 with a stripped down 3.8.13 kernel.

Maybe there is a change in the guest additions which require a kernel module which we do not include?

Any help greatly appreciated.

Thanks,
Richard
RRJ
 
Posts: 3
Joined: 28. Mar 2014, 17:27

Re: Shared folders will not mount after 3.10 update

Postby Perryg » 28. Mar 2014, 17:52

Debian based machines seem to have changed the location of the install, pointing to location that does not exist.

Look at /sbin/mount.vboxsf and see if the link is broken, and see if the Guest additions are installed in /opt, and if so see below.

The work-a-round is to run the following in a terminal on the guest.
Code: Select all   Expand viewCollapse view
sudo ln -s /opt/VBoxGuestAdditions-4.3.10/lib/VBoxGuestAdditions \
/usr/lib/VBoxGuestAdditions
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Shared folders will not mount after 3.10 update

Postby RRJ » 28. Mar 2014, 18:24

Yes, the link was broken.
The work around has fixed the problem

Thanks for the quick response
Richard
RRJ
 
Posts: 3
Joined: 28. Mar 2014, 17:27

Re: Shared folders will not mount after 3.10 update

Postby ~A! » 14. Apr 2014, 04:15

The link was broken for me as well, created an account here specifically to say thanks.
~A!
 
Posts: 1
Joined: 14. Apr 2014, 04:15

Re: Shared folders will not mount after 3.10 update

Postby vboxuser12 » 14. Apr 2014, 19:02

This thread was useful, but did not provide the actual fix. So I created an account to post this.

Host: Windows 7 64bit
Guest: Ubuntu 13.10 , recently updated
Virtual Box version: 4.3.10-93012 (updated after the failure started, did not resolve)

Symptoms:
1. mount command would fail with "protocol error"
2. "sf_read_super_aux err=-71" shows up in "dmesg|tail" output
3. "ls -l /sbin/mount*" shows a broken link.

This is the fix that worked for me.
Code: Select all   Expand viewCollapse view
sudo ln -f -s /opt/VBoxGuestAdditions-4.3.10/lib/VBoxGuestAdditions/mount.vboxsf /sbin/mount.vboxsf


After that the mount command worked without issue:
sudo mount -t vboxsf -o uid=1000,gid=1000 <shared_folder_name> <shared_folder_mount_path_in_guest>
vboxuser12
 
Posts: 1
Joined: 14. Apr 2014, 18:52

Re: Shared folders will not mount after 3.10 update

Postby joosts » 15. Apr 2014, 19:52

Well vboxuser12, I don't know if yours was the only solution to my poblem, but you sure brought an hour of trying to a succesfull end.
Thanks!
joosts
 
Posts: 1
Joined: 15. Apr 2014, 19:44

Re: Shared folders will not mount after 3.10 update

Postby amason » 2. May 2014, 01:04

Perry: I have a Ubuntu14.04 VM, and it had a link /sbin/mount.vboxsf to /usr/lib/VBoxGuestAdditions/mount.vboxsf, which wasn't there, so your fix would work.

I have a CentOS 6.5 VM, and it has a link /sbin/mount.vboxsf to /usr/lib64/VBoxGuestAdditions/mount.vboxsf, which in turn points to /opt/VBoxGuestAdditions-4.3.10/lib/VBoxGuestAdditions, so it works fine.

What do you think the right fix for Debian/Ubuntu is? Seems like if the GAs just pointed straight to /opt/... it would work for at least those 2 cases. It seems this changed in 4.2.16. If I should submit a bug report I'll figure out how to do so, but I need to know what to ask for.

Thanks,
Andy
amason
 
Posts: 3
Joined: 2. May 2014, 00:46
Location: Ottawa
Primary OS: FreeBSD
VBox Version: OSE other
Guest OSses: Ubuntu, CentOS

Re: Shared folders will not mount after 3.10 update

Postby Perryg » 2. May 2014, 01:29

No need for a bug ticket. The reason for the issue was found and fixed. It is to be included in the next maintenance release. You can run the guest/s with the older guest additions until then next release or use symlinks.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Shared folders will not mount after 3.10 update

Postby amason » 2. May 2014, 18:13

Sweet, thx! Links it is. So much for my usefulness :)

Andy
amason
 
Posts: 3
Joined: 2. May 2014, 00:46
Location: Ottawa
Primary OS: FreeBSD
VBox Version: OSE other
Guest OSses: Ubuntu, CentOS

Re: Shared folders will not mount after 3.10 update

Postby Jan Miller » 14. Jul 2014, 17:05

Perryg wrote:Debian based machines seem to have changed the location of the install, pointing to location that does not exist.

Look at /sbin/mount.vboxsf and see if the link is broken, and see if the Guest additions are installed in /opt, and if so see below.

The work-a-round is to run the following in a terminal on the guest.
Code: Select all   Expand viewCollapse view
sudo ln -s /opt/VBoxGuestAdditions-4.3.10/lib/VBoxGuestAdditions \
/usr/lib/VBoxGuestAdditions

Thanks, this worked after my link was undoubtedly broken after updating from 4.3.06 to 4.3.10.
Jan Miller
 
Posts: 1
Joined: 14. Jul 2014, 17:05
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu 12.04


Return to Linux Guests

Who is online

Users browsing this forum: Exabot [Bot] and 6 guests