Issues after installing VirtualBox 4.3

Discussions related to using VirtualBox on Windows hosts.

Issues after installing VirtualBox 4.3

Postby GeertVc » 20. Oct 2013, 09:42

Hi,

Host OS: Windows XP - Home Edition - SP3 / Guest OS: Lubuntu 12.10.

I recently upgraded VirtualBox from 4.2.18 to 4.3. Until I upgraded, all worked fine. When I finish my VirtualBox session, I always save the machine state to be able to start up quickly the next time I need it.

However, since I moved to 4.3, I'm not able any more to start up from a saved session. When I start the session directly (that is, without starting up VirtualBox 4 Manager first), the state is restored, but the moment the 100% restoring is reached, the session kicks out.

When I then start up VirtualBox 4 Manager and start the saved state from there, I see the following error message:

2013-10-20 09_32_05-VirtualBox - Error.jpg
Error dialogue box when starting saved state in VirtualBox 4.3
2013-10-20 09_32_05-VirtualBox - Error.jpg (24.56 KiB) Viewed 2551 times


I have to discard the saved state and start from scratch each and every time now, which is quite inconvenient.

PS: I've never had this issue until I started to use 4.3.

Any ideas?
Best rgds,
--Geert
GeertVc
 
Posts: 17
Joined: 30. Dec 2007, 14:53
Location: Belgium
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 12.04

Re: Issues after installing VirtualBox 4.3

Postby noteirak » 20. Oct 2013, 21:06

Saved state cannot be used accross different version, as the internal format change (this is actually what the error is telling you).
Nothing can be done except discarding the state if you move accross versions.
Hyperbox - Virtual Infrastructure Manager - http://hyperbox.altherian.org
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 4036
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Re: Issues after installing VirtualBox 4.3

Postby klaus » 21. Oct 2013, 11:27

Save state breakages across versions (when upgrading - downgrading is expected to fail) are bugs. Saved states are supposed to work perfectly, and this is a case where it doesn't, and it should be fixed.
klaus
Oracle Corporation
 
Posts: 282
Joined: 10. May 2007, 14:57

Re: Issues after installing VirtualBox 4.3

Postby mpack » 21. Oct 2013, 13:05

If saved state worked across versions this time, AFAIK that would be a first. This is the first time I've heard that it's even supposed to work.
mpack
Site Moderator
 
Posts: 16541
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Issues after installing VirtualBox 4.3

Postby Ramshankar » 21. Oct 2013, 13:40

We have always tried to have a policy that breaking saved state is a no-go, but unfortunately due to the complexity and size of the test matrix, we've had problems in the past (and from this thread, probably still do) with saved-state compatibility, so it's understandable that you're surprised that saved-states are supposed to be compatible. We do try to keep compatibility though :) This is one area where our automated testing needs to cover more.
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 656
Joined: 7. Jan 2008, 16:17

Re: Issues after installing VirtualBox 4.3

Postby GeertVc » 25. Oct 2013, 09:02

noteirak wrote:Saved state cannot be used accross different version, as the internal format change (this is actually what the error is telling you).
Nothing can be done except discarding the state if you move accross versions.


Even if that would be the case, then stil there's some issue: after the above mentioned crash, if I start all over from scratch, then we can't speak of "accross different versions" any more, since I'm starting my Lubuntu session afresh, agree?

So, once this step is executed once, I should not get the above mentioned issues any more, also agree?

Well, I do still have them, over and over again.

As I said, I always have to start from scratch now, since I've switched to version 4.3... :(

And I also want to repeat that I have never had this issue before when I switched to a newer version of VirtualBox. So, that was across different versions all the time, without any problems so far, until now...
Best rgds,
--Geert
GeertVc
 
Posts: 17
Joined: 30. Dec 2007, 14:53
Location: Belgium
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 12.04

Re: Issues after installing VirtualBox 4.3

Postby Ramshankar » 25. Oct 2013, 11:05

Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 656
Joined: 7. Jan 2008, 16:17

Re: Issues after installing VirtualBox 4.3

Postby GeertVc » 26. Oct 2013, 16:45



Thanks for pointing out the ticket. Awaiting the upcoming 4.3.x release!
Best rgds,
--Geert
GeertVc
 
Posts: 17
Joined: 30. Dec 2007, 14:53
Location: Belgium
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 12.04

Re: Issues after installing VirtualBox 4.3

Postby GeertVc » 2. Nov 2013, 14:56

GeertVc wrote:


Thanks for pointing out the ticket. Awaiting the upcoming 4.3.x release!


Hi,

Just installed VirtualBox 4.3.2 (including an update of the VirtualBox Guest Additions). According to the release notes, the bug 12222 (VMM: fixed PATM saved state incompatibility for software virtualized VMs (bug #12222)) should be solved.

I've tried out the new version and the problem remains, be it with another error message this time. See image below:

2013-11-02 13_37_03-VirtualBox - Error.jpg
2013-11-02 13_37_03-VirtualBox - Error.jpg (23.91 KiB) Viewed 1899 times


Where the error message previously was "VERR_SSM_FIELD_NOT_CONSECUTIVE", this time it's "VERR_SSM_LOADED_TOO_MUCH" that I see when I want to restart a saved session.

I've also attached the corresponding Vbox.log file, in which I see another error message, prior to the one given above:

"00:00:05.201750 AIOMgr: Preparing flush failed with VERR_NOT_SUPPORTED, disabling async flushes".

Don't know if there's a relation between the two, though...
Attachments
VBox.log
VirtualBox log file created when failed to (re)load saved session.
(77.69 KiB) Downloaded 11 times
Best rgds,
--Geert
GeertVc
 
Posts: 17
Joined: 30. Dec 2007, 14:53
Location: Belgium
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 12.04

Re: Issues after installing VirtualBox 4.3

Postby noteirak » 3. Nov 2013, 11:18

Might be useful to also add your post into the ticket
Hyperbox - Virtual Infrastructure Manager - http://hyperbox.altherian.org
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 4036
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Re: Issues after installing VirtualBox 4.3

Postby GeertVc » 3. Nov 2013, 18:41

noteirak wrote:Might be useful to also add your post into the ticket


Done: https://www.virtualbox.org/ticket/12222#comment:13
Best rgds,
--Geert
GeertVc
 
Posts: 17
Joined: 30. Dec 2007, 14:53
Location: Belgium
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 12.04

Re: Issues after installing VirtualBox 4.3

Postby loverboy » 4. Nov 2013, 17:13

Different kind of error, but I can't resume saved states with version 4.3
(see attachments)

The only way to work is Powering Off the guest machine
Attachments
Clipboard02.jpg
Clipboard02.jpg (67.72 KiB) Viewed 1734 times
MyXP4Portable-2013-11-04-15-37-13.log
(45.76 KiB) Downloaded 9 times
loverboy
 
Posts: 1
Joined: 4. Nov 2013, 17:09


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Martin and 29 guests