Can't get any USB device to show up in VM

Discussions related to using VirtualBox on Windows hosts.

Can't get any USB device to show up in VM

Postby cr_bin » 4. Jun 2012, 05:50

Win XP, sp3 Host, Nas4free guest. VB version 4.1.16 with matching extensions installed.
I've rebooted, changed the sequence of when I plug in my USB memory stick, etc., have yet to see any usb device show up. I'm assuming when you add a USB filter VB is supposed to be showing existing USB devices? Else what is the icon with the green + for? The help tip says it will add a filter for the 'selected' device - yet I've never seen any devices show up.

Going to the command line - "vboxmanager list usbhost" shows <none>. I've tried it with / without VBox running, with / without my VM running - always shows <none>.

I've made a pass through uninstalling any windows application that may want to grab the USB device but may have missed something. Even when windows has grabbed the device, shouldn't it be listed in the list usbhost output?

Also, I've tried with / without EHCI box checked.
Attachments
Nas4Free-2012-06-03-22-21-13.zip
(7.82 KiB) Downloaded 44 times
cr_bin
 
Posts: 6
Joined: 4. Jun 2012, 05:34

Re: Can't get any USB device to show up in VM

Postby naemrr » 6. Jun 2012, 01:36

Perhaps this will be of use.

https://forums.virtualbox.org/viewtopic ... 88#p224382

I also recommend that in the future a little searching before posting, between Google and the forum search this and several other answers would have come up.
naemrr
 
Posts: 83
Joined: 17. Dec 2011, 22:56
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: ubuntu natty, windows 2k3, windows xp pro, windows vista x86 & x64, debian squeeze

Re: Can't get any USB device to show up in VM

Postby cr_bin » 9. Jun 2012, 15:08

Naemrr - thanks for the reply. I read the posting you referenced and followed its directions, but it didn't fix me. That posting and the several others I had found before I posted the original question seem to be focusing on getting the usb filter setup correctly in vbox. That posting and the VBox manual both point to "VBoxManage list usbhost" as one method to determine what usb devices the host is seeing and what the vendor and product IDs are. As I said in my original post, VBoxManage list usbhost says <none>. I'm assuming (please, someone confirm) that "VBoxManage list usbhost" is supposed to show the usb devices regardless of my VM filter or any of the issues regarding windows grabbing USB devices before VBox can get it. Based on that assumption it seems my problem is more basic than just not having the correct filter setup or not plugging in my usb device in the correct sequence.
cr_bin
 
Posts: 6
Joined: 4. Jun 2012, 05:34

Re: Can't get any USB device to show up in VM

Postby Perryg » 9. Jun 2012, 15:28

Does VBoxManage list extpacks show the extpack and that it matches the current version of VirtualBox?
Perryg
Site Moderator
 
Posts: 33727
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Can't get any USB device to show up in VM

Postby cr_bin » 9. Jun 2012, 18:35

Yes, extpacks version matches what vbox <help><about> shows.

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe list extpacks
Extension Packs: 1
Pack no. 0: Oracle VM VirtualBox Extension Pack
Version: 4.1.16
Revision: 78094
Description: USB 2.0 Host Controller, VirtualBox RDP, PXE ROM with E1000 support.
VRDE Module: VBoxVRDP
Usable: true
Why unusable:
cr_bin
 
Posts: 6
Joined: 4. Jun 2012, 05:34

Re: Can't get any USB device to show up in VM

Postby Perryg » 9. Jun 2012, 18:49

I have no idea then. Consider posting a ticket at bugtracker. Look for other topics first that matches your issue.
Perryg
Site Moderator
 
Posts: 33727
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Can't get any USB device to show up in VM

Postby cr_bin » 10. Jun 2012, 23:09

Thanks. What about the output of vboxmanage list usbhost? Does virtualBox and/or a VM have to be running to get valid output? Does it matter what filters are defined? I assume it be similar to what I'd see with a linux lsusb command?
Just to get a feel for how it is supposed to work I'm now trying it on my laptop where I run ubuntu. Below is what I get. Does this make sense or am I doing something wrong? Since this is a different OS, different PC, slightly older version of VB (4.1.12), yet I'm getting the same thing I'm suspecting I'm not understanding how "vboxmanage list usbhost" is meant to be used.

ruth@ruth-laptop:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) 64MB QDI U2 DISK
ruth@ruth-laptop:~$ vboxmanage list usbhost
Host USB Devices:

<none>
cr_bin
 
Posts: 6
Joined: 4. Jun 2012, 05:34

Re: Can't get any USB device to show up in VM

Postby Perryg » 10. Jun 2012, 23:23

No they don't need to be running. VBoxManage list usbhost is meant to show what the host says is available.

Since it shows nothing, and I assume you have something USB plugged into the host, it must be something that is blocking VBox from seeing it on Windows.
Perryg
Site Moderator
 
Posts: 33727
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Can't get any USB device to show up in VM

Postby cr_bin » 10. Jun 2012, 23:53

That last post was from a laptop running lubuntu - so it's not just windows. I've tried couple different USB thumb drives. So far the common denominators are virtual box and the operator, and no one else seems to be complaining about this.
cr_bin
 
Posts: 6
Joined: 4. Jun 2012, 05:34

Re: Can't get any USB device to show up in VM

Postby Perryg » 11. Jun 2012, 00:03

Linux you need your user name in the vboxusers group and the Extension Pack.

In a host terminal run this:
Code: Select all   Expand viewCollapse view
sudo usermod -aG vboxusers <your username>

Replace <your username> with the name you use to log in. Type your user password when prompted.


Be sure to log off and back in to finalize the change in permissions
Perryg
Site Moderator
 
Posts: 33727
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Can't get any USB device to show up in VM

Postby cr_bin » 11. Jun 2012, 00:07

Yep. Just saw the error message from Virtual Box when I tried to run 'settings'. I'm working on linux now. Thanks for your help. Now I know what it is supposed to look like.
cr_bin
 
Posts: 6
Joined: 4. Jun 2012, 05:34

Re: Can't get any USB device to show up in VM

Postby SeaChanger » 14. Jun 2012, 03:46

Windows7 Host
Virtual Box V4.1.6 r78096
Linux 2.6 (64 bit)

Cannot get any USB device to load (busy with previous request) ...

But I can mount all of these USB devices if I define an empty filter in the vbox USB filter list ... webcam/wireless adapter... pretty frustrating after 2 days of trying.
--------------------------------------------------------------------------------------------------
seachanger@seachanger-VirtualBox:~$ VBoxManage list usbhost
Host USB Devices:

UUID: e59fb79b-7093-4ac8-8592-a6522653a209
VendorId: 0x0408 (0408)
ProductId: 0x2fb1 (2FB1)
Revision: 9.1 (0901)
Manufacturer: CN07CN2C786641670C24A00
Product: Laptop_Integrated_Webcam_2HDM
Address: sysfs:/sys/devices/pci0000:00/0000:00:0b.0/usb1/1-1//device:/dev/vboxusb/001/002
Current State: Busy

UUID: a051c2be-5a47-4c6a-a949-b61df644d8f2
VendorId: 0x413c (413C)
ProductId: 0x8183 (8183)
Revision: 0.0 (0000)
Manufacturer: <ADell Wireless 5540
Product: Dell Wireless 5540
SerialNumber: 3532360302994430
Address: sysfs:/sys/devices/pci0000:00/0000:00:0b.0/usb1/1-2//device:/dev/vboxusb/001/003
Current State: Busy

UUID: e35cce12-e6d5-4c38-b19f-114e9628cd2c
VendorId: 0x80ee (80EE)
ProductId: 0x0021 (0021)
Revision: 1.0 (0100)
Manufacturer: VirtualBox
Product: USB Tablet
Address: sysfs:/sys/devices/pci0000:00/0000:00:06.0/usb2/2-1//device:/dev/vboxusb/002/002
Current State: Busy

seachanger@seachanger-VirtualBox:~$
SeaChanger
 
Posts: 1
Joined: 14. Jun 2012, 00:17

Re: Can't get any USB device to show up in VM

Postby jrs_s » 1. Oct 2014, 03:56

I had the same issue but got it to work by using sudo. Then all my devices showed up.
jrs_s
 
Posts: 1
Joined: 1. Oct 2014, 03:55


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Bing [Bot] and 20 guests