TXT breaks VT-x on Lenovo X201 Tablet

Discussions related to using VirtualBox on Windows hosts.

TXT breaks VT-x on Lenovo X201 Tablet

Postby cpswan » 17. Aug 2011, 15:06

I've had a frustrating few weeks of not being able to run 64bit machines that I had once worked, and I was seeing the dreaded error message:

'VT-x/AMD-V hardware acceleration has
been enabled, but is not operational.
Your 64-bit guest will fail to detect a
64-bit CPU and will not be able to boot.
Please ensure that you have enabled
VT-x/AMD-V properly in the BIOS of
your host computer.'

Much had changed on my machine, giving me lots of things to try rolling backwards and forwards. I tried the usual recommendations of switching VT on/off in the BIOS, updating the BIOS, powering off completely etc. All to no avail - VirtualBox was still unable to use VT, and hence unable to run 64bit VMs that had worked before.

Then some logical reasoning came into the picture. When I turned VT off in the BIOS it complained that this would disable the TXT feature. Could it be TXT (Intel's Trusted eXecution Technology) itself (or at least Lenovo's implementation of it) that was preventing VirtualBox from using VT? It turned out that this was the case, and I'm back to having 64bit VMs working.

Looking back I think I turned on TXT when I did a RAM upgrade - after all you can never have too much security - except for when it breaks things.
Posts: 1
Joined: 17. Aug 2011, 14:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, XP

Re: TXT breaks VT-x on Lenovo X201 Tablet

Postby Martin » 17. Aug 2011, 20:03

I've seen several posts mentioning VT-x not usable for Vbox when TXT was enabled.
Posts: 2340
Joined: 30. May 2007, 18:05
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: XP, Win7, Linux, OS/2

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 57 guests