VirtualBox on Solaris has no sound

Discussions related to using VirtualBox on Solaris hosts.

VirtualBox on Solaris has no sound

Postby Karsten Bolz » 14. Mar 2008, 19:06

I'm running VirtualBox 1.5.51 on my Toshiba Tecra M5 notebook on top of Solaris 11 (snv66). When running the Windows Media Player or tools alike, I don't have any sound. In VirtualBox the audio driver is configured as follows:
Host Driver Null Audio Driver
Controller ICH AC97

Any idea?
Thanks

Karsten
Karsten Bolz
 
Posts: 5
Joined: 5. Mar 2008, 11:54

Postby Ramshankar » 19. Mar 2008, 11:40

Solaris native Host audio is being worked on. It's not yet available publicly.
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 636
Joined: 7. Jan 2008, 16:17

Solaris native Host audio...

Postby Karsten Bolz » 25. Mar 2008, 11:58

Ramshankar,

thanks for your answer. Any chance to see it in the next beta?

Thanks

Karsten
Karsten Bolz
 
Posts: 5
Joined: 5. Mar 2008, 11:54

MIC missing?

Postby kcg » 15. May 2008, 10:42

Ramshankar wrote:Solaris native Host audio is being worked on. It's not yet available publicly.


Hello,

I see in VBox 1.6 on Solaris if switched to host solaudio sound output seems to work (I've been able to hear Skype's ringing), the problem is that it seems sound input is not implemented yet, at least this message from log suggests it:

00:00:02.560 Audio: Trying driver 'solaudio'.
00:00:02.569 Audio: set_record_source ars=0 als=0 (not implemented)
00:00:02.569 AC97: WARNING: Unable to open PCM IN!
00:00:02.569 AC97: WARNING: Unable to open PCM MC!
00:00:02.591 Console: VM runtime error: fatal=false, errorID=HostAudioNotResponding message="Some audio devices (PCM_in, PCM_mic) could not
be opened. Guest applications generating audio output or depending on audio input may hang. Make sure your host audio device is working pr
operly. Check the logfile for error messages of the audio subsystem."

My question is: do you plan to make sound input working too?

Thanks!
Karel
PS: intention is to run Skype inside WindowsXP or Linux guests.
kcg
 
Posts: 11
Joined: 7. Apr 2008, 12:34

Postby kcg » 30. Sep 2008, 11:01

Ramshankar wrote:Solaris native Host audio is being worked on. It's not yet available publicly.

Hello,
I'd like to ask how is it looking with this project? I'm using 1.6.2 and mic is neither supported. Is it already supported in 2.0.x? Or shall I wait for another release?
Thanks!
Karel
kcg
 
Posts: 11
Joined: 7. Apr 2008, 12:34

Postby victoredwardocallaghan » 21. Nov 2008, 08:34

Hi,

I believe that if you install the OSS Sound stack and the latest VBox version this is no longer a problem.
However, VBox still does not work with the sun-audio framework.

Regards,
Edward.
victoredwardocallaghan
 
Posts: 2
Joined: 21. Nov 2008, 08:16

Mic still not working

Postby bruehlicke » 9. Dec 2008, 19:11

See http://opensolaris.org/jive/thread.jspa?threadID=78838

I just tried on 2.0.6 with Solaris host and Win XP 64 bit client. Sound works but Mic does not.

B-)
bruehlicke
 
Posts: 27
Joined: 30. Oct 2008, 17:57


Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 1 guest