PAE problem - Causes VM to Abort

Discussions related to using VirtualBox on Linux hosts.

PAE problem - Causes VM to Abort

Postby hendricksonrw » 4. May 2010, 23:39

Hi,

I am running a web-server (Apache, SSH, Subversion, Trac) as a VM machine so that I can move it between different computers easily and back up the whole image easily. The image works on both of my Windows 7 machines (64 & 32 bit) and only after moving it to my linux machine did I run into problems. I am not sure if this is simply a hardware limitation of my laptop or is something I can fix. I was just trying to VM the server on something a little low-powered b/c it really isn't going to be used for much but needs to run 24/7.

Running Vitural Box 3.1.6 r59338
Host Machine
Ubuntu 9.10
Pentium M 1.5
1GB ram

Client VM
Ubuntu 10.4
384 Ram
12 mb video

The error at the end of the log file:
00:00:34.305 VM: Raising runtime error 'PAEmode' (fFlags=0x1)
00:00:34.305 Changing the VM state from 'RUNNING' to 'FATAL_ERROR'.
00:00:34.306 Console: VM runtime error: fatal=true , errorID=PAEmode message="The guest is trying to switch to the PAE mode which is currently disabled by default in VirtualBox. PAE support can be enabled using the VM settings (General/Advanced)"


I attempted to enable PAE mode, but the option is grayed out and I don't know if it is a hardware problem, something I need to mess with in my BIOS, or I'm missing a package for Linux. Just asking for some direction.

Thanks in advanced.

Ross
hendricksonrw
 
Posts: 4
Joined: 4. May 2010, 22:48
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Ubuntu

Re: PAE problem - Causes VM to Abort

Postby Perryg » 5. May 2010, 00:02

Make sure the guest is shut down (not saved) and then go to the settings of the guest -> system -> processor. Make sure PAE is set to on. (has check mark).
Ubuntu server requires this feature to work. If you can not put the check mark in then as sudo in the terminal of the host post the results of cat /proc/cpuinfo
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: PAE problem - Causes VM to Abort

Postby hendricksonrw » 5. May 2010, 00:11

Well,

To move the VM I tried first copying the virtual disk, then I tried exporting the disk as an appliance from my other machine and importing it to this machine. The guest is for sure shut down and the option in guest -> system -> processor is greyed out, I can't check it.

the result of cat /proc/cpuinfo

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 1.50GHz
stepping : 6
cpu MHz : 1500.000
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 apic mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2
bogomips : 2992.13
clflush size : 64
power management:
hendricksonrw
 
Posts: 4
Joined: 4. May 2010, 22:48
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Ubuntu

Re: PAE problem - Causes VM to Abort

Postby Perryg » 5. May 2010, 00:14

I don't see a pae flag in your result. Ubuntu server is not going to work without it.

Here are my flags
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 constant_tsc up pni monitor
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: PAE problem - Causes VM to Abort

Postby fixedwheel » 5. May 2010, 00:18

Perryg wrote:Ubuntu server is not going to work without it.

AFAIK ubuntu server is fed from the same repository as ubuntu desktop. Install a desktop kernel before moving the vdi to the non-pae cpu
fixedwheel
Volunteer
 
Posts: 1699
Joined: 13. Sep 2008, 02:18

Re: PAE problem - Causes VM to Abort

Postby hendricksonrw » 5. May 2010, 00:23

Alright, so it is a Hardware issue, unless I install a desktop kernel to the VM-server? That is what I needed to know, thanks for your help troubleshooting this problem. Any suggestions on how to install a desktop kernel?

Reading this http://www.serverwatch.com/tutorials/article.php/3715071/Ubuntu-Server--Kernel-Configuration-Considerations.htm makes me think that using a desktop kernel isn't going to solve my problem if my CPU doesn't have the PAE flag. Thoughts?

Ross
hendricksonrw
 
Posts: 4
Joined: 4. May 2010, 22:48
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Ubuntu

Re: PAE problem - Causes VM to Abort

Postby fixedwheel » 5. May 2010, 00:32

hendricksonrw wrote:Any suggestions on how to install a desktop kernel?

apt-get install linux-image-generic

Reading this http://www.serverwatch.com/tutorials/article.php/3715071/Ubuntu-Server--Kernel-Configuration-Considerations.htm makes me think that using a desktop kernel isn't going to solve my problem if my CPU doesn't have the PAE flag. Thoughts?

Thats quite esoteric, the -generic will do as well
fixedwheel
Volunteer
 
Posts: 1699
Joined: 13. Sep 2008, 02:18

Re: PAE problem - Causes VM to Abort

Postby Perryg » 5. May 2010, 00:53

Fixedwheel is correct. The desktop kernel does not require the pae flag. It is only a restriction of the server kernel.

You do loose some timing and it is not as efficient as the server kernel but with what you are telling me you are using it for and the fact that you are trying to move this to an older system maybe it does not need to be. You could have actually installed all of the LAMP modules in the desktop version. They work there as well.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: PAE problem - Causes VM to Abort

Postby hendricksonrw » 5. May 2010, 01:25

Thanks everyone for all the responses. Yes, I am very well aware of how I could have installed everything to my linux machine's native os. The advantage of the VM is its portability (I may have to move it to a more powerful server in the future) and its backup-ability. I may also have to take the VM and hand it off to a colleague at some point in the future so it is easier to go this route than making a partition image of my laptop's linux install :).

Thanks for the apt-get command, I didn't know it was that simple. The article I mentioned was the top "bing" for a "install a desktop kernel to ubuntu server" search I did earlier.

Thanks again,

Ross
hendricksonrw
 
Posts: 4
Joined: 4. May 2010, 22:48
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Ubuntu


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Google [Bot] and 21 guests