VM won't start: medium is already in use by this snapshot

Discussions related to using VirtualBox on Mac OS X hosts.

VM won't start: medium is already in use by this snapshot

Postby uruguayiandude » 18. Jun 2019, 03:48

Hello guys,

I restarted my mac, and much to my surprise the linux VM became inaccessible and the following error appeared:
Code: Select all   Expand viewCollapse view
Cannot attach medium '/Applications/VirtualBox.app/Contents/MacOS/VBoxGuestAdditions.iso' {6fc4e532-cc81-4e7f-9780-0d78f25abdff} from snapshot 'f4a28b32-ffe5-48a9-b665-f7e650bc9f43': medium is already in use by this snapshot!.

Result Code: VBOX_E_OBJECT_IN_USE (0x80BB000C)
Component: MediumWrap
Interface: IMedium {4afe423b-43e0-e9d0-82e8-ceb307940dda}

I spent a lot of hours configuring that VM, so any help that can prevent me from doing that again, and to actually getting that VM up and running again would be super appreciated.

Thanks in advance.
Last edited by socratis on 18. Jun 2019, 11:19, edited 1 time in total.
Reason: Changed title to something more appropriate.
uruguayiandude
 
Posts: 3
Joined: 18. Jun 2019, 03:44

Re: VM won't start: medium is already in use by this snapshot

Postby socratis » 18. Jun 2019, 11:16

Delete any snapshots, leaving your VM at the "Current State".
In the VM Settings remove the VBoxGuestAdditions.iso.

Moving to "OSX Hosts" from "OSX Guests".
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25224
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VM won't start: medium is already in use by this snapshot

Postby uruguayiandude » 18. Jun 2019, 17:45

Thanks for the quick reply.

However, I can't access the snapshot GUI. How can I delete those? Sorry for my ignorance, but I'm new to Mac.

Thanks in advance.
uruguayiandude
 
Posts: 3
Joined: 18. Jun 2019, 03:44

Re: VM won't start: medium is already in use by this snapshot

Postby socratis » 18. Jun 2019, 18:06

uruguayiandude wrote:However, I can't access the snapshot GUI

Why's that? If you've got a snapshot, then you've used this before...

If you hover over a VM, you'll see the tools option (Image). Click on that, select "Snapshots". Start deleting the previous/oldest snapshots until you're left with the "Current State".
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25224
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VM won't start: medium is already in use by this snapshot

Postby uruguayiandude » 18. Jun 2019, 19:45

I just tried, and the snapshots option is greyed out, can't delete any of those (or access it for that matter) from the Virtual Box tool itself.
uruguayiandude
 
Posts: 3
Joined: 18. Jun 2019, 03:44

Re: VM won't start: medium is already in use by this snapshot

Postby socratis » 18. Jun 2019, 21:55

I would like to see the "recipe" of the VM, the ".vbox" file:
  1. Right-click on the VM in the VirtualBox Manager. Select "Show in Finder".
  2. ZIP the selected ".vbox" file and attach it to your response.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25224
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Majestic-12 [Bot] and 13 guests