Page 1 of 1

Can't use special keys in VM

PostPosted: 4. Jun 2019, 20:54
by sum_b0dy
I am having an issue where I can't use special keys (such as Shift, control, option, TAB etc...) in my VM, because when I click then, it registers as the Host key ( which is set to Left Command). So I am unable to type anything in capital letters, for example, in a terminal when I try to "cd Desktop" , I can't type 'D', and if I hold shift and press S, it opens the settings windows of the VM (which would be HOST + S) , but again, my host key is Left Command. This started out of nowhere, I haven't changed any settings, I even load a snapshot back and the problem persists. I have tried changing the host key, and still nothing. Here is a screenshot that shows what happens when I press the shift key, tab, control etc...

does anyone have any idea how to fix this?

Thank you in advance !

Re: Can't use special keys in VM

PostPosted: 5. Jun 2019, 07:14
by socratis
That sounds like a problem with your host's setup. Do you have any 3rd party keyboard modifiers, like Karabiner?

I need two things:
  1. The "VirtualBox.xml" file located in "/Users/<you>/Library/VirtualBox/VirtualBox.xml". ZIPPED.
  2. The output of the commands:
      ls -aldR /Applications/*/* /Users/<you>/Applications/*/*
      kextstat | grep -v
You need to replace the "<you>" part with your actual username...