ExtPack installation fails for VirtualBox 6.0.8 on OSX 10.14.5

Discussions related to using VirtualBox on Mac OS X hosts.

ExtPack installation fails for VirtualBox 6.0.8 on OSX 10.14.5

Postby RudyMLE » 31. May 2019, 09:27

So , it seems that the recovery mode allows to install and run 6.0.8 on 10.14.5 - but still cannot install theOracle_VM_VirtualBox_Extension_Pack-6.0.8... The error is:
Contents/MacOS/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/darwin.amd64/VBoxPuelMain.dylib'): VERR_FILE_NOT_FOUND - dlopen(/Applications/VirtualBox.app/Contents/MacOS/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/darwin.amd64/VBoxPuelMain.dylib, 6): Library not loaded: /Applications/VirtualBox.app/Contents/MacOS/VBoxVMM.dylib

Referenced from: /Applications/VirtualBox.app/Contents/MacOS/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/darwin.amd64/VBoxPuelMain.dylib

Reason: Incompatible library version: VBoxPuelMain.dylib requires version 6.0.8 or later, but VBoxVMM.dylib provides version 5.2.30.

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ExtPackManagerWrap
Interface: IExtPackManager {edba9d10-45d8-b440-1712-46ac0c9bc4c5}
Last edited by socratis on 31. May 2019, 10:29, edited 1 time in total.
Reason: Enclosed the information in [quote] tag for better readability
RudyMLE
 
Posts: 2
Joined: 31. May 2019, 09:24

Re: ExtPack installation fails for VirtualBox 6.0.8 on OSX 10.14.5

Postby socratis » 31. May 2019, 10:28

I split your post from the "installation fails for vbox 6.0.8 on osx 10.14.5" thread. You don't have the same problem, not at all. Please read "Do not highjack other threads, create your own. Choose the title carefully."

RudyMLE wrote:VBoxPuelMain.dylib requires version 6.0.8 or later, but VBoxVMM.dylib provides version 5.2.30.
It seems that you're trying to install a different version of the ExtPack from the VirtualBox version that you have. Please make sure that the ExtPack version matches exactly the version of the main program.

RudyMLE wrote:So , it seems that the recovery mode allows to install and run 6.0.8 on 10.14.5
You do not need to boot in Recovery mode to install VirtualBox 6.0.8 anymore. Please read carefully the 1st post from the thread which I split your post from, the red letters part...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25224
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: ExtPack installation fails for VirtualBox 6.0.8 on OSX 10.14.5

Postby RudyMLE » 31. May 2019, 11:03

socratis wrote:I split your post from the thread. You don't have the same problem, not at all. Please read Do not highjack other threads, create your own. Choose the title carefully."

Thanks, will do.

socratis wrote:It seems that you're trying to install a different version of the ExtPack from the VirtualBox version that you have. Please make sure that the ExtPack version matches exactly the version of the main program.


How can I check my version ? the about box only states the UI version (Version 5.2.30 r130521 (Qt5.6.3) ).... Checking for updates says "You are already running the most recent version of VirtualBox."

socratis wrote:You do not need to boot in Recovery mode to install VirtualBox 6.0.8 anymore. Please read carefully the 1st post from the thread which I split your post from, the red letters part...


If I made the change before in order to all the installation to complete, should I uninstall and somehow revert the change that I have done in the command line in the recovery mode?

Thanks again.
RudyMLE
 
Posts: 2
Joined: 31. May 2019, 09:24

Re: ExtPack installation fails for VirtualBox 6.0.8 on OSX 10.14.5

Postby socratis » 31. May 2019, 17:24

Download the latest VirtualBox from http://www.virtualbox.org/wiki/Downloads. In the same page you'll find the matching ExtPack, download that too. Install VirtualBox, then install the ExtPack.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25224
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 7 guests