Page 2 of 3

@socratis: all those tips and tricks are hacks

PostPosted: 17. May 2019, 23:41
by IOOI
the way to go for Oracle is to get their KEXTs notarized, see:

https://developer.apple.com/documentati ... stribution

@socratis: can you please forward this information to the developers?

Thanks,

IOOI

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 18. May 2019, 01:43
by snklkjlqqe
spctl kext-consent add VB5E2TV963 in recovery mode worked for me.
Thank you.

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 18. May 2019, 03:47
by mrusli
Hi All,

I too having the same issues with Virtual Box version 6.0.8 on Macos Mojave 10.14,5.
It cannot be install. I try many times and it still did not work.
I have to revert back to 6.0.6 as version 6.0.8 did not install and work at all.

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 18. May 2019, 09:12
by socratis
IOOI wrote:@socratis: can you please forward this information to the developers?
I don't have to forward anything, they already know. But as I suspect it won't work until 6.0.10.

6.0.8 and 10.14.5

PostPosted: 21. May 2019, 19:29
by JKM
The install fails. Not only that, it kills the previous install. So when I went to use my original VirtualBox after trying to install 6.0.8, I got a "kernel not there" message. Had to move the application to the trash and reinstall 6.0.6, which worked. I have no clue if 6.0.8 works with previous systems, I had literally just upgraded to 10.14.5 this morning, and got the message from VirtualBox that there was an update.

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 21. May 2019, 20:11
by socratis
@JKM
I merged your thread with the main one dealing with this issue. Read it from the beginning.

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 21. May 2019, 21:04
by JKM
@socratis,

Thanks, I didn't see that when I posted.

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 21. May 2019, 21:09
by dw.vbox
JustinCPorter wrote:Try restarting your workstation in Recovery Mode. Access Terminal and enter the following command:
Code: Select all   Expand viewCollapse view
spctl kext-consent add VB5E2TV963

Restart your machine and retry the installation of VirtualBox.

JP


Worked great, JP. Thanks!

DW

Virtual box 6.0.8 installation fails on Mojave 10.14.5

PostPosted: 22. May 2019, 16:00
by jashnb
I tried to update my Virtual box from version 5 to the latest one ( 6.0.8 ) and it seems like the installation is broked for good. I am running MacOS Mojave 10.14.5. It reaches the last step and shows Installation failed. I seemed to look at a lot of people who is facing a similar issue but I dont seem to understand the best solution.
When I open the virtual server I had already setup in the previous version it gives an error like -

Kernel driver not installed (rc=-1908)
Make sure the kernel module has been loaded successfully.
where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

Also I get another error like below:
"Failed to create Host network interface"

The virtual machine 'UbuntuServer' has terminated unexpectedly during startup with exit code 1 (0x1).
Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
MachineWrap
Interface:
IMachine {5047460a-265d-4538-b23e-ddba5fb84976}

And also, I see there are no networks in host Network Manager and when I try to create one I get an error as below
VBoxNetAdpCtl: Error while adding new interface: failed to open /dev/vboxnetctl: No such file or directory.

Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
HostNetworkInterfaceWrap
Interface:
IHostNetworkInterface {455f8c45-44a0-a470-ba20-27890b96dba9}

One of the solution online suggested I need to accept the Oracle certificate but I had already done that in the previous version installation and I can see that the certificate is still valid when I try to click on the small lock symbol on the top right corner of the installation.

Looking forward to the help.

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 22. May 2019, 16:30
by klaus
FYI, VirtualBox 6.0.6 and 5.2.28 are notarized (for these old enough versions notarization produces just warnings, because Apple decided to be forgiving) as of now. So you can install these versions on 10.14.5, as long as you do the install while you have a connection to the Internet (so that Apple's 'gatekeeper' can phone home to check the notarization).

We're working on getting 6.0.8 (and with a little lower priority also 5.2.30 - its list of supported macOS versions ends with 10.13) notarized as quickly as possible. Impossible to tell exactly when it will happen. Once this is done we'll review the options of providing modified installers (which would include the notarization tickets, so that installation would work when the system doesn't have a connection to the Internet).

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 22. May 2019, 16:35
by JustinCPorter
Thanks for the update Klaus.

JP

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 23. May 2019, 08:53
by VMAC
Wow this is bad... So the only way to get the previously working versions (since Apple's "security update") is to boot into the recovery OS and disable checking using that tool? I need to boot my VM!

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 23. May 2019, 09:15
by socratis
VMAC wrote:I need to boot my VM!

Install 6.0.6. It works GREAT!!!

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 23. May 2019, 13:40
by geo68
any chance to have an update of virtualbox package that solves the problem? 6.0.8 is useless for average mac user who doesn't mess up with terminal

Re: installation fails for vbox 6.0.8 on osx 10.14.5

PostPosted: 23. May 2019, 13:47
by klaus
geo68 wrote:any chance to have an update of virtualbox package that solves the problem? 6.0.8 is useless for average mac user who doesn't mess up with terminal


Use 6.0.6 for now - it can be installed and used without trouble on macOS 10.14.5 since yesterday.