installation fails for vbox 6.0.8 on osx 10.14.5

Discussions related to using VirtualBox on Mac OS X hosts.

installation fails for vbox 6.0.8 on osx 10.14.5

Postby geo68 » 16. May 2019, 09:20


ModEdit
Effective immediately (2019-05-23 18:00 UTC)
the install of VirtualBox 6.0.8 and 5.2.30
should simply work on macOS 10.14.5


after updating to osx 10.14.5 on my mac mini 2018 , I got the notification to update virtualbox to 6.0.8
it fails and it doesn't give any clue since the "security and privacy doesn't even detect the oracle installation
I had to switch back to 6.0.6 . installation for it is ok.
Last edited by socratis on 23. May 2019, 20:30, edited 3 times in total.
Reason: Topic changed to Sticky
geo68
 
Posts: 2
Joined: 16. May 2019, 09:16

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby BrendenBain » 16. May 2019, 12:04

I also get this error for both 6.0.6 and 6.0.8. I was able to install 6.0.4 by completely uninstalling using the uninstall script and starting again.

I have attached the install logs for the three different installs as well as some screenshots of the errors.

I was thinking it might have been related to viewtopic.php?f=8&t=84092. However, I don't think it is. The fact that I was able to downgrade successfully seems to indicate that I have already allowed access to kexts signed by Oracle (provided the key didn't change between 6.0.4 and 6.0.8?). I have also dumped what I have been told is the KextPolicy database. It looks like I have approved the org.virtualbox.kext.VBoxDrv, org.virtualbox.kext.VBoxNetAdp, org.virtualbox.kext.VBoxNetFlt and org.virtualbox.kext.VBoxUSB extensions in the past.

Anyone have an idea what is going on?
Attachments
vbox.zip
(156.06 KiB) Downloaded 118 times
BrendenBain
 
Posts: 1
Joined: 16. May 2019, 11:41

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby andyp73 » 16. May 2019, 16:56

There has been some discussion in the thread 6.0.6 Fails to install on 10.14.5 Beta (18F108f) about how kexts now need to be notarized by Apple.

Apple wrote:Important
Beginning in macOS 10.14.5, all new or updated kernel extensions and all software from developers new to distributing with Developer ID must be notarized in order to run. In a future version of macOS, notarization will be required by default for all software.

Having just upgraded my iMac to 10.14.5 I'm just about to see if I can get VirtualBox 6.0.8 to install.

-Andy.
My crystal ball is currently broken. If you want assistance you are going to have to give me all of the necessary information.
Please don't ask me to do your homework for you, I have more than enough of my own things to do.
andyp73
Volunteer
 
Posts: 1641
Joined: 25. May 2010, 23:48
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Assorted Linux, Windows Server 2012, DOS, Windows 10, BIOS/UEFI emulation

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby bock » 16. May 2019, 18:21

Confirm that.
I did a fresh Osx Mojave installation.
System started and automatically updated to 10.14.5

After that, NO WAY to finish install of VirtualBox. Checked .8, .6 and .4, Same.

THEN, I re-install mojave, then switched off internet in order to have just 10.14 and NOT the 10.14.5 upgrade.
And, YES, Virtual Box is able to install.
So, problem is last 10.14.5 security update.
bock
 
Posts: 3
Joined: 16. May 2019, 12:34

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby JustinCPorter » 16. May 2019, 19:08

Try restarting your workstation in Recovery Mode. Access Terminal and enter the following command:
Code: Select all   Expand viewCollapse view
spctl kext-consent add VB5E2TV963

Restart your machine and retry the installation of VirtualBox.

JP
JustinCPorter
 
Posts: 4
Joined: 16. May 2019, 19:02

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby Control4 » 16. May 2019, 19:15

Code: Select all   Expand viewCollapse view
spctl kext-consent add VB5E2TV963
spctl: failed to store new configuration.

sudo spctl kext-consent add VB5E2TV963
Password:
spctl: failed to store new configuration.

How should I configure the system to accept a new config?
Control4
 
Posts: 5
Joined: 16. May 2019, 18:21

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby Control4 » 16. May 2019, 19:24

May 16 11:21:53 ControlFours-Mac Installer[891]: Package Authoring Error: <background> has an unsupported MIME type: image/data
May 16 11:21:53 ControlFours-Mac Installer[891]: Package Authoring Error: <background_scaling> has an unsupported MIME type: X-NSObject/NSNumber
May 16 11:21:53 ControlFours-Mac Installer[891]: Package Authoring Error: <background_alignment> has an unsupported MIME type: X-NSObject/NSNumber
May 16 11:21:53 ControlFours-Mac Installer[891]: Package Authoring Error: <layout-direction> has an unsupported MIME type: X-NSObject/NSNumber
May 16 11:22:04 ControlFours-Mac installd[679]: PackageKit: ----- Begin install -----
May 16 11:22:07 ControlFours-Mac installd[679]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “VirtualBox.pkg”." UserInfo={NSFilePath=./postflight, NSURL=file:///Volumes/VirtualBox/VirtualBox.pkg#VBoxKEXTs.pkg, PKInstallPackageIdentifier=org.virtualbox.pkg.vboxkexts, NSLocalizedDescription=An error occurred while running scripts from the package “VirtualBox.pkg”.} {
NSFilePath = "./postflight";
NSLocalizedDescription = "An error occurred while running scripts from the package \U201cVirtualBox.pkg\U201d.";
NSURL = "file:///Volumes/VirtualBox/VirtualBox.pkg#VBoxKEXTs.pkg";
PKInstallPackageIdentifier = "org.virtualbox.pkg.vboxkexts";
}
May 16 11:22:07 ControlFours-Mac Installer[891]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
May 16 11:22:07 ControlFours-Mac Installer[891]: Displaying 'Install Failed' UI.
May 16 11:22:07 ControlFours-Mac Installer[891]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.
Control4
 
Posts: 5
Joined: 16. May 2019, 18:21

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby JustinCPorter » 16. May 2019, 19:57

Control4 wrote:spctl kext-consent add VB5E2TV963
spctl: failed to store new configuration.

sudo spctl kext-consent add VB5E2TV963
Password:
spctl: failed to store new configuration.

How should I configure the system to accept a new config?

Hi Control4,

Did you restart your workstation in Recovery Mode?

JP
JustinCPorter
 
Posts: 4
Joined: 16. May 2019, 19:02

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby Control4 » 16. May 2019, 20:00

Yes and reinstalled 10.14.5.
Control4
 
Posts: 5
Joined: 16. May 2019, 18:21

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby Control4 » 16. May 2019, 20:02

I've downgraded to vbox 6.0.4 but it won't start because it is using the extension pack from 6.0.8. Looking to see if I can downgrade as well.
Control4
 
Posts: 5
Joined: 16. May 2019, 18:21

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby JustinCPorter » 16. May 2019, 20:09

Control4 wrote:Yes and reinstalled 10.14.5.


Very strange.

I experienced this issue across all my workstations once I applied the MacOS 10.14.5 update and then vbox 6.0.8.

Running the 'spctl kext-consent add' command from the terminal in recovery mode worked for me on all machines.

Sorry it didn't help you Control4
JustinCPorter
 
Posts: 4
Joined: 16. May 2019, 19:02

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby Control4 » 16. May 2019, 20:29

User error: I misread your instructions.

I reinstalled 10.14.5 from Recovery Mode, rebooted and then tried to issue the command and it failed, as well as the 6.0.8 install.

I didn't issue the command from the Terminal in Recovery Mode. Once I did, I was able to install 6.0.8 just fine.

Thanks for your help.
Control4
 
Posts: 5
Joined: 16. May 2019, 18:21

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby sinistra » 16. May 2019, 23:31

Code: Select all   Expand viewCollapse view
csrutil disable
allows me to install and run.
But as soon as
Code: Select all   Expand viewCollapse view
csrutil enable
is run, the problem returns.

Code: Select all   Expand viewCollapse view
spctl kext-consent add VB5E2TV963
executed in the recovery terminal allows the application to install and run without errors.

Thanks for your help
sinistra
 
Posts: 1
Joined: 16. May 2019, 23:26

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby djblankinship » 17. May 2019, 22:01

Does anybody have a feeling for whether Apple acknowledges this as an issue to be addressed in the MacOS? Not sure that I want to disable the System Integrity Protection just to be able to run VirtualBox since I can just use workarounds such as running BrowserStack in the meantime.
djblankinship
 
Posts: 1
Joined: 17. May 2019, 22:00

Re: installation fails for vbox 6.0.8 on osx 10.14.5

Postby Martin » 17. May 2019, 22:31

Read the post above yours again. You don't need to disable SIP.
Martin
Volunteer
 
Posts: 2243
Joined: 30. May 2007, 18:05
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: XP, Win7, Linux, OS/2

Next

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: derrellsimpson, socratis and 12 guests