VERR_VM_DRIVER_NOT_INSTALLED

Discussions related to using VirtualBox on Mac OS X hosts.

VERR_VM_DRIVER_NOT_INSTALLED

Postby Sy » 14. May 2019, 12:05

I'm trying to get VirtualBox installed on my iMAC. My iMAC:

macOS Mojave, Version 10.14.5
Processor: 4 GHz Intel Core i7
Memory: 16 GB 1867 MHz DDR3
Graphics: AMD Radeon R9 M395X 4 GB

VirtualBox 6.0.6 r130049 (Qt5.6.3) downloaded today.

I have a Ubuntu 14.04 virtual machine, when I try to Start it I get two error dialogs displayed, the first contains:
Failed to open a session for the virtual machine, Ubuntu 14.04 ACS dev.
Details:
The virtual machine 'Ubuntu 14.04 ACS Dev' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine
{5047460a-265d-4538-b23e-ddba5fb84976}

The other error dialog contains:
Kernel driver not installed (rc=-1908)
Make sure the kernel module has been loaded successfully.
where: suplibOsInit what: 3
VERR_VM_DRIVER_NOT_INSTALLED (-1908)
- The support driver is not installed. On linux, open returned ENOENT.

I've searched around for solutions and found several posts suggesting to go to System Preferences then Security & Privacy, in the General tab there is supposed to be an option to allow the oracle virtual box access. I don't see this and I don't know how to get the option. I've unlocked the system, I've uninstalled VirtualBox numerous times and tried again, but each time its the same problem, I've also tried shutting down and restarting after an uninstall, no difference.

What else can I try?
Kind Regards,
Sy
Sy
 
Posts: 33
Joined: 30. Oct 2017, 22:29
Location: United Kingdom
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows 7

Re: VERR_VM_DRIVER_NOT_INSTALLED

Postby bsevier » 17. May 2019, 19:37

I'm having the same issues with a Windows VM. Just to get the VB 5.2.30 install to work I had to disable the gatekeeper with csrutil - install ran then, as did the extension pack. And the VM opened and ran fine. Rebooted into safe mode, re-enabled with csrutil, virtual box kicked out launch error and kernel error. Earlier I'd tried the adding of VB5E2TV963 (Oracle dev code, I believe) because I wasn't getting the "install blocked" in the Security preferences of Mojave, didn't make any difference. If I turn off gatekeeper it runs - which I will do for a while since I have dev work to do, but NOT a good solution.

Apparently Mojave 10.14.5 update changes something in the security gatekeeper functions (again). Here's an announcement from last month about 10.14.5: Apple today released updated developer documentation letting developers know that as of macOS 10.14.5, all new software distributed with a new Developer ID must be notarized in order to run. Maybe Oracle hasn't done this??

Ben Sevier
San Diego
bsevier
 
Posts: 3
Joined: 2. Apr 2014, 19:01

Re: VERR_VM_DRIVER_NOT_INSTALLED

Postby socratis » 18. May 2019, 10:06

@Sy
You ignored the error message during the installation. How on earth do you expect it to work if it errors in the first place?

@bsevier
Yes, the Apple policy has changed. VirtualBox will have to adjust. Only a new release can do that officially.

@both
Why did you post in the "OSX pre-release" area? Moving this to the "OSX Hosts" one.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25313
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Emm and 30 guests