Page 1 of 1

VirtualBox is crawling with any graphical OS (Windows/Linux)

PostPosted: 4. Apr 2019, 08:34
by Razva
Hello,

I have a beefy i7, 16 GB RAM, 15 inch 2018 MacBook Pro. I've installed VirtualBox (latest) and Extension Packs (latest).

Doesn't matter how many resources I allocate, all VMs, with any kind of graphical UI, are absolutely crawling. I've made a "demo", you can find it at h ttps:// screencast. com/t/Z5wwjjim (first post so can't post links).

Here's the complete log of a session: h ttps:// gist.github. com/Razva/37d72e418cd121ad7322a86e695e7a56

Is this "the norm"? Any way to improve it?

Thank you,
Razvan

Re: VirtualBox is crawling with any graphical OS (Windows/Linux)

PostPosted: 4. Apr 2019, 09:34
by socratis
Razvan, this is *not* cool! I was talking to you live on IRC, solving your problem, and you "forgot" to mention that you were simultaneously posting on the forums? Really?

I have two words for you: not cool...

Re: VirtualBox is crawling with any graphical OS (Windows/Linux)

PostPosted: 4. Apr 2019, 14:32
by Razva
Asking on IRC and on forums is quite common. In fact, I think that this occasion is the first one on which somebody got offended because of this. We're all different, I guess, so sorry if you got offended.

Anyway, as per our discussion, I've:
  • lowered the resolution to 800x600
  • set 2 CPUs
  • enabled I/O Cache
  • set 200% Global scaling for the guest VM

Unfortunately things are not (way) faster. I'll try with another OS, as Whonix doesn't support current VBox GAs.

Thank you for your support!