Page 1 of 1

Kali Linux run slowly

PostPosted: 29. Mar 2019, 17:42
by Vetteliano
I have a new MacBook Pro 2018 13 inch 8gb ram and 256 gb ssd. The so is Mac OS 10.14.4. I have recently updated the operating system but the problem also occurred with Mac OS 10.4.3.

The virtual machine I use (Kali Linux) run very slowly, especially for browsing web. When I scroll the pages, they go very slowly. This slowness is present throughout the system.


I tried disabling the 3d acceleration, changing the resolution, increasing the ram or cpu, but the result does not change.

Re: Kali Linux run slowly

PostPosted: 4. Apr 2019, 08:02
by socratis
00:00:01.596260 DMI Product Name: MacBookPro15,2
MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports), 2560-by-1600 (Retina); Scaled resolutions: 1680 by 1050, 1440 by 900, and 1024 by 640 pixels.

00:00:01.795769 GUI: UIMachineLogicFullscreen::sltHandleNativeFullscreenWillEnter:
Machine-window #0 will enter native fullscreen
Don't go full-screen. You have a fake GPU, with lots of pixels to move around, the load is too much to handle in software rendering.

Instead prefer a windowed-mode, depending on your OSX System Preferences ยป Display. If you selected the "More Space" option, your effective resolution would be 1680x1050, so pick something like 1280x800 for your guest's resolution, no more than that.

Now, you also have the following:
00:00:14.601649 VMMDev: SetVideoModeHint: Got a video mode hint (2880x1800x32)@(0x0),(1;0) at 0
Are you having an external monitor hooked up to the MBP? See my previous comment, and mutiply it by a factor of (2880x1800)/(1680x1050)=2.94 times worse.

Also, if Firefox is your problem, go to the Preferences and disable the "Hardware acceleration when available" option.