Network (NAT, Bridged) not working

Discussions related to using VirtualBox on Mac OS X hosts.

Network (NAT, Bridged) not working

Postby capudipusher » 2. Feb 2019, 18:09

I have tried version 6.0.0.0, 6.0.0.2 and now 6.0.0.4, the guest is Windows 7 Home Premium, host is MacOS Mojave 10.14.2, and from the guest I am unable not only to connect to the internet, but also to connect or to ping or trace the router, both using NAT or Bridged Networking, I haven't tried the remaining option. I absolutely don't know what to do, with my previous macbook with virtualbox 5.2 everithing worked fine. Any help ? Thank you
Last edited by capudipusher on 11. Feb 2019, 05:04, edited 2 times in total.
capudipusher
 
Posts: 6
Joined: 2. Feb 2019, 17:21

Re: Network (NAT, Bridged) not working

Postby capudipusher » 3. Feb 2019, 09:41

Additional information : Host running on Mac Mini 2018, guest is 64bit, host connected via wi-fi, guest seems to get ip address, gateway and dns via dhcp from the router both using NAT or Bridged, tried both the default adapter (Intel PRO 1000 MT Desktop) and Virtio-net.
capudipusher
 
Posts: 6
Joined: 2. Feb 2019, 17:21

Re: Network (NAT, Bridged) not working

Postby capudipusher » 10. Feb 2019, 10:45

Finally got it working, at least NAT configuration (I will try Bridged once installed all update e service pack in the guest), but I have had to use the Development Branch Build, specifically version 6.0.97-128689. I haven't tried the Stable Branch Build 6.0.5. Hope this info may help who is affected by the same issue.
capudipusher
 
Posts: 6
Joined: 2. Feb 2019, 17:21

Re: [Solved] Network (NAT, Bridged) not working

Postby capudipusher » 10. Feb 2019, 14:30

Bridged network still do not work, and if you modify the setting from NAT to bridged, then you have to change network card to have the network working (e.g. from adapter 1 to adapter 2).
capudipusher
 
Posts: 6
Joined: 2. Feb 2019, 17:21

Re: [Solved] Network (NAT, Bridged) not working

Postby socratis » 10. Feb 2019, 19:03

How about starting describing your setup, your problem and what made you think that it's solved (or not)? With details please...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24221
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [Solved] Network (NAT, Bridged) not working

Postby capudipusher » 10. Feb 2019, 19:30

I try to better describe the problem, but please consider, socratis, that English is not my primary language.

So, I have a new Mac Mini 2018 running Os X Mojave 10.14.2 and connected to the Internet using WiFi. I have installed initially VB 6.0.0, then unistalled and installed 6.0.2, then unistalled again and installed 6.0.4. With all these three versions I cannot connect to the LAN nor the Internet from the guest OS, either using NAT configuration or Bridged Networking. If I well remember, in all these cases, I selected the Bridged mode before starting the virtual machine for the first time, and only subsequently I tried the NAT configuration. However, I have never been able to connect to the LAN or the Internet.

Today, I have downloaded the VirtualBox-6.0.97-128689-OSX.dmg and installed it. This time, I didn't modify the default network configuration, so I have started the virtual machine with Adapter 1 enabled and set to NAT. Installed the guest (Windows 7 Home Premium) and the network was correctly working, I was able to connect to the LAN and the Internet. So I installed all updates and service pack.

Only at this point I have shut down the virtual machine and have tried to change the network setting of Adapter 1 from NAT to Bridged. Restarted the virtual machine, the network wasn't working, either with DHCP configuration or manually setting the IP, Gateway and DNS in the guest.

At this point, I have tried to switch back from Bridged to NAT, and NAT in this case, doesn't work. So I have shut down the guest, disabled Adapter 1, enabled Adapter 2 (default setting NAT), and the guest is connected to the internet. The issue is not really solved, and I need the Bridged configuration, but now I am connected to the internet. That's all I can say.
capudipusher
 
Posts: 6
Joined: 2. Feb 2019, 17:21

Re: Network (NAT, Bridged) not working

Postby socratis » 12. Feb 2019, 04:46

It's not a good idea to switch configurations on the fly, until you have your basic setup working.

Does the VM connect to the internet if you're in NAT mode? And by connect I mean can you perform the following "pings":
> ping 1.1.1.1                      <-- tests outgoing connectivity
> ping download.virtualbox.org <-- tests name resolution

If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24221
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Network (NAT, Bridged) not working

Postby capudipusher » 12. Feb 2019, 07:02

Yes, I can ping both and I receive a reply
Attachments
Schermata 2019-02-12 alle 05.57.56.jpg
Schermata 2019-02-12 alle 05.57.56.jpg (113.5 KiB) Viewed 299 times
capudipusher
 
Posts: 6
Joined: 2. Feb 2019, 17:21

Re: Network (NAT, Bridged) not working

Postby socratis » 12. Feb 2019, 08:03

Good. So, that means that you have a connection, an active connection with NAT.

Now, the Bridged part... Bridged and wireless don't always play nice. Bridged networking is outside the WLAN specification. It may or may not work. Some combinations of Routers/Access Points, WLAN cards and drivers work, some don't. See: Bridging & Wifi - Supported hardware and add your experience.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24221
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 13 guests