[Resolved] Mouse on host OS is unresponsive as soon as VM is started

Discussions related to using VirtualBox on Mac OS X hosts.

[Resolved] Mouse on host OS is unresponsive as soon as VM is started

Postby thecpat » 22. Jan 2019, 01:20

Hi there,
I recently upgraded VirtualBox to the 6.0.2 version only to find that as soon as I started the VM's the mouse in my Mac OS stopped responding.. After waiting for the OS to boot fully, the mouse was available in the guest OS but I could not release it from the VM even when I hit Left Control. The VM's I'm running have been working fine for me for the past year and half.

I uninstalled the 6.X version and installed 5.2.24 only to have the same problem.

Typically I start the VM in background mode then Remote Desktop to them so I can multitask while using them.

Any assistance as to how to have my mouse work both in the VM as well as in the Mac OS (host) would be appreciated

C. Pat.
Last edited by socratis on 24. Jan 2019, 08:24, edited 1 time in total.
Reason: Marked as [Resolved].
thecpat
 
Posts: 3
Joined: 22. Jan 2019, 01:15

Re: Mouse on host OS is unresponsive as soon as VM is started

Postby thecpat » 22. Jan 2019, 01:23

BTW, yes I installed the appropriate extension pack for each version installed.
thecpat
 
Posts: 3
Joined: 22. Jan 2019, 01:15

Re: Mouse on host OS is unresponsive as soon as VM is started

Postby socratis » 22. Jan 2019, 01:39

First of all, stop the Remote Desktop for the moment, you got to take some parameters out of the equation.

Second, do you happen to have a USB filter enabled? Remove it. See if that changes the situation...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24231
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mouse on host OS is unresponsive as soon as VM is started

Postby thecpat » 24. Jan 2019, 05:08

Hey Socratis,

Thanks for the reply.. and thanks for the suggestion. Worked like a charm..

I'm pretty sure that I had at least some of those USB filters in place when I did the last upgrade but removing them has fixed the issue.

Cheers!.
thecpat
 
Posts: 3
Joined: 22. Jan 2019, 01:15

Re: Mouse on host OS is unresponsive as soon as VM is started

Postby socratis » 24. Jan 2019, 08:24

Glad you got it going. Marking as [Resolved].
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24231
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 11 guests