Page 1 of 1

[Fixed] Extension Pack Installed? (#18197)

PostPosted: 18. Dec 2018, 22:24
by utkonos

ModEdit; related ticket: #18197: OSX: Dbl-clicking on registered file types results in no action

In the 5.2.x and earlier, during installation of the extension pack there would be a popup in VirtualBox that indicates that the extension pack was installed successfully.

In the new 6.0.0 and in the release candidate, after double clicking on the extension pack, it opens VirtualBox, but there is no indication that the install was successful or not.

Now that the popup is gone, is there a different way to verify that the extension pack was installed correctly?

Re: Extension Pack Installed?

PostPosted: 18. Dec 2018, 22:31
by utkonos
One more thing: with previous versions, during the extension pack install process, I would need to authenticate as an administrator. When double clicking the extension pack now, it opens VirtualBox, but there is no authentication request nor is there a popup indicating the install failed or succeeded.

Re: Extension Pack Installed?

PostPosted: 18. Dec 2018, 22:51
by utkonos
I've solved my own problem:

You cannot double click on the extension pack anymore. That method of installation does not work in 6.0.0.

The only way to install the extension pack is to open Preferences under the VirtualBox menu, select Extensions, click add new, and then navigate to where the extension pack file is located. This works fine.

Re: Extension Pack Installed? (#18197)

PostPosted: 18. Dec 2018, 23:35
by socratis
utkonos wrote:When double clicking the extension pack now, it opens VirtualBox, but there is no authentication request nor is there a popup indicating the install failed or succeeded.
There is no installation taking place, as you found out. In fact every dbl-clicking on any of the registered files (vbox, ova, ovf, extpack) results in no action whatsoever.

I opened a ticket for this; OSX: Dbl-clicking on registered file types results in no action. Add yourself in the Cc: list by adding a "me too" or "+1" comment...

Re: Extension Pack Installed? (#18197)

PostPosted: 21. Dec 2018, 16:37
by JolleyLama
I had the exact same problem with VirtualBox 6. I had to go to Preferences -> Extensions and then delete extensions for VB5 and manually install extensions for VB6. It seemed to work after that.

Re: Extension Pack Installed? (#18197)

PostPosted: 22. Dec 2018, 12:35
by socratis
Yes, it works if you install the Extension Pack manually, that's not the problem. The problem is that it should do that if you double-clicked on the ExtPack file itself...

Re: Extension Pack Installed? (#18197)

PostPosted: 19. Jan 2019, 22:05
by socratis
Confirmed as fixed with 6.0.3 r128258, maybe earlier.