HELP - Virtual Machine launches to a screen with UEFI Interactive Shell v2.1

Discussions related to using VirtualBox on Mac OS X hosts.

HELP - Virtual Machine launches to a screen with UEFI Interactive Shell v2.1

Postby RayL » 11. Dec 2018, 05:46

I've downloaded VirtualBox Version 5.2.22 r126460 (Qt5.6.3) to my Macbook Pro running macOS Mojave Version 10.14.2 (18C54) with 340 GB available.

When I launch VirtualBox from Finder, the Oracle VM VirtualBox Manager opens with the Firtual Machine I created on the left side of this window with the "New", "Settings", "Disgard" and "Start" buttons above with the Virtual Machine "Powered Off".

When I click on "Start", the Virtual Machine launches ("[Running]" at the top of this window). However, the screen is black with the following text:

UEFI Interactive Shell v2.1
EDK II
UEFI v2.40 (EDK II, 0x00010000)
Mapping table
BLK0: Alias(s):
PciRoot (0x0)/Pci (0x1f,0x2)/Sata (0x0,0x0,0x0)
Press ESC in 1 seconds to skip startu.nsh or any other key to continue.
Shell>

Please see the attached image.

I've searched online for solutions to this but haven't found anything helpful. I'm optimistic about having better luck here.
Attachments
Screen Shot 2018-12-10 at 7.40.46 PM.png
Screen Shot 2018-12-10 at 7.40.46 PM.png (94.81 KiB) Viewed 992 times
RayL
 
Posts: 1
Joined: 11. Dec 2018, 05:21

Re: HELP - Virtual Machine launches to a screen with UEFI Interactive Shell v2.1

Postby andyp73 » 11. Dec 2018, 10:56

It looks like you have defined a guest to use the UEFI BIOS but haven't actually installed a guest OS. How is the guest configured within VirtualBox Manager and what OS do you think you have installed?

-Andy.
My crystal ball is currently broken. If you want assistance you are going to have to give me all of the necessary information.
Please don't ask me to do your homework for you, I have more than enough of my own things to do.
andyp73
Volunteer
 
Posts: 1642
Joined: 25. May 2010, 23:48
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Assorted Linux, Windows Server 2012, DOS, Windows 10, BIOS/UEFI emulation

Re: HELP - Virtual Machine launches to a screen with UEFI Interactive Shell v2.1

Postby AwwwDRAT » 23. Jan 2019, 18:49

I get this also when trying to install windows XP. What info can I give you for some help? Im running Windows 10 with vbox 6 installed.
AwwwDRAT
 
Posts: 1
Joined: 23. Jan 2019, 18:46

Re: HELP - Virtual Machine launches to a screen with UEFI Interactive Shell v2.1

Postby andyp73 » 23. Jan 2019, 19:12

AwwwDRAT wrote:I get this also when trying to install windows XP.

If you had used the default template for creating a Windows XP guest then it would use the standard BIOS not EFI. Have you created this guest yourself or have you imported something from somewhere?

-Andy.
My crystal ball is currently broken. If you want assistance you are going to have to give me all of the necessary information.
Please don't ask me to do your homework for you, I have more than enough of my own things to do.
andyp73
Volunteer
 
Posts: 1642
Joined: 25. May 2010, 23:48
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Assorted Linux, Windows Server 2012, DOS, Windows 10, BIOS/UEFI emulation

Re: HELP - Virtual Machine launches to a screen with UEFI Interactive Shell v2.1

Postby mpack » 23. Jan 2019, 19:23

What is the point of using an EFI BIOS with XP? The XP installer only understands MBR partitions.
mpack
Site Moderator
 
Posts: 29845
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 7 guests