Cannot turn off/disable microphone for VB

Discussions related to using VirtualBox on Mac OS X hosts.

Cannot turn off/disable microphone for VB

Postby tomliv » 29. Oct 2018, 15:35

I am using Mac OSMojave and as of a recent update VB is constantly activating the microphone of my Mac. I have tried this command: [ VBoxManage controlvm <uuid|vmname> audioin on|off ] but it isn't stopping the mic from being active. I am using Micro Snitch and it is showing the mic as active. How do I stop it? I don't want it on.

Thanks!
tomliv
 
Posts: 3
Joined: 29. Oct 2018, 15:32
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Linux

Re: Cannot turn off/disable microphone for VB

Postby socratis » 29. Oct 2018, 16:09

VM Settings » Audio » Enable Audio Input: uncheck.
Or on the bottom right (status bar) of the VM window, the audio icon.
That's the default for newly created VMs in any event, for security reasons.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24358
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Cannot turn off/disable microphone for VB

Postby tomliv » 31. Oct 2018, 19:38

Thanks for the reply. It was already unchecked. Any other thoughts?
tomliv
 
Posts: 3
Joined: 29. Oct 2018, 15:32
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Linux

Re: Cannot turn off/disable microphone for VB

Postby tomliv » 31. Oct 2018, 20:22

I believe I have it figured out. I had to disable audio completely and for all VMs I have installed. Just unchecking the input/output check boxes didn't fix the issue. Not really a problem for me so I guess that solves that. Thanks.
tomliv
 
Posts: 3
Joined: 29. Oct 2018, 15:32
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Linux

Re: Cannot turn off/disable microphone for VB

Postby socratis » 31. Oct 2018, 20:31

tomliv wrote:I had to disable audio completely and for all VMs I have installed.
Just to get it straight... If you have a single VM, that has audio input enabled, and you simply launch VirtualBox Manager, your MicroSnitch is reporting that the microphone is in use?

tomliv wrote:Not really a problem for me so I guess that solves that.
No, in fact you actually just opened Pandora's box! :D
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24358
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Why does VBox keep trying to access the microphone?

Postby mcandre » 7. Nov 2018, 06:25

Why does VirtualBox frequently attempt to access the microphone? It didn't used to do this. I am not doing anything specific to audio processing, just booting up some UNIX guest boxes and compiling command line C apps.
mcandre
 
Posts: 9
Joined: 13. Oct 2015, 22:36

Re: Cannot turn off/disable microphone for VB

Postby socratis » 7. Nov 2018, 06:48

@mcandre
I merged your question with a similar one that was asked and semi-answered last week. No point in recreating the discussion. Can you confirm/refute my questions in the message (which is now) above yours? And do you have MicroSnitch installed as well?

mcandre wrote:It didn't used to do this.
When was that? What version of host/VirtualBox?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24358
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Microhone avtivated at every Login

Postby ergo » 21. Jan 2019, 23:35

Hello,

whenever I start virtualbox with a linux guest - for example xubuntu or others too - the microphone
is activated until the login is finished though the audio line in is deactivated in the virtualbox preferences.
After the login is over it is deactivated again as my firewall indicates.
Why does this happen though it is deactivated?

I did a research and found a similiar question here - but the answer is unsatisfying and doesn't hit:

viewtopic.php?f=7&t=67842&p=321583&hilit=Audio+activated#p321457

How can I stop this whenever I don't need it?
ergo
 
Posts: 18
Joined: 18. Mar 2009, 22:10

Re: Cannot turn off/disable microphone for VB

Postby socratis » 22. Jan 2019, 00:01

ergo wrote:How can I stop this whenever I don't need it?
I merged your thread with an existing one that explains what you need to do. Read the whole thread please...

But I think that 10.14 users are becoming a little bit paranoid, thanks Apple! ;)
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24358
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Cannot turn off/disable microphone for VB

Postby ergo » 22. Jan 2019, 13:01

But I think that 10.14 users are becoming a little bit paranoid, thanks Apple!

Well socratis, this may be - but is not the real reason here for my question.
Besides, I am not a 10.14er but of a deeper version. :wink:

I didn't want to tell long stories and therefore focussed on the problem at first.
Of course Micro Snitch's displayed messages are the origin for this.

My background for this question:
What will happen when I change my host system to a Linux Distro and will use Virtualbox there?
I feel a little bit uncomfortable that with every boot audio line in is activated though is deactivated in VM settings and in the status bar in the bottom line and remains activated until login is finished - at least here.

Two questions please, socratis:
  1. Why and wherefore does this happen? What is the idea?
  2. Who or better what guarantees it is deactivated when no Micro Snitch will tell it is because there is no Micro Snitch or a similar app for another OS available as far as I know?
Obviously to uncheck these options in preferences doesn't work.
ergo
 
Posts: 18
Joined: 18. Mar 2009, 22:10

Re: Cannot turn off/disable microphone for VB

Postby socratis » 22. Jan 2019, 13:35

ergo wrote:Of course Micro Snitch's displayed messages are the origin for this.
I think that apps like that are in cohorts with psychologists/psychiatrists/pharmaceuticals for the "extra careful" users. :D

Unless you keep on repeating vocally your passwords, or your significant other is spying on you, then I think that reactions like these are exaggerated. But that's my own personal opinion. I stopped worrying when Stasi closed shop... ;)

ergo wrote:What will happen when I change my host system to a Linux Distro and will use Virtualbox there?
I suspect the same thing/behavior. VirtualBox is an application that provides sound services to its guests. Don't you think that it should check if that sound foundation should be checked for availability/working state? Maybe that's what's triggering the alarm...

ergo wrote:though is deactivated in VM settings and in the status bar in the bottom line
To ease your fears, check also the audio input in your guest. If you're *really* unconformable with that, disable audio altogether!
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24358
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: socratis and 14 guests