Page 1 of 1

VBHeadless suddenly requires the microphone to be active when starting Vagrant Box

PostPosted: 18. Oct 2018, 07:03
by retrovertigo
After updating to VB 5.2.20 when starting Homestead/Vagrant it requires activating the microphone on my machine:
screenshots.firefox.com/OgY82ROnL4TsU38j/files.slack.com [ModEdit: screenshot "expired", that's why you should attach images locally]

If I block the request booting fails.

I for now manually set the mic to low, but I might downgrade VB soon and see if the issue persists or not.

Re: VBHeadless suddenly requires the microphone to be active when starting Vagrant Box

PostPosted: 18. Oct 2018, 07:54
by socratis
  1. Vagrant is a program that relies on VirtualBox but modifies its configuration files in unknown ways to us. It is not supported on these VirtualBox user forums, they have their own Vagrant support channels. If you are having this problem with a standalone version of VirtualBox, then we can continue this discussion.

  2. This icon is not a VirtualBox icon. Who/what is causing this dialog to pop up?

  3. I'm not sure I understand the following statement. What does "set the mic to low" mean?
    retrovertigo wrote:I for now manually set the mic to low

Re: VBHeadless suddenly requires the microphone to be active when starting Vagrant Box

PostPosted: 23. Nov 2018, 07:49
by retrovertigo
Thanks for getting back to me socratis!

I now found the setting. Just had to deactivate Audio input - maybe it wasn't activated before or couldn't be used by the box for some reason!?
See screenshot

Just to quickly reply to your response:
1) fair enough
2) https://objective-see.com/products/oversight.html
3) I changed the setting in my macOS host by kinda switching the mic off there (macOS > System Preferences > Sound > Input Volumn)

Re: VBHeadless suddenly requires the microphone to be active when starting Vagrant Box

PostPosted: 15. Jan 2019, 02:32
by retrovertigo
To add to this, here is the error message when I block the request to access the mic:

Code: Select all   Expand viewCollapse view
default: Warning: Connection reset. Retrying...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["showvminfo", "32053cd8-775a-467f-abe3-323364b8a164", "--machinereadable"]

Stderr: VBoxManage: error: The object is not ready
VBoxManage: error: Details: code E_ACCESSDENIED (0x80070005), component SessionMachine, interface IMachine, callee nsISupports
VBoxManage: error: Context: "COMGETTER(BandwidthControl)(bwCtrl.asOutParam())" at line 2322 of file VBoxManageInfo.cpp

Re: VBHeadless suddenly requires the microphone to be active when starting Vagrant Box

PostPosted: 15. Jan 2019, 02:46
by socratis
@retrovertigo
This is not a message that I'm familiar with, maybe it's Vagrant specific? I wouldn't know.

BTW, I just went to check the image from your first post, and it has expired! That's why you should attach images locally... ;)

Re: VBHeadless suddenly requires the microphone to be active when starting Vagrant Box

PostPosted: 15. Jan 2019, 10:04
by retrovertigo
socratis wrote:@retrovertigo
This is not a message that I'm familiar with, maybe it's Vagrant specific? I wouldn't know.

fair enough. thanks for checking it.

socratis wrote:BTW, I just went to check the image from your first post, and it has expired! That's why you should attach images locally... ;)

Yeap, I saw that today as well. for general reference it was a screenshot similar to this
webcamAlert.png
webcamAlert.png (14.92 KiB) Viewed 636 times

from https://objective-see.com/products/oversight.html