Failed to install the Extension Pack (5.4.2)

Discussions related to using VirtualBox on Mac OS X hosts.

Failed to install the Extension Pack (5.4.2)

Postby Eschscholzia » 5. Jan 2018, 20:47

On Mac OS 10.11.6, I updated to VBox 5.4.2 a while back but didn't get to the additions install until today. I used http://download.virtualbox.org/virtualb ... ox-extpack to download the extensions pack 5.4.2 and attempted to install it. I got this error on the install:
Failed to install the Extension Pack /Users/MyUserName/Downloads/Oracle_VM_VirtualBox_Extension_Pack-5.2.4-119785.vbox-extpack.

Failed to load the main module ('/Applications/VirtualBox.app/Contents/MacOS/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/darwin.amd64/VBoxPuelMain.dylib'): VERR_FILE_NOT_FOUND - dlopen(/Applications/VirtualBox.app/Contents/MacOS/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/darwin.amd64/VBoxPuelMain.dylib, 6): Library not loaded: /Applications/VirtualBox.app/Contents/MacOS/VBoxVMM.dylib

Referenced from: /Applications/VirtualBox.app/Contents/MacOS/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/darwin.amd64/VBoxPuelMain.dylib

Reason: Incompatible library version: VBoxPuelMain.dylib requires version 5.2.4 or later, but VBoxVMM.dylib provides version 5.1.30.

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ExtPackManagerWrap
Interface: IExtPackManager {edba9d10-45d8-b440-1712-46ac0c9bc4c5}

and when I tried to reopen my VBox to recapture the screen that reminded me about the new extension pack, I get this error:
Failed to open a session for the virtual machine Windows 7.

Implementation of the USB 2.0 controller not found!

Because the USB 2.0 controller state is part of the saved VM state, the VM cannot be started. To fix this problem, either install the 'Oracle VM VirtualBox Extension Pack' or disable USB 2.0 support in the VM settings.

Note! This error could also mean that an incompatible version of the 'Oracle VM VirtualBox Extension Pack' is installed (VERR_NOT_FOUND).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Help!
Last edited by socratis on 5. Jan 2018, 21:22, edited 1 time in total.
Reason: Fixed formatting.
Eschscholzia
 
Posts: 7
Joined: 27. Oct 2016, 18:12

Re: Failed to install the Extension Pack (5.4.2)

Postby socratis » 5. Jan 2018, 21:25

You need to have the same version of the ExtPack as the main VirtualBox version. So, if you have VirtualBox 5.2.4, you should remove any other instances of the ExtPack and install 5.2.4. They're both in the same Downloads page...

And use the "VirtualBox_Uninstall.tool" in the VirtualBox.dmg that you downloaded to clean/uninstall any previous installed versions.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25216
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed to install the Extension Pack (5.4.2)

Postby flabbynaps » 19. Mar 2019, 20:09

There is only one extension pack I see on the wiki/Downloads. The "all supported platforms" link goes to one single binary. lol.
flabbynaps
 
Posts: 1
Joined: 19. Mar 2019, 20:07

Re: Failed to install the Extension Pack (5.4.2)

Postby socratis » 19. Mar 2019, 21:24

Any proposals why it shouldn't be? I'm not quite sure I understand your comment. There are binaries per platform (think Firefox) and add-ons for all platforms.

BTW, I'm not sure that the OP would see your message, haven't logged in since 2018-01-05... ;)
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25216
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: 007fred50 and 7 guests