Page 1 of 1

Using latest VirtualBox on my Mac(10.13.1), got a error message

PostPosted: 3. Dec 2017, 05:33
by kit1888
Hi, I was learning docker and trying to use VirtualBox creating a virtual machine (by docker) as follows:

Code: Select all   Expand viewCollapse view
docker-machine create --driver virtualbox myvm1


However, I got error messages:

(myvm1) Creating a new host-only adapter produced an error: /usr/local/bin/VBoxManage hostonlyif create failed:
(myvm1) 0%...
(myvm1) Progress state: NS_ERROR_FAILURE
(myvm1) VBoxManage: error: Failed to create the host-only adapter
(myvm1) VBoxManage: error: VBoxNetAdpCtl: Error while adding new interface: failed to open /dev/vboxnetctl: No such file or directory
(myvm1) VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
(myvm1) VBoxManage: error: Context: "RTEXITCODE handleCreate(HandlerArg *)" at line 94 of file VBoxManageHostonly.cpp
(myvm1)
(myvm1) This is a known VirtualBox bug. Let's try to recover anyway...
Error creating machine: Error in driver during machine creation: Error setting up host only network on machine start: The host-only adapter we just created is not visible. This is a well known VirtualBox bug. You might want to uninstall it and reinstall at least version 5.0.12 that is is supposed to fix this issue


But I use the latest version so I don't know what is wrong with it and how I can solve it.
BTW when I installed virtualBox on MacBook, the installation firstly showed that I failed in installing it, but anyhow, it is indeed installed on my mac.

Re: Using latest VirtualBox on my Mac(10.13.1), got a error message

PostPosted: 3. Dec 2017, 06:06
by socratis
Docker is a program that relies on VirtualBox but modifies its configuration files in unknown ways to us. It is not supported on these VirtualBox user forums, they have their own Docker support channels. If you are having this problem with a standalone version of VirtualBox, then we can continue this discussion.

kit1888 wrote:BTW when I installed virtualBox on MacBook, the installation firstly showed that I failed in installing it, but anyhow, it is indeed installed on my mac.
How can it fail and getting installed at the same time? It doesn't compute.

Re: Using latest VirtualBox on my Mac(10.13.1), got a error message

PostPosted: 3. Dec 2017, 06:14
by kit1888
when I clicked the install button, after a while, there's a dialog telling me I failed (refer to attachment), but meanwhile, an icon of virtualbox exists on my mac and I can open it.

Re: Using latest VirtualBox on my Mac(10.13.1), got a error message

PostPosted: 3. Dec 2017, 06:41
by socratis
  1. Reboot.
  2. Download the latest release, or the latest test build (https://www.virtualbox.org/wiki/Testbuilds), if you don't already have them.
  3. Mount the DMG from the previous step. Run "VirtualBox_Uninstall.tool". Make sure there are no error messages. If there are, please post them, exactly as they appear.
  4. Reboot.
  5. Mount the DMG from the previous steps. Double-click the "VirtualBox.pkg". As soon as you start the installation, press Cmd+L to show the log. Select "Show All Logs" from the drop-down menu. Before the last step of the installation (Done), click the "Save" in the log window. ZIP and attach that file.
  6. Start VirtualBox. If it crashes, open Console.app and look at "~/Library/Logs". Is there a VirtualBox related log with the current date/time? ZIP and attach that file as well.

PS. Next time, please downsize your attached images by 50% (at least). Not everyone is blessed with a HiDPI display ;)

Re: Using latest VirtualBox on my Mac(10.13.1), got a error message

PostPosted: 3. Dec 2017, 07:10
by kit1888
Thanks. I followed your suggestions and uploaded the log.

Re: Using latest VirtualBox on my Mac(10.13.1), got a error message

PostPosted: 3. Dec 2017, 10:21
by socratis
Please reboot your host and once it has rebooted, post the output of the command in the Terminal:
    kextstat | grep -v com.apple