Page 1 of 1

Win 10 VM keyboard issues on Mac OSX host

PostPosted: 2. Dec 2017, 20:43
by startingtopuff
I have just created a Win 10 VM on my iMac. Both host & VM are configured to use UK keyboard, UK region. Unfortunately both the " and @ are transposed. This issue has been raised previously on this forum but became rather messy with no solution. This was 2-3 years ago so I wondered if anyone has any fresh thoughts on the problem?

Re: Win 10 VM keyboard issues on Mac OSX host

PostPosted: 2. Dec 2017, 22:59
by socratis
I have multiple VMs set up with dual US/Greek keyboards, same as my host, never had the slightest problem. Actually the host is a triple layout US/Greek/Unicode, but it's the same. So, I'm not quite sure what you refer to when you say that there are are problems. There is a layout that should work for you in your setup, that's for sure, I simply don't have your keyboard in front of me to test/reconfigure it.

I would suggest to try with a couple of layouts and I'm sure that it's going to work. It just needs the right combination. ;)

Re: Win 10 VM keyboard issues on Mac OSX host

PostPosted: 3. Dec 2017, 00:05
by BillG
I have seen the " and @ problem. It was a US/UK keyboard mix.

Re: Win 10 VM keyboard issues on Mac OSX host

PostPosted: 3. Dec 2017, 11:08
by mpack
Yup. Speaking as someone from the UK, it's a common problem, and the solution is the same as it has been since the 1980s: fix the incorrect keyboard layout selection in your OS. The statement that the keyboard is already correctly configured (i.e. matches the keyboard) cannot be correct, otherwise you wouldn't still be getting the symptoms.

Of course one complicating factor is that the Mac doesn't have a PC keyboard, so no standard PC keyboard layout selection will be correct. ISTR this discussion cropping up before and the suggestion was to go look for the keyboard layout provided by Apple for their Windows dual boot option.