Trouble creating a NAT network

Discussions related to using VirtualBox on Mac OS X hosts.

Trouble creating a NAT network

Postby robertdawson » 23. Nov 2017, 11:38

I want to use a NAT network to connect different VMs on my Mac 10.11.6's Virtual Box.
I copy-pasted the following command from the VirtualBox (version 5.1.30) :

Code: Select all   Expand viewCollapse view
VBoxManage natnetwork add --netname natnet1 --network "192.168.15.0/24" --enable


This should create a NAT network named "natnet1", right ?
But I did not do it correctly, because no name appears in the "Network Settings" section :

explain1.png
explain1.png (44.05 KiB) Viewed 75 times


Any help appreciated.
robertdawson
 
Posts: 20
Joined: 11. Jan 2017, 13:23

Re: Trouble creating a NAT network

Postby Perryg » 23. Nov 2017, 14:40

Look in the pull down for the "attached to:" and see if you have "NAT network". That is what you configured and not NAT.
Perryg
Site Moderator
 
Posts: 34269
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Trouble creating a NAT network

Postby robertdawson » 23. Nov 2017, 15:09

Perryg wrote:Look in the pull down for the "attached to:" and see if you have "NAT network".


Indeed, it seems to work now :

explain2.png
explain2.png (23.42 KiB) Viewed 65 times


Thanks for your help.
robertdawson
 
Posts: 20
Joined: 11. Jan 2017, 13:23


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 15 guests