Windows XP on Mac OS X

Discussions related to using VirtualBox on Mac OS X hosts.

Windows XP on Mac OS X

Postby MBQhiker » 7. Aug 2008, 22:54

As I load Windows XP on the new partition, things start off well. I have the partition set up with 512 MB memory and 10 GB of hard drive. The system gets to a point where it says that the partition needs to be formatted. At that point, my whole system locks up. I let it go overnight and still 0% formatted.

Any ideas?
MBQhiker
 
Posts: 5
Joined: 7. Aug 2008, 00:17

Installing XP on Mac OS X Host

Postby amagine » 7. Aug 2008, 23:30

What version of XP are you using. I have not tried anything less than XP SP2.

512MB Ram and 10Gb image should be fine.

What is your Pre-installation setup?

It should not take more than a few minutes to format, and I always choose the "Quick Format - NTFS" seems to work fine for me.

FYI: Here is the setup I have working fine. After quite a few different installs:
http://forums.virtualbox.org/viewtopic. ... highlight=

You may need to try another test run install from fresh, perhaps there was a glitch of some sort?
amagine
Volunteer
 
Posts: 177
Joined: 28. Jul 2008, 19:52

Postby MBQhiker » 7. Aug 2008, 23:42

Here's what I have:
Model Name: Mac mini
Model Identifier: Macmini1,1
Processor Name: Intel Core Duo
Processor Speed: 1.66 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache (per processor): 2 MB
Memory: 512 MB
Bus Speed: 667 MHz
Boot ROM Version: MM11.0055.B08
SMC Version: 1.3f4

2 banks of 256 MB DDR2 SDRAM 667 MHz (512 MB total)

Mac OS X 10.4.11

I have an older version of XP that did not include SP2. That was a leter addition. Perhaps I need a more current version of Windows.
MBQhiker
 
Posts: 5
Joined: 7. Aug 2008, 00:17

Postby MBQhiker » 7. Aug 2008, 23:48

Here's the VirtualBox setup:

General
Name XP for TM
OS Type Windows XP
Base Memory 512 MB
Video Memory 8 MB
Boot Order Floppy, CD/DVD-ROM, Hard Disk
ACPI Enabled
IO APIC Disabled
VT-x/AMD-V Disabled
PAE/NX Disabled

Hard Disks
IDE Primary Master
XP for TM.vdi [Normal, 10.00 GB]


CD/DVD-ROM
Host Drive MATSHITA CD-RW CW-8124

Floppy
Not mounted

Audio
Host Driver Null Audio Driver
Controller ICH AC97


Network
Adapter 0 PCnet-FAST III (NAT)


Serial Ports
Disabled

USB
Device Filters 0 (0 active)

Shared Folders
None

Remote Display
Disabled
MBQhiker
 
Posts: 5
Joined: 7. Aug 2008, 00:17

Postby dmcgraw » 7. Aug 2008, 23:52

Do I understand correctly that the Host machine has 512MB RAM and you are trying to give 512MB to the Guest?

Dave
dmcgraw
Volunteer
 
Posts: 808
Joined: 24. Jun 2008, 17:16
Location: St. Louis, MO, USA
Primary OS: Ubuntu 8.10
VBox Version: PUEL
Guest OSses: XP, Ubuntu 9.10

Postby MBQhiker » 7. Aug 2008, 23:53

Yes, I did. I incorrectly "assumed" I had 1 GB of memory. Sounds like a change is in order.
MBQhiker
 
Posts: 5
Joined: 7. Aug 2008, 00:17

... XP versions/editions supported?

Postby amagine » 8. Aug 2008, 00:02

All XP versions are supported. I just like knowing the details, I am fairly new to VirtualBox so I have limited understanding of the statistical trend of success for installing Guest OS's. So many variables.

1.3.2 Supported guest operating systems
from the VirtualBox UserManual.pdf

...... Windows 2000 / XP / Server 2003 / Vista All versions/editions and service packs are fully supported. Guest Additions are available. ....

I did notice that you indicated your Mac has 512MB of Ram and you assigned 512MB to Guest XP... This is likely the problem.

*** oops notice dmcgraw caught this. And thus the reason why it is always soo helpfull to list your full setup for troubleshooting ***
amagine
Volunteer
 
Posts: 177
Joined: 28. Jul 2008, 19:52

Postby MBQhiker » 8. Aug 2008, 02:39

I scaled back on the memory for the virtual machine to 256MB and I am now up and running Windows on the partition!

Thanks for helping me get through typical oversight problems.
MBQhiker
 
Posts: 5
Joined: 7. Aug 2008, 00:17


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Daterp and 32 guests