Installation fails on 10.13.x, 10.14.x (rc=-1908)

Discussions related to using VirtualBox on Mac OS X hosts.

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 6. Nov 2018, 23:18

@cdc
If your first time VirtualBox installation failed, then that's the only known thing that can fix it. I need to to describe in detail what you did. Exactly...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby Jupatrix » 9. Nov 2018, 16:53

I'm in trouble with my virtual box. After Mac OS atualization. I can't open my virtual machines, neither install new version of Virtual Box.
Attachments
Registro do Instalador 8-Nov-2018.txt.zip
(3.25 KiB) Downloaded 32 times
Jupatrix
 
Posts: 1
Joined: 9. Nov 2018, 16:48

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 9. Nov 2018, 18:11

@Jupatrix
Nov  8 22:58:32 MacBook-Pro-de-Jupara installd[673]: ./postflight:
/Library/Application Support/VirtualBox/VBoxDrv.kext failed to load -
(libkern/kext) system policy prevents loading; check the system/kernel
logs for errors or try kextutil(8).

Read the thread from the beginning... The 1st post.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby CO-VBOX » 15. Feb 2019, 23:40

On OSX High Sierra 10.13.6 on a Mid 2009 13 inch MacBook Pro. HighSierra was force installed onto this unsupported hardware.

I had the same error messages trying to run Virtual Box and during the Virtual Box post installation phase.

From a Terminal window my solution was:

sudo touch /System/Library/Extensions

Background, my previous system update hung resulting in outdated startup caches in /System/Library/Caches/com.apple.kext.caches/Startup compared to a newer /System/Library/Extensions/System.kext.

Listing "ls -altF /System/Library/Extensions" revealed that the Extensions directory had an older date stamp than some of the kernel extensions, so the cache needed to be rebuilt by touching the directory which starts up the kextcache commands needed to update the startup cache.

In all cases, VBoxDrv.kext failed to load with undefined symbols that are in com.apple.kpi.private.

My unsupported Vmware Fusion version 7.1.3 had the same problem - it was unable to locate the kennel symbol map.

Parallels 14 ran even with the incorrect cache.

VirtualBox 6.0.4 is now running, as is VMWare Fusion 7.1.3, as is a trail of Parallels 14.

So long, for today, hope this works for you. Apple's reinstall the OS for any problem would get you a fresh cache:)
CO-VBOX
 
Posts: 1
Joined: 15. Feb 2019, 22:19

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 17. Feb 2019, 11:17

@CO-VBOX
You do realize that this is a hack and completely unsupported, right? Mainly because the foundation is not supported (OSX on your computer), not because VirtualBox won't run on 10.13/14...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby Samuel:) » 10. Mar 2019, 04:43

Hello. I am unable to install VirtualBox. I am running OS X 10.13.6. I have tried every solution I can find on the internet including everything on this forum as of the time of this writing. I never received the System Preference "allow" prompt even after numerous reboots and extensive waiting. I have even entered recovery mode and entered the command:
Code: Select all   Expand viewCollapse view
spctl kext-consent add VB5E2TV963

When I run
Code: Select all   Expand viewCollapse view
kextstat | grep -v com.apple

I get no output under the headers. I have attached the installer logs. Please help.
Attachments
Installer Log 9-Mar-2019.txt.zip
(3.21 KiB) Downloaded 19 times
Samuel:)
 
Posts: 3
Joined: 9. Mar 2019, 22:37

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 10. Mar 2019, 20:46

Mar  9 18:38:36 Sams-MBP-2 installd[493]: ./postflight: /Library/Application
Support/VirtualBox/VBoxDrv.kext failed to load - (libkern/kext) authentication
failure (file ownership/permissions)
; check the system/kernel logs for errors or
try kextutil(8).

There appears to be something wrong with your system's permissions. Post the output of the commands (from /Applications/Utilities/Terminal):

    ls -aled@ \
    / \
    /Applications \
    /Applications/VirtualBox.app \
    /Applications/VirtualBox.app/Contents/MacOS/VirtualBox \
    /Applications/VirtualBox.app/Contents/MacOS/VirtualBoxVM \
    /Applications/VirtualBox.app/Contents/MacOS/VBoxRT.dylib \
    /Library \
    /Library/Filesystems \
    /Library/Frameworks \
    /private \
    /private/etc \
    /private/etc/sudoers \
    /private/tmp \
    /usr/local/lib
Yes, it is a big one, just copy/paste it in the Terminal.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby Samuel:) » 11. Mar 2019, 21:41

@socratis here is the output of the commands:
drwxr-xr-x@ 30 root  wheel       960 Feb 25 00:51 /
com.apple.backupd.unlockrecordUUIDs 168
drwxrwxr-x+ 59 root admin 1888 Mar 11 12:35 /Applications
0: group:everyone deny delete
drwxr-xr-x 3 root admin 96 Jan 25 10:45 /Applications/VirtualBox.app
-rw-r--r-- 1 root admin 5903952 Jan 25 10:46 /Applications/VirtualBox.app/Contents/MacOS/VBoxRT.dylib
-rwxr-xr-x 1 root admin 33067904 Jan 25 10:46 /Applications/VirtualBox.app/Contents/MacOS/VirtualBox
-rwsr-xr-x 1 root admin 157264 Jan 25 10:46 /Applications/VirtualBox.app/Contents/MacOS/VirtualBoxVM
drwxr-xr-x+ 63 root wheel 2016 Dec 28 12:07 /Library
0: group:everyone deny delete
drwxr-xr-x 4 root wheel 128 Mar 11 12:35 /Library/Filesystems
drwxr-xr-x 10 root wheel 320 Mar 11 12:35 /Library/Frameworks
drwxr-xr-x 6 root wheel 192 Mar 27 2018 /private
drwxr-xr-x 88 root wheel 2816 Mar 11 12:33 /private/etc
-r--r----- 1 root wheel 1563 Feb 12 2018 /private/etc/sudoers
drwxrwxrwt 6 root wheel 192 Mar 11 12:36 /private/tmp
drwxrwxr-x 27 sam admin 864 Mar 11 12:35 /usr/local/lib
Last edited by socratis on 14. Mar 2019, 16:48, edited 1 time in total.
Reason: Enclosed the information in [quote][pre] tags for better readability
Samuel:)
 
Posts: 3
Joined: 9. Mar 2019, 22:37

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 14. Mar 2019, 16:52

Samuel:) wrote:
drwxrwxr-x 27 sam admin 864 Mar 11 12:35 /usr/local/lib

This is your problem. In no way, shape or form should "/usr/local/lib" be owned by anyone else except 'root'. Please fix that.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby Samuel:) » 14. Mar 2019, 23:03

I have changed the ownership of "/usr/local/lib" to 'root', but I am still unable to install VirtualBox.

I have also tried using "kextload" on all the .kexts in /Library/Application Support/VirtualBox/ but I receive the following errors:
Code: Select all   Expand viewCollapse view
/Library/Application Support/VirtualBox/VBoxDrv.kext failed to load - (libkern/kext) authentication failure (file ownership/permissions); check the system/kernel logs for errors or try kextutil(8).
/Library/Application Support/VirtualBox/VBoxNetAdp.kext failed to load - (libkern/kext) authentication failure (file ownership/permissions); check the system/kernel logs for errors or try kextutil(8).
/Library/Application Support/VirtualBox/VBoxNetFlt.kext failed to load - (libkern/kext) authentication failure (file ownership/permissions); check the system/kernel logs for errors or try kextutil(8).
/Library/Application Support/VirtualBox/VBoxUSB.kext failed to load - (libkern/kext) authentication failure (file ownership/permissions); check the system/kernel logs for errors or try kextutil(8).

I hope this gives more context. I am considering just installing a fresh OS.
Samuel:)
 
Posts: 3
Joined: 9. Mar 2019, 22:37

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby SwiftRob » 15. Mar 2019, 04:29

Hi there,

I have two macs that are both failing to install VirtualBox.

I've tried the latest 6.x and recent 5.x installers and they do the same.
I've checked and the appropriate system folders are owned by root.
I've rebooted.
I've tried pressing the Allow Oracle button in the mac system security settings, but i DO get the feeling that button is not working.
MacOS 10.13.6 is the machine I'm sending the logs from.
Logs are here after an install: https://pastebin.com/ishJntdU

If anyone can offer some advice it would be greatly appreciated.

Thank you.
SwiftRob
 
Posts: 11
Joined: 26. Jul 2012, 10:27

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 15. Mar 2019, 09:41

SwiftRob wrote:If anyone can offer some advice it would be greatly appreciated.

Reinstall OSX. From the recovery partition. That's the only sure way of resetting the permissions that I know of.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby SwiftRob » 15. Mar 2019, 10:17

Hi and thanks for answering.
I want to just check we're not getting our wires crossed.
I have 2 x mac computers and want to install virtualbox so I can run windows on them.
Are you saying I have to fully format both mac computers and start with a fresh OSX?
If that's the case it's something I can't do (they are not my machines). There surely is another way? Did the error log indicate something I can focus on perhaps?

Thanks again, I appreciate your answer.
SwiftRob
 
Posts: 11
Joined: 26. Jul 2012, 10:27

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 15. Mar 2019, 11:00

Here's the thing... There can be too many things going on with (what you think) is a clean host installation. And I'm not talking OSX only, OK? People think that they have the cleanest installation, nothing added on. No. This is almost never the case. People install "things" and those "things" tend to screw up the host royally.

So, my advice? Start from scratch! I've been painstakingly trying to solve one too many problems. I give up. Just re-install it and get a fresh start...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Kernel Panic - Bluetooth, Mac OS X 10.14.3 Mojave (#18107)

Postby PTP23 » 31. Mar 2019, 06:20

Getting this error. What should I do?

Kernel driver not installed (rc=-1908)

Make sure the kernel module has been loaded successfully.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.
PTP23
 
Posts: 20
Joined: 26. Oct 2018, 01:15

PreviousNext

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Google [Bot] and 14 guests