Installation fails on 10.13.x, 10.14.x (rc=-1908)

Discussions related to using VirtualBox on Mac OS X hosts.

Re: Kernel driver not installed (rc=-1908)

Postby socratis » 22. Feb 2018, 12:41

Which brings us back to the source/cause of the problem... See above.
;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Kernel driver not installed (rc=-1908)

Postby AnaphylacticPenquin » 29. Apr 2018, 21:53

After trying to re-install, you must go to the 'Security & Privacy' section in settings. There you will find a notification that will 'allow' the program. I am fairly confident that you must try to install first before the message will appear.

It would be really interesting to start a thread about the evolution of Gatekeeper, etc... It seems that this new feature is more of an annoyance to its users than a real security implementation.

Thoughts?
AnaphylacticPenquin
 
Posts: 1
Joined: 29. Apr 2018, 21:45

Re: Kernel driver not installed (rc=-1908)

Postby socratis » 29. Apr 2018, 21:58

AnaphylacticPenquin wrote:It would be really interesting to start a thread about the evolution of Gatekeeper, etc... It seems that this new feature is more of an annoyance to its users than a real security implementation.

I believe that the Apple forums are more appropriate for this kind of discussions. It's not like it's a VirtualBox problem, VirtualBox is the victim here, along with a gazillion other applications, of a halfwit software engineer with hey[1] for brains regarding security!


[1]: I had something else in mind, but let's keep it civil ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Kernel driver not installed (rc=-1908)

Postby SuhasPaul » 16. Jun 2018, 08:08

Hi ,

I have tried allowing "oracle America" in system preferences. Still the re-installation is not successful. Please suggest me a way to install virtual box 5.2.12.

Note: When clicking "allow" in system preference there is nothing like it was accepted. :(
SuhasPaul
 
Posts: 1
Joined: 16. Jun 2018, 08:04

Re: Kernel driver not installed (rc=-1908)

Postby socratis » 16. Jun 2018, 10:35

SuhasPaul wrote:When clicking "allow" in system preference there is nothing like it was accepted.

Are you controlling the Mac remotely? Apple does not allow that option to be activated remotely. You have to be sitting physically in front of your computer for that "Allow" to work. It took us quite some time to figure that out!
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Kernel driver not installed (rc=-1908)

Postby underp » 3. Jul 2018, 01:03

If you are using MagicPrefs (or likely any app that intercepts mouse events), the allow button won't work. For me, exiting MagicPrefs allowed the button to work and the installation to work after that.
underp
 
Posts: 1
Joined: 3. Jul 2018, 00:59

Re: Kernel driver not installed (rc=-1908)

Postby merlinni » 30. Jul 2018, 23:28

Hi, I am a Virtual Box user who is not a computer expert. I just got this error today. I read through this thread, but it got pretty confusing for me, can someone please tell me what I need to do to get Virtual Box running again on my iMac (high Sierra)? VirtualBox tells me I'm running the latest version, 5.2.16. Please help, and hopefully I can follow the instructions for a solution. thank you!!

Kernel driver not installed (rc=-1908)
Make sure the kernel module has been loaded successfully.
where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.
merlinni
 
Posts: 6
Joined: 30. Jul 2018, 23:21

Re: Kernel driver not installed (rc=-1908)

Postby socratis » 30. Jul 2018, 23:55

There are no steps to repeat. If this is your first time that you're using VirtualBox then most probably you have to read the Apple Documentation: User-Approved Kernel Extension Loading and take appropriate action.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Kernel driver not installed (rc=-1908)

Postby merlinni » 31. Jul 2018, 01:37

Thanks for that info, and for the link to the Apple Documentation. I read it, and now understand that I need to approve the KEXT somehow, but I am past the 30-minute window where the alert option to do that shows up in my System Preferences window. Am I on the right track, and if so, can you tell me how can I approve the KEXT to hopefully get VirtualBox working again?
merlinni
 
Posts: 6
Joined: 30. Jul 2018, 23:21

Re: Kernel driver not installed (rc=-1908)

Postby socratis » 31. Jul 2018, 08:29

@merlinni
Reboot your Mac. That will reset the timer.
Oh, and don't forget to thank Apple for their infinite wisdom... ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x (rc=-1908)

Postby emudevsRassclowns » 11. Oct 2018, 02:05

tried to install, says installation failed, but then somehow the program runs anyway. When clicking CMD L after install i get the following. Have had an impossible time of installing bluestacks as well which crashes on opening. Even where i could install blue stacks on my bootcamp windows partition it doesn't work right. 95% to the point of saying SPAM_SEARCH emulators. Any help appreciated ive been at this for two days. Situation is I am living in a place with no service and weak wifi(so my phone cant get it but my laptop can) and I need a couple of apps to work

[ModEdit: Removed partial copy/paste Installer log]

by the way when I do go into VB, set up a VM with android 86 7.2 I get the kernel error message. I do not have the prompts from apple about security. I did at first but resolved them by approving them and haven't seen them since even when reinstalling. They preferences seem to be remembered.
The virtual machine 'android' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {85cd948e-a71f-4289-281e-0ca7ad48cd89}
Last edited by socratis on 11. Oct 2018, 10:17, edited 1 time in total.
Reason: Removed partial log.
emudevsRassclowns
 
Posts: 3
Joined: 11. Oct 2018, 01:59

Re: Installation fails on 10.13.x (rc=-1908)

Postby socratis » 11. Oct 2018, 10:27

emudevsRassclowns wrote:When clicking CMD L after install
Not after, during the install! Please read the instructions again. And please do not post chunks of text. Just follow the instructions and post the whole log ZIPPED.

emudevsRassclowns wrote:Have had an impossible time of installing bluestacks
That's not something we can help you with here...

emudevsRassclowns wrote:to the point of saying SPAM_SEARCH emulators
Swearing on your first post? Tsk, tsk, tsk...

emudevsRassclowns wrote:set up a VM with android 86 7.2
That's not officially a supported guest.

emudevsRassclowns wrote:I do not have the prompts from apple about security
Read the thread from the beginning. A reboot of your Mac always works. And if don't get prompted, just go ahead in the Security settings and "Allow Oracle".
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x (rc=-1908)

Postby emudevsRassclowns » 13. Oct 2018, 02:12

Code: Select all   Expand viewCollapse view
Oct 12 18:11:55 daniels-MacBook-Air installd[448]: PackageKit: ----- Begin install -----
Oct 12 18:11:59 daniels-MacBook-Air installd[448]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “VirtualBox.pkg”." UserInfo={NSFilePath=./postflight, NSURL=file://localhost/Volumes/VirtualBox/VirtualBox.pkg#VBoxKEXTs.pkg, PKInstallPackageIdentifier=org.virtualbox.pkg.vboxkexts, NSLocalizedDescription=An error occurred while running scripts from the package “VirtualBox.pkg”.} {
       NSFilePath = "./postflight";
       NSLocalizedDescription = "An error occurred while running scripts from the package \U201cVirtualBox.pkg\U201d.";
       NSURL = "file://localhost/Volumes/VirtualBox/VirtualBox.pkg#VBoxKEXTs.pkg";
       PKInstallPackageIdentifier = "org.virtualbox.pkg.vboxkexts";
   }
Oct 12 18:12:00 daniels-MacBook-Air Installer[11270]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Oct 12 18:12:00 daniels-MacBook-Air Installer[11270]: Displaying 'Install Failed' UI.
Oct 12 18:12:00 daniels-MacBook-Air Installer[11270]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.

how am i supposed to zip that. It's not even possible to do anything with that after the prompt to keep or trash installer comes up

there is nothing showing up in the settings as I said, have rebooted multiple times
Last edited by socratis on 13. Oct 2018, 08:29, edited 1 time in total.
Reason: Enclosed the information in [quote][code] tags for better readability
emudevsRassclowns
 
Posts: 3
Joined: 11. Oct 2018, 01:59

Re: Installation fails on 10.13.x (rc=-1908)

Postby socratis » 13. Oct 2018, 08:39

emudevsRassclowns wrote:how am i supposed to zip that. It's not even possible to do anything with that after the prompt to keep or trash installer comes up
I'm going to link you a second (and hopefully last) time to the instructions on how to grab the complete installer log. Including how to Save it and ZIP it. Plus the commands that I need you to run and post the output. Please read and follow them exactly this time.


PS. Can you please read the 2nd line of my signature below?
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27382
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby cdc » 6. Nov 2018, 23:00

I'm running macOS 10.14.1 and VB 5.2.20 r125813. I've run through the various solutions offered but nothing works. I thought this had been fixed when 10.14 was released.
cdc
 
Posts: 2
Joined: 6. Nov 2018, 15:57

PreviousNext

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot] and 10 guests