Installation fails on 10.13.x, 10.14.x (rc=-1908)

Discussions related to using VirtualBox on Mac OS X hosts.

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby TheQL » 18. Apr 2021, 15:01

Have you checked and fixed the permissions of the kext staging folders as suggested in the last few posts in this very thread?
TheQL
 
Posts: 15
Joined: 4. Nov 2020, 22:27

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby tcw » 19. Apr 2021, 22:33

I thought I had, but digging through further it seems not - one of the folders didn't have the restricted tag.

After a bunch of confusion I eventually realised I had to go into disk utility and mount Macintosh HD before doing the relevant chflags commands in recovery mode.

Once that was done, the issue was fixed! Thanks very much!
tcw
 
Posts: 2
Joined: 17. Apr 2021, 08:04

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby TheQL » 20. Apr 2021, 10:42

Glad it worked! The solution is pretty much explained in detail somewhere, but is somewhat getting lost in the conversation around it ;)
TheQL
 
Posts: 15
Joined: 4. Nov 2020, 22:27

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby 2Bornot2B » 27. Apr 2021, 12:59

Hi,

i have a similar problem, after upgrade to MacOS Big Sur Virtual Box can no longer start existing VMs.

Error-Message: Kernel driver not installed (rc=-1908)
Make sure the kernel module has been loaded successfully.
where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

macOS: 11.2.3
VirtualBox: 6.1.20 r143896

The "Allow" Button on System Preferences -> Security & Privacy -> General never shows up.
The installation succeeds without any errors, no errors in the installation log too.

Tried to fix the permissions with

# chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement
# chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement/Staging

and

# kextcache --clear-staging

in recovery mode - no success. Any help or suggestions are highly appreciated.
2Bornot2B
 
Posts: 2
Joined: 27. Apr 2021, 10:44

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby VirtualJan » 10. May 2021, 23:40

2Bornot2B wrote:i have a similar problem, after upgrade to MacOS Big Sur Virtual Box can no longer start existing VMs.

Same here. I will just follow the topic to see if anyone has tips.
VirtualJan
 
Posts: 5
Joined: 5. May 2021, 20:48

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby Bujji » 28. May 2021, 15:19

Hi,

My Mac OS version --> Bis Sur 11.4

I had installed Oracle VirtualBox Version 6.1.22 r144080 (Qt5.6.3) but still unable to create/run any VM...

when I'm trying to run any VM I'm got this error

Kernel driver not installed (rc=-1908)

Make sure the kernel module has been loaded successfully.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

any help pls
Bujji
 
Posts: 1
Joined: 28. May 2021, 14:40

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby gillem » 2. Jun 2021, 00:31

I hope this can help someone.
MacOS 11.4, after upgrading from 6.1.18 to 6.1.22, i received the "rc-1908" error. I could launch VirtualBox, but could not launch my virtual machine (Windows 10).
I tried to restore 6.1.18, and its Virtual Machines using Time Machine. No luck
I restored the computer using Time Machine. This installed 6.1.18, but unfortunately, what used to work now had the rc=1908 message.

The next thing I did solved the issue, I wish I had known, done that before wasting half a day.
I went to Systems Preferences/Security and Privacy/General:
In the section "Allow apps downloaded from:" (I have it set to App Store and identified developers) there was a message to the effect that Oracle extensions had to be updated, and the change required a restart. I agreed to that and after the restart, my virtual machine launched again.
I might try ro re-install 6.1.22, but that will be in a few days.
gillem
 
Posts: 1
Joined: 2. Jun 2021, 00:22

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby ptram » 2. Jun 2021, 03:31

TheQL wrote:In the end I could fix it by running the following from the rescue environment after unlocking "Macintosh HD"
Code: Select all   Expand viewCollapse view
# chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement
# chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement/Staging



This worked for me, too! Thank you very much! You saved me another OS reinstall!

Another things I tried successfully was to manually trash the full "/Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement" folder. The system immediately recreated it, this time with the right "restricted" flag.

To empty the Recycle bin I had then to reboot in Recovery mode (Cmd-R), go to the Terminal, type "csrutil disable" and "reboot". When the Finder reappeared, I emptied the bin. Then restarted again in Recovery mode, go to the Terminal, type "csrutil enable" and "reboot".

All done!

Paolo
ptram
 
Posts: 75
Joined: 10. Dec 2008, 18:58

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby petersarum » 10. Jun 2021, 08:17

Same problem as being discussed above with VB no longer working because of the RC=-1908 error.
Using OSX Mojave 10.14.6 and have been trying to follow the "chflags" instructions in Recovery Mode.
But when in Disk Utility in Recovery I see no choice offered to unlock the volume? What am I doing wrong?
petersarum
 
Posts: 3
Joined: 10. Jun 2021, 08:13


Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby petersarum » 10. Jun 2021, 21:27

Thank you, will try that.
petersarum
 
Posts: 3
Joined: 10. Jun 2021, 08:13

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby petersarum » 11. Jun 2021, 16:17

For info in case it helps anyone else (OSX Mojave 14.6), this has worked for me - - -

As per ptram's comment and suggestion 2 June - I trashed the full "/Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement" folder, and the system immediately recreated it, this time with the right "restricted" flag.

Thanks!
petersarum
 
Posts: 3
Joined: 10. Jun 2021, 08:13

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby TheQL » 11. Jun 2021, 16:55

Right, but then you still need to jump through hoops to empty the trash ;)
TheQL
 
Posts: 15
Joined: 4. Nov 2020, 22:27

Previous

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: granada29 and 15 guests