Page 8 of 10

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 2. Oct 2019, 13:26
by THH
Hi! Haven´t been problems reported since some time so I assume for most this problem is fixed with the solutions presented is this thread. Unfortunately, I got this problem some days ago when I updated my High Sierra to version 10.13.6 (17G8037 running on a Mac Mini/late 2012). I got the -1908 error when trying to start my guest. After reading a bit I did everything suggested in this thread but without any success. The only thing that helps is to disable SIP. Then the guest runs even though the preceding installation of VB 6.0.12-133076 failed when the SIP still was enabled. I also don´t get any message on “System Preferences » Security » General”, i.e. not only the “allow” box is missing but there never comes any message at all (and I tried uninstall and reboot several times). Also, the “add VB5E2TV963” does not have any effect on my system.
Any more suggestions? Thank you.

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 3. Oct 2019, 15:56
by THH
Update: I re-installed MacOS from recovery and now everything works fine. The system version is now 17G65 (different from before). Not sure if this makes a difference or if there was something corrupt that has been repaired by the re-install...

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 3. Oct 2019, 16:12
by fth0
Just FYI:

macOS 10.13.6 (17G65) is the first 10.13.6 version without the security updates.
macOS 10.13.6 (17G8037) is the current 10.13.6 version with all security updates (up to Security Update 2019-005).

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 3. Oct 2019, 16:17
by THH
OK, thanks. When searching for updates I noticed that the recent update came up again. Will clone the system, update and check if the problem comes up again.

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 3. Oct 2019, 18:03
by socratis
THH wrote:Update: I re-installed MacOS from recovery and now everything works fine
Phew... because I couldn't find anything that I could think of as a known culprit. The only thing I found from your logs, and which I'm putting here for reference, was:
Oct  2 11:57:43 jor-1409 installd[498]: ./postflight: /Library/Application
Support/VirtualBox/VBoxUSB.kext failed to load - (libkern/kext)
dependency load failed; check the system/kernel logs for errors or try
kextutil(8).

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 8. Oct 2019, 18:53
by THH
Update 2: After updating the re-install everything still works fine. So it was fortunately just a corrupt update. Sorry for bothering you...

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 8. Oct 2019, 20:42
by socratis
THH wrote:Sorry for bothering you...
Not at all 'THH', thanks for reporting back, much appreciated! 8)

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 20. Oct 2019, 23:48
by Vascular Microchip
Can anyone help me ? I cannot load linux on my macbook.

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 30. Oct 2019, 11:51
by bucknaked
Anyone having the same issue, try this, in Terminal run:
Code: Select all   Expand viewCollapse view
sudo kextcache --clear-staging

That's it! Try install it again and it shouldn't fail.

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 30. Oct 2019, 12:44
by socratis
Vascular Microchip wrote:Can anyone help me ? I cannot load linux on my macbook.

With that amount of information that you've given us, no, there's nobody going to be able to help you. Unless you start talking specifics, your plea for help will most probably remain unanswered. I know at least I can't answer that...

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 15. Nov 2019, 17:39
by Jörn Dinkla
I had the same issue on macOS Catalina, 10.15.1.

First the installation did not finish successfully without giving an explicit cause. "sudo /Library/Application\ Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh restart" then revealed that a "system policy prevents loading".

And finally "spctl kext-consent add VB5E2TV963" in Restore mode solved it!

Thanks!
All the best!

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

PostPosted: 15. Nov 2019, 22:21
by socratis
Jörn Dinkla wrote:And finally "spctl kext-consent add VB5E2TV963" in Restore mode solved it!

You could have always opted for the easier "System Preferences" » "Security" » "General", and "Allow Oracle" to install kernel extensions. Same idea, less ... hacking. ;)

VirtualBox failed to install on Mac OS Catalina

PostPosted: 21. Nov 2019, 21:43
by psych
Hi there,

I am trying to download VirtualBox(version 6.0.14) for a 2014 iMac with macOS Catalina(10.15.1) installed. After opening the 'VirtualBox-6.0.14-133895-OSX.dmg' file and double clicking on the 'VirtualBox.pkg' Icon to Install the software, I keep getting a message stating:
The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.

Does anyone else have this issue? I have attached a log file with the error for convenience.

Additionally, despite the installation fail, I am able to open the VirtualBox app. I have attempted to create a virtual Windows 10 machine, however, when I attempt to start it, I get an error message stating:

(Dialog box 1)
Failed to open a session for the virtual machine windows

The virtual machine 'windows' has terminated unexpectedly during startup with exit code 1 (0x1).
Result Code: 'NS_ERROR_FAILURE (0x80004005)
Component: 'MachineWrap'
Interface: 'IMachine {5047460a-265d-4538-b23e-ddba5fb84976}

(Dialog Box 2)
Kernel driver not installed (rc=-1908)
Make sure the kernel module has been loaded successfully.
where: 'suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.'

I don't know if anyone will have an answer to this, but I hope that at least this can help the developers with these issues. :)

Re: VirtualBox failed to install on Mac OS Catalina

PostPosted: 21. Nov 2019, 23:11
by psych
Forgot to add the crash report from when I tried to run the Windows Virtual Machine, which I have attached here.

Re: VirtualBox failed to install on Mac OS Catalina

PostPosted: 22. Nov 2019, 00:59
by svenyonson
I am having the exact same error, same situation, fresh install of Catalina 10.15.1