Installation fails on 10.13.x, 10.14.x (rc=-1908)

Discussions related to using VirtualBox on Mac OS X hosts.

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby THH » 2. Oct 2019, 13:26

Hi! Haven´t been problems reported since some time so I assume for most this problem is fixed with the solutions presented is this thread. Unfortunately, I got this problem some days ago when I updated my High Sierra to version 10.13.6 (17G8037 running on a Mac Mini/late 2012). I got the -1908 error when trying to start my guest. After reading a bit I did everything suggested in this thread but without any success. The only thing that helps is to disable SIP. Then the guest runs even though the preceding installation of VB 6.0.12-133076 failed when the SIP still was enabled. I also don´t get any message on “System Preferences » Security » General”, i.e. not only the “allow” box is missing but there never comes any message at all (and I tried uninstall and reboot several times). Also, the “add VB5E2TV963” does not have any effect on my system.
Any more suggestions? Thank you.
Attachments
Installationsprotokoll 2-Oct-2019.txt.zip
Installation log
(3.23 KiB) Downloaded 7 times
THH
 
Posts: 4
Joined: 2. Oct 2019, 13:19
Location: Norway
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win 10

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby THH » 3. Oct 2019, 15:56

Update: I re-installed MacOS from recovery and now everything works fine. The system version is now 17G65 (different from before). Not sure if this makes a difference or if there was something corrupt that has been repaired by the re-install...
THH
 
Posts: 4
Joined: 2. Oct 2019, 13:19
Location: Norway
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win 10

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby fth0 » 3. Oct 2019, 16:12

Just FYI:

macOS 10.13.6 (17G65) is the first 10.13.6 version without the security updates.
macOS 10.13.6 (17G8037) is the current 10.13.6 version with all security updates (up to Security Update 2019-005).
fth0
Volunteer
 
Posts: 256
Joined: 14. Feb 2019, 03:06
Location: Germany
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux, Windows 10, macOS, ...

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby THH » 3. Oct 2019, 16:17

OK, thanks. When searching for updates I noticed that the recent update came up again. Will clone the system, update and check if the problem comes up again.
THH
 
Posts: 4
Joined: 2. Oct 2019, 13:19
Location: Norway
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win 10

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 3. Oct 2019, 18:03

THH wrote:Update: I re-installed MacOS from recovery and now everything works fine
Phew... because I couldn't find anything that I could think of as a known culprit. The only thing I found from your logs, and which I'm putting here for reference, was:
Oct  2 11:57:43 jor-1409 installd[498]: ./postflight: /Library/Application
Support/VirtualBox/VBoxUSB.kext failed to load - (libkern/kext)
dependency load failed; check the system/kernel logs for errors or try
kextutil(8).
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26901
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby THH » 8. Oct 2019, 18:53

Update 2: After updating the re-install everything still works fine. So it was fortunately just a corrupt update. Sorry for bothering you...
THH
 
Posts: 4
Joined: 2. Oct 2019, 13:19
Location: Norway
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win 10

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 8. Oct 2019, 20:42

THH wrote:Sorry for bothering you...
Not at all 'THH', thanks for reporting back, much appreciated! 8)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26901
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby Vascular Microchip » 20. Oct 2019, 23:48

Can anyone help me ? I cannot load linux on my macbook.
Vascular Microchip
 
Posts: 1
Joined: 20. Oct 2019, 23:36

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby bucknaked » 30. Oct 2019, 11:51

Anyone having the same issue, try this, in Terminal run:
Code: Select all   Expand viewCollapse view
sudo kextcache --clear-staging

That's it! Try install it again and it shouldn't fail.
bucknaked
 
Posts: 9
Joined: 30. Oct 2019, 08:29
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: None

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 30. Oct 2019, 12:44

Vascular Microchip wrote:Can anyone help me ? I cannot load linux on my macbook.

With that amount of information that you've given us, no, there's nobody going to be able to help you. Unless you start talking specifics, your plea for help will most probably remain unanswered. I know at least I can't answer that...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26901
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby Jörn Dinkla » 15. Nov 2019, 17:39

I had the same issue on macOS Catalina, 10.15.1.

First the installation did not finish successfully without giving an explicit cause. "sudo /Library/Application\ Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh restart" then revealed that a "system policy prevents loading".

And finally "spctl kext-consent add VB5E2TV963" in Restore mode solved it!

Thanks!
All the best!
Jörn Dinkla
 
Posts: 1
Joined: 15. Nov 2019, 17:35

Re: Installation fails on 10.13.x, 10.14.x (rc=-1908)

Postby socratis » 15. Nov 2019, 22:21

Jörn Dinkla wrote:And finally "spctl kext-consent add VB5E2TV963" in Restore mode solved it!

You could have always opted for the easier "System Preferences" » "Security" » "General", and "Allow Oracle" to install kernel extensions. Same idea, less ... hacking. ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26901
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Previous

Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: towo2099 and 21 guests